summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-02-07 23:49:38 +0100
committerMichael Weber <xmw@gentoo.org>2017-02-07 23:50:26 +0100
commit0223e6611c47e1fba279c7db5a7a217123e55dca (patch)
treecec14efbbe5218f864a1d25e8c465b18785fb532 /sci-electronics/osqoop/osqoop-1.1.1.ebuild
parentprofiles: Mask USE=ayatana on mips (diff)
downloadgentoo-0223e6611c47e1fba279c7db5a7a217123e55dca.tar.gz
gentoo-0223e6611c47e1fba279c7db5a7a217123e55dca.tar.bz2
gentoo-0223e6611c47e1fba279c7db5a7a217123e55dca.zip
sci-electronics/osqoop: EAPI=6, call cmake-utils_src_prepare (thanks johu).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-electronics/osqoop/osqoop-1.1.1.ebuild')
-rw-r--r--sci-electronics/osqoop/osqoop-1.1.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sci-electronics/osqoop/osqoop-1.1.1.ebuild b/sci-electronics/osqoop/osqoop-1.1.1.ebuild
index 3e01da3a58d7..4d309cd97345 100644
--- a/sci-electronics/osqoop/osqoop-1.1.1.ebuild
+++ b/sci-electronics/osqoop/osqoop-1.1.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils toolchain-funcs
@@ -22,6 +22,8 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}-${PN}
src_prepare() {
+ cmake-utils_src_prepare
+
for f in $(find datasource processing -name CMakeLists.txt); do
sed -e '/install(TARGETS/s:DESTINATION :DESTINATION '$(get_libdir)/${PN}'/:' \
-i "${f}" || die