summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/pcb/pcb-20140316.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/pcb/pcb-20140316.ebuild')
-rw-r--r--sci-electronics/pcb/pcb-20140316.ebuild149
1 files changed, 149 insertions, 0 deletions
diff --git a/sci-electronics/pcb/pcb-20140316.ebuild b/sci-electronics/pcb/pcb-20140316.ebuild
new file mode 100644
index 000000000000..d47a24357903
--- /dev/null
+++ b/sci-electronics/pcb/pcb-20140316.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools eutils fdo-mime gnome2-utils toolchain-funcs
+
+DESCRIPTION="GPL Electronic Design Automation: Printed Circuit Board editor"
+HOMEPAGE="http://www.gpleda.org/"
+SRC_URI="mirror://sourceforge/pcb/pcb/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-macos"
+IUSE="dbus debug doc gcode gif gtk jpeg m4lib-png motif nelma opengl png
+test tk toporouter xrender"
+# toporouter-output USE flag removed, there seems to be no result
+
+CDEPEND="dev-libs/glib:2
+ gif? ( >=media-libs/gd-2.0.23 )
+ gtk? ( x11-libs/gtk+:2 x11-libs/pango
+ x11-libs/gtkglext
+ dbus? ( sys-apps/dbus ) )
+ jpeg? ( >=media-libs/gd-2.0.23[jpeg] )
+ motif? ( !gtk? (
+ >=x11-libs/motif-2.3:0
+ dbus? ( sys-apps/dbus )
+ xrender? ( >=x11-libs/libXrender-0.9 ) ) )
+ nelma? ( >=media-libs/gd-2.0.23 )
+ opengl? ( virtual/opengl )
+ gcode? ( >=media-libs/gd-2.0.23 )
+ virtual/libintl
+ png? ( >=media-libs/gd-2.0.23[png] )
+ m4lib-png? ( >=media-libs/gd-2.0.23[png] )
+ tk? ( >=dev-lang/tk-8 )"
+#toporouter-output? ( x11-libs/cairo )
+
+DEPEND="${CDEPEND}
+ test? (
+ || ( media-gfx/graphicsmagick[imagemagick] media-gfx/imagemagick )
+ sci-electronics/gerbv
+ )
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+RDEPEND="${CDEPEND}
+ sci-electronics/electronics-menu"
+
+DOCS="AUTHORS README NEWS ChangeLog"
+
+pkg_setup() {
+ if use gtk && use motif; then
+ elog "Can only build for GTK+ or Motif/Lesstif GUI. GTK+ has priority."
+ fi
+ if !(use gtk || use motif); then
+ elog "Building without GUI, make sure you know what you are doing."
+ fi
+ if use dbus && !(use gtk || use motif); then
+ elog "dbus needs GTK or Motif/Lesstif GUI. Try USE=-dbus or USE=gtk or USE=motif."
+ fi
+ if use opengl && !(use gtk); then
+ elog "GL drawing needs GTK"
+ fi
+ if (use gtk || (! use gtk && ! use motif)) && (use xrender); then
+ elog "The XRender extension is only usable with the Motif/Lesstif GUI."
+ fi
+}
+
+src_prepare() {
+ if use test; then
+ # adapt the list of tests to run according to USE flag settings
+ if ! use png; then
+ sed -i '/^hid_png/d' tests/tests.list || die
+ fi
+ if ! use gcode; then
+ sed -i '/^hid_gcode/d' tests/tests.list || die
+ fi
+ fi
+ # Backport from upstream
+ # http://git.geda-project.org/pcb/commit/?id=a34b40add60310a51780f359cc90d9c5ee75752c
+ # (do not install static GTS library)
+ sed -i -e 's/lib_LIBRARIES/noinst_LIBRARIES/' -e 's/include_HEADERS/noinst_HEADERS/' gts/Makefile.am || die
+
+ # fix bad syntax in Makefile.am and configure.ac before running eautoreconf
+ sed -i -e 's/:=/=/' Makefile.am || die
+ epatch "${FILESDIR}"/${PN}-20110918-fix-config.diff
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use gtk ; then
+ myconf="--with-gui=gtk $(use_enable dbus) $(use_enable opengl gl) --disable-xrender"
+ elif use motif ; then
+ myconf="--with-gui=lesstif $(use_enable dbus) $(use_enable xrender)"
+ else
+ myconf="--with-gui=batch --disable-xrender --disable-dbus"
+ fi
+
+ local exporters="bom gerber ps"
+ if (use png || use jpeg || use gif) ; then
+ exporters="${exporters} png"
+ fi
+ use nelma && exporters="${exporters} nelma"
+ use gcode && exporters="${exporters} gcode"
+ use tk || export WISH="${EPREFIX}/bin/true"
+
+ econf \
+ ${myconf} \
+ $(use_enable doc) \
+ $(use_enable gif) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable m4lib-png) \
+ $(use_enable toporouter) \
+ $(use_enable debug) \
+ --enable-nls \
+ --disable-toporouter-output \
+ --with-exporters="${exporters}" \
+ --disable-dependency-tracking \
+ --disable-rpath \
+ --disable-update-mime-database \
+ --disable-update-desktop-database \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+}
+# toporouter-output USE flag removed, there seems to be no result
+# $(use_enable toporouter-output) \
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}