summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/puff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/puff')
-rw-r--r--sci-electronics/puff/Manifest1
-rw-r--r--sci-electronics/puff/metadata.xml9
-rw-r--r--sci-electronics/puff/puff-20100127.ebuild49
3 files changed, 59 insertions, 0 deletions
diff --git a/sci-electronics/puff/Manifest b/sci-electronics/puff/Manifest
new file mode 100644
index 000000000000..d18765f728a5
--- /dev/null
+++ b/sci-electronics/puff/Manifest
@@ -0,0 +1 @@
+DIST puff-20100127.tgz 430028 SHA256 055b9831abda64d59fddc74bce0fa0b4a393101725ad06281002411f66dc6dbd SHA512 d39d74300a5f6d226dcd6147f3c63cf30396abd14d765b24b48dbd1956c81a10d4233c141789648423aa44631197e1ec160630f9b20b6ac5ae641ae67cdcb2da WHIRLPOOL e405377a63c1d33af188eafb6a902a18dd44c95f04d8ce1b9b2b27954cdca6776ce495fb49d10607e44ec85c23a6225e7719ef66c8aa4d302f7d9006f2655dc8
diff --git a/sci-electronics/puff/metadata.xml b/sci-electronics/puff/metadata.xml
new file mode 100644
index 000000000000..54e80a6841ab
--- /dev/null
+++ b/sci-electronics/puff/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-electronics</herd>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-electronics/puff/puff-20100127.ebuild b/sci-electronics/puff/puff-20100127.ebuild
new file mode 100644
index 000000000000..51c2138057bf
--- /dev/null
+++ b/sci-electronics/puff/puff-20100127.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit flag-o-matic multilib
+
+DESCRIPTION="microwave CAD software"
+HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/puff/"
+SRC_URI="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-lang/fpc
+ amd64? ( >=dev-lang/fpc-2.4.0 )"
+
+src_prepare() {
+ # fix lib path for X11 and dont ignore LDFLAGS
+ sed -i -e "s#lib\\\/#$(get_libdir)\\\/#" \
+ -e 's/CFLAGS/#CFLAGS/' \
+ -e 's/link.res pu/link.res $(LDFLAGS) pu/' Makefile || die
+}
+
+src_compile() {
+ LDFLAGS="$(raw-ldflags)"
+ emake -j1 || die
+}
+
+src_install() {
+ dobin puff || die
+
+ dodoc changelog.txt README.txt || die
+ newdoc "Puff Manual.pdf" Puff_Manual.pdf || die
+
+ insinto /usr/share/${PN}
+ doins setup.puf || die
+ doins -r orig_dev_and_puf_files || die
+}
+
+pkg_postinst() {
+ elog "You must copy /usr/share/${PN}/setup.puf into your working directory"
+ elog "before using the program."
+}