summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-11-25 13:41:50 +0300
committerSergey Popov <pinkbyte@gentoo.org>2015-11-25 13:41:50 +0300
commita503fd0a7546a2f471bacb57e784b63d336df281 (patch)
treea1b474130791e5992bbc65f10ff4aaac33f47697 /sci-electronics/pulseview/pulseview-0.2.0.ebuild
parentwww-misc/shellinabox: amd64 stable wrt bug #566718 (diff)
downloadgentoo-a503fd0a7546a2f471bacb57e784b63d336df281.tar.gz
gentoo-a503fd0a7546a2f471bacb57e784b63d336df281.tar.bz2
gentoo-a503fd0a7546a2f471bacb57e784b63d336df281.zip
sci-electronics/pulseview: add subslot to dev-libs/boost dependency, migrate to git-r3 eclass
Package-Manager: portage-2.2.23
Diffstat (limited to 'sci-electronics/pulseview/pulseview-0.2.0.ebuild')
-rw-r--r--sci-electronics/pulseview/pulseview-0.2.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/sci-electronics/pulseview/pulseview-0.2.0.ebuild b/sci-electronics/pulseview/pulseview-0.2.0.ebuild
deleted file mode 100644
index cf87801f711c..000000000000
--- a/sci-electronics/pulseview/pulseview-0.2.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python3_{3,4} )
-inherit eutils cmake-utils python-single-r1
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="git://sigrok.org/${PN}"
- inherit git-2
-else
- SRC_URI="http://sigrok.org/download/source/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="Qt based logic analyzer GUI for sigrok"
-HOMEPAGE="http://sigrok.org/wiki/PulseView"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+decode static"
-REQUIRED_USE="decode? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=dev-libs/glib-2.28.0
- >=sci-libs/libsigrok-0.3.0
- dev-qt/qtgui:4
- >=dev-libs/boost-1.42
- decode? (
- >=sci-libs/libsigrokdecode-0.3.0
- ${PYTHON_DEPS}
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( HACKING NEWS README )
-
-src_configure() {
- local mycmakeargs=(
- -DDISABLE_WERROR=TRUE
- $(cmake-utils_use_enable decode DECODE)
- $(cmake-utils_use_enable static STATIC_PKGDEPS_LIBS)
- )
- cmake-utils_src_configure
-}