summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-03 00:33:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-06 20:15:25 +0200
commitf97cf58b9f21dd5955964fadee9c1592bebf5d28 (patch)
treed48b2d8b65daab1485c4975891874ab805ab9aa9 /sci-electronics/pulseview
parentsci-libs/libsigrokdecode: python3_8, python3_9 (diff)
downloadgentoo-f97cf58b9f21dd5955964fadee9c1592bebf5d28.tar.gz
gentoo-f97cf58b9f21dd5955964fadee9c1592bebf5d28.tar.bz2
gentoo-f97cf58b9f21dd5955964fadee9c1592bebf5d28.zip
sci-electronics/pulseview: EAPI-7 bump, use cmake.eclass
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-electronics/pulseview')
-rw-r--r--sci-electronics/pulseview/pulseview-9999.ebuild31
1 files changed, 17 insertions, 14 deletions
diff --git a/sci-electronics/pulseview/pulseview-9999.ebuild b/sci-electronics/pulseview/pulseview-9999.ebuild
index 570474071f06..58e35968ffd6 100644
--- a/sci-electronics/pulseview/pulseview-9999.ebuild
+++ b/sci-electronics/pulseview/pulseview-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
-inherit cmake-utils gnome2-utils python-single-r1 xdg-utils
+inherit cmake python-single-r1 xdg-utils
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
inherit git-r3
else
@@ -23,21 +23,24 @@ SLOT="0"
IUSE="+decode static"
REQUIRED_USE="decode? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="
+BDEPEND="
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-cpp/glibmm-2.28.0:2
>=dev-libs/boost-1.55:=
>=dev-libs/glib-2.28.0:2
- >=dev-cpp/glibmm-2.28.0:2
- >=sci-libs/libsigrok-0.6.0:=[cxx]
dev-qt/qtcore:5
dev-qt/qtgui:5
- dev-qt/qtwidgets:5
dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ >=sci-libs/libsigrok-0.6.0:=[cxx]
decode? (
- >=sci-libs/libsigrokdecode-0.6.0:=[${PYTHON_SINGLE_USEDEP}]
${PYTHON_DEPS}
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ >=sci-libs/libsigrokdecode-0.6.0:=[${PYTHON_SINGLE_USEDEP}]
+ )
+"
+RDEPEND="${DEPEND}"
DOCS=( HACKING NEWS README )
@@ -47,15 +50,15 @@ src_configure() {
-DENABLE_DECODE=$(usex decode)
-DSTATIC_PKGDEPS_LIBS=$(usex static)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_desktop_database_update
}
pkg_postrm() {
- gnome2_icon_cache_update
+ xdg_icon_cache_update
xdg_desktop_database_update
}