summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-07-14 13:11:14 +0200
committerPacho Ramos <pacho@gentoo.org>2017-07-14 13:11:14 +0200
commit18dc6a2a1f1bef9bd29500c5ac672cc34c464dc5 (patch)
tree8e471f785bcc3b4f8397761c5d0fe49f25a6e719 /sci-electronics
parentRemove hardmasked packages (diff)
downloadgentoo-18dc6a2a1f1bef9bd29500c5ac672cc34c464dc5.tar.gz
gentoo-18dc6a2a1f1bef9bd29500c5ac672cc34c464dc5.tar.bz2
gentoo-18dc6a2a1f1bef9bd29500c5ac672cc34c464dc5.zip
Remove hardmasked packages
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/ghdl/Manifest2
-rw-r--r--sci-electronics/ghdl/files/ghdl-0.29-gcc.patch132
-rw-r--r--sci-electronics/ghdl/ghdl-0.29.ebuild77
-rw-r--r--sci-electronics/ghdl/metadata.xml13
4 files changed, 0 insertions, 224 deletions
diff --git a/sci-electronics/ghdl/Manifest b/sci-electronics/ghdl/Manifest
deleted file mode 100644
index b00d1d7ce30d..000000000000
--- a/sci-electronics/ghdl/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST gcc-core-4.3.4.tar.bz2 24329359 SHA256 3189838f5047be4ff54711c84db17c76ecfcc79bf4f4d110bf7323eeb90568fa SHA512 03282633d5dcfee2b474b6d0ed2bfc708611a2049f4f4abf85c371ae04c2060a97a01380c77ef2e88b4e6f7eff5c368d1031737f4eab9f537dc1ed61430f0cf1 WHIRLPOOL 18b7202c67b6c10696c2f399741683f3b6a5805a55fd8a20240e309e0bb2e4311bb00cd4a7b72dcb3e1e38a192ae70399b92e66b97486bb2584a5f0595270dc5
-DIST ghdl-0.29.tar.bz2 784389 SHA256 6a4b01e14fae83b336ed33e8d92e0673a5999963ff569528e592721ab28db496 SHA512 6e86013d3798c875b8fbb67b64c9b0cdda89c878985b64a1ea2d0e04e0c3ae714799a4ffe050f3651f7df8078b791d8613733065c799261f28884103c1597210 WHIRLPOOL 381ca0e2a32bba2595f7a4317c847f9b09f4129bd72b5d265da33acf458e52aefc6d9a9ba9532940a15f587d2adc8c294b302ac4d45e92e3b56575e164bbe668
diff --git a/sci-electronics/ghdl/files/ghdl-0.29-gcc.patch b/sci-electronics/ghdl/files/ghdl-0.29-gcc.patch
deleted file mode 100644
index b819371ca510..000000000000
--- a/sci-electronics/ghdl/files/ghdl-0.29-gcc.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-diff --git a/gcc/config/alpha/linux-unwind.h b/gcc/config/alpha/linux-unwind.h
-index 23151ad..1b2d9d0 100644
---- a/gcc/config/alpha/linux-unwind.h
-+++ b/gcc/config/alpha/linux-unwind.h
-@@ -52,7 +52,7 @@ alpha_fallback_frame_state (struct _Unwind_Context *context,
- else if (pc[1] == 0x201f015f) /* lda $0,NR_rt_sigreturn */
- {
- struct rt_sigframe {
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_ = context->cfa;
- sc = &rt_->uc.uc_mcontext;
-diff --git a/gcc/config/bfin/linux-unwind.h b/gcc/config/bfin/linux-unwind.h
-index c369711..90c91a3 100644
---- a/gcc/config/bfin/linux-unwind.h
-+++ b/gcc/config/bfin/linux-unwind.h
-@@ -52,10 +52,10 @@ bfin_fallback_frame_state (struct _Unwind_Context *context,
- {
- struct rt_sigframe {
- int sig;
-- struct siginfo *pinfo;
-+ siginfo_t *pinfo;
- void *puc;
- char retcode[8];
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_ = context->cfa;
-
-diff --git a/gcc/config/i386/linux-unwind.h b/gcc/config/i386/linux-unwind.h
-index 58eb733..9808925 100644
---- a/gcc/config/i386/linux-unwind.h
-+++ b/gcc/config/i386/linux-unwind.h
-@@ -137,9 +137,9 @@ x86_fallback_frame_state (struct _Unwind_Context *context,
- {
- struct rt_sigframe {
- int sig;
-- struct siginfo *pinfo;
-+ siginfo_t *pinfo;
- void *puc;
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_ = context->cfa;
- /* The void * cast is necessary to avoid an aliasing warning.
-diff --git a/gcc/config/ia64/linux-unwind.h b/gcc/config/ia64/linux-unwind.h
-index 8b2878e..bbc77e6 100644
---- a/gcc/config/ia64/linux-unwind.h
-+++ b/gcc/config/ia64/linux-unwind.h
-@@ -51,7 +51,7 @@ ia64_fallback_frame_state (struct _Unwind_Context *context,
- struct sigframe {
- char scratch[16];
- unsigned long sig_number;
-- struct siginfo *info;
-+ siginfo_t *info;
- struct sigcontext *sc;
- } *frame_ = (struct sigframe *)context->psp;
- struct sigcontext *sc = frame_->sc;
-@@ -130,7 +130,7 @@ ia64_handle_unwabi (struct _Unwind_Context *context, _Unwind_FrameState *fs)
- struct sigframe {
- char scratch[16];
- unsigned long sig_number;
-- struct siginfo *info;
-+ siginfo_t *info;
- struct sigcontext *sc;
- } *frame = (struct sigframe *)context->psp;
- struct sigcontext *sc = frame->sc;
-diff --git a/gcc/config/mips/linux-unwind.h b/gcc/config/mips/linux-unwind.h
-index 4e71182..86d4711 100644
---- a/gcc/config/mips/linux-unwind.h
-+++ b/gcc/config/mips/linux-unwind.h
-@@ -79,7 +79,7 @@ mips_fallback_frame_state (struct _Unwind_Context *context,
- struct rt_sigframe {
- u_int32_t ass[4]; /* Argument save space for o32. */
- u_int32_t trampoline[2];
-- struct siginfo info;
-+ siginfo_t info;
- _sig_ucontext_t uc;
- } *rt_ = context->cfa;
- sc = &rt_->uc.uc_mcontext;
-diff --git a/gcc/config/pa/linux-unwind.h b/gcc/config/pa/linux-unwind.h
-index 812561e..84ab137 100644
---- a/gcc/config/pa/linux-unwind.h
-+++ b/gcc/config/pa/linux-unwind.h
-@@ -66,7 +66,7 @@ pa32_fallback_frame_state (struct _Unwind_Context *context,
- int i;
- struct sigcontext *sc;
- struct rt_sigframe {
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *frame;
-
-diff --git a/gcc/config/sh/linux-unwind.h b/gcc/config/sh/linux-unwind.h
-index 3a3e9aa..7699729 100644
---- a/gcc/config/sh/linux-unwind.h
-+++ b/gcc/config/sh/linux-unwind.h
-@@ -80,9 +80,9 @@ shmedia_fallback_frame_state (struct _Unwind_Context *context,
- && (*(unsigned long *) (pc+11) == 0x6ff0fff0))
- {
- struct rt_sigframe {
-- struct siginfo *pinfo;
-+ siginfo_t *pinfo;
- void *puc;
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_ = context->cfa;
- /* The void * cast is necessary to avoid an aliasing warning.
-@@ -179,7 +179,7 @@ sh_fallback_frame_state (struct _Unwind_Context *context,
- && (*(unsigned short *) (pc+14) == 0x00ad))))
- {
- struct rt_sigframe {
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_ = context->cfa;
- /* The void * cast is necessary to avoid an aliasing warning.
-diff --git a/gcc/config/xtensa/linux-unwind.h b/gcc/config/xtensa/linux-unwind.h
-index 18daff2..2a5e4f8 100644
---- a/gcc/config/xtensa/linux-unwind.h
-+++ b/gcc/config/xtensa/linux-unwind.h
-@@ -66,7 +66,7 @@ xtensa_fallback_frame_state (struct _Unwind_Context *context,
- struct sigcontext *sc;
-
- struct rt_sigframe {
-- struct siginfo info;
-+ siginfo_t info;
- struct ucontext uc;
- } *rt_;
-
diff --git a/sci-electronics/ghdl/ghdl-0.29.ebuild b/sci-electronics/ghdl/ghdl-0.29.ebuild
deleted file mode 100644
index 64a4a0e12f1b..000000000000
--- a/sci-electronics/ghdl/ghdl-0.29.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="3"
-
-inherit eutils multilib
-
-GCC_VERSION="4.3.4"
-GNATGCC_SLOT="4.3"
-
-DESCRIPTION="Complete VHDL simulator using the GCC technology"
-HOMEPAGE="http://ghdl.free.fr"
-SRC_URI="http://ghdl.free.fr/${P}.tar.bz2
- mirror://gnu/gcc/releases/gcc-${GCC_VERSION}/gcc-core-${GCC_VERSION}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND="<sys-apps/texinfo-5.1
- dev-lang/gnat-gcc:${GNATGCC_SLOT}"
-RDEPEND=""
-S="${WORKDIR}/gcc-${GCC_VERSION}"
-
-ADA_INCLUDE_PATH="${ROOT}/usr/lib/gnat-gcc/${CHOST}/${GNATGCC_SLOT}/adainclude"
-ADA_OBJECTS_PATH="${ROOT}/usr/lib/gnat-gcc/${CHOST}/${GNATGCC_SLOT}/adalib"
-GNATGCC_PATH="${ROOT}/usr/${CHOST}/gnat-gcc-bin/${GNATGCC_SLOT}:${ROOT}/usr/libexec/gnat-gcc/${CHOST}/${GNATGCC_SLOT}"
-
-src_prepare() {
- mv "${WORKDIR}/${P}"/vhdl gcc
- sed -i -e 's/ADAC = \$(CC)/ADAC = gnatgcc/' gcc/vhdl/Makefile.in || die "sed failed"
- sed -i \
- -e 's/AGCC_CFLAGS=-g/AGCC_CFLAGS=$(CFLAGS)/' \
- -e 's/rm -rf $(infodir)/rm -rf $(DESTDIR)$(infodir)/' \
- gcc/vhdl/Make-lang.in || die "sed failed"
-
- # Fix issue similar to bug #195074, ported from vapier's fix for binutils
- sed -i -e "s:egrep.*texinfo.*dev/null:egrep 'texinfo[^0-9]*(4\.([4-9]|[1-9][0-9])|[5-9]|[1-9][0-9])' >/dev/null:" \
- configure* || die "sed failed"
-
- # For multilib profile arch, see bug #203721
- if (has_multilib_profile || use multilib ) ; then
- for T_LINUX64 in `find "${S}/gcc/config" -name t-linux64` ;
- do
- einfo "sed for ${T_LINUX64} for multilib. :)"
- sed -i \
- -e "s:\(MULTILIB_OSDIRNAMES = \).*:\1../lib64 ../lib32:" \
- "${T_LINUX64}" \
- || die "sed for ${T_LINUX64} failed. :("
- done
- fi
-
- # fix for bug #477552 backported from bug #424970
- epatch "${FILESDIR}"/${P}-gcc.patch
-}
-
-src_configure() {
- PATH="${GNATGCC_PATH}:${PATH}" econf --enable-languages=vhdl
-}
-
-src_compile() {
- PATH="${GNATGCC_PATH}:${PATH}" emake -j1 || die "Compilation failed"
-}
-
-src_install() {
- # bug #277644
- PATH="${GNATGCC_PATH}:${PATH}" emake -j1 DESTDIR="${D}" install || die "Installation failed"
-
- cd "${D}"/usr/bin ; rm `ls --ignore=ghdl`
- rm -rf "${D}"/usr/include
- rm "${D}"/usr/$(get_libdir)/lib*
- cd "${D}"/usr/$(get_libdir)/gcc/${CHOST}/${GCC_VERSION} ; rm -rf `ls --ignore=vhdl*`
- cd "${D}"/usr/libexec/gcc/${CHOST}/${GCC_VERSION} ; rm -rf `ls --ignore=ghdl*`
- cd "${D}"/usr/share/info ; rm `ls --ignore=ghdl*`
- cd "${D}"/usr/share/man/man1 ; rm `ls --ignore=ghdl*`
- rm -Rf "${D}"/usr/share/locale
- rm -Rf "${D}"/usr/share/man/man7
-}
diff --git a/sci-electronics/ghdl/metadata.xml b/sci-electronics/ghdl/metadata.xml
deleted file mode 100644
index 17b3ab25ae76..000000000000
--- a/sci-electronics/ghdl/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-electronics@gentoo.org</email>
- <name>Gentoo Electronics Project</name>
- </maintainer>
- <longdescription>
- A complete VHDL simulator, using the GCC technology. GHDL implements the VHDL
- language according to the IEEE 1076-1987 or the IEEE 1076-1993 standard. GHDL
- compiles VHDL files and creates a binary which simulates (or executes) your design.
- </longdescription>
-</pkgmetadata>