summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2022-10-18 14:19:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2022-10-18 15:16:30 +0200
commit3a9a3fc2e0bf1658377afb434a2f99d1312e867c (patch)
treed2f337b081058153857fa8094adb09d9724d0741 /sci-electronics
parentwww-client/firefox: add 106.0 (diff)
downloadgentoo-3a9a3fc2e0bf1658377afb434a2f99d1312e867c.tar.gz
gentoo-3a9a3fc2e0bf1658377afb434a2f99d1312e867c.tar.bz2
gentoo-3a9a3fc2e0bf1658377afb434a2f99d1312e867c.zip
sci-electronics/gazebo: bump to 11.12.0
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gazebo/Manifest1
-rw-r--r--sci-electronics/gazebo/gazebo-11.12.0.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/sci-electronics/gazebo/Manifest b/sci-electronics/gazebo/Manifest
index c0eac4fab473..51f9bccaff8e 100644
--- a/sci-electronics/gazebo/Manifest
+++ b/sci-electronics/gazebo/Manifest
@@ -1,2 +1,3 @@
DIST gazebo-11.10.2.tar.bz2 56496495 BLAKE2B 09bf370531214e9567d961445797cb50c9e5a81a405720c580d13e6b33029a63dd2cd9930dcbd239c1bf9091a9d5b092bfdef77b0b3524d281a10549e22e7c9a SHA512 8900c483f63cedb8543cfe718b336e3ec372fc0dc3d47ac9cd5378987fae634f16911d3c91fdf70add93b4a090e92f3558beec6c1277e1ba109652dcaf049ac2
DIST gazebo-11.11.0.tar.bz2 56505651 BLAKE2B c3f63a1ee128fd86be914ba9ad7567d0adf337d82772184bbc362373083ad2b79f1172998182a70faf4127fe6f5996d6946e79927c40a384ac5e0eef3b7799c9 SHA512 f9062a54ee4e252219a246124ad0a22570e12f34f7bced8910a14b96541b16337efbba0f824b0ba70adf91d41acfc407eb0cdb19bbd7272151ef9723acc48882
+DIST gazebo-11.12.0.tar.bz2 56542859 BLAKE2B f2da8371fa4655cc831401fcf6ceec8c82d507a93515762c078ac20a78cb4b739c9f373ef53bebc71b5d7e1c1cf4b98928b3e855fca6943a09da554ee19df1cb SHA512 8f60d432ab07084951bbe31c632f04f2fa11500441fb81fe27078a5cb5b67ba681889e1079844d44a5a30df562797d51683fd674942db9fd8c4d853e3e2c5d3e
diff --git a/sci-electronics/gazebo/gazebo-11.12.0.ebuild b/sci-electronics/gazebo/gazebo-11.12.0.ebuild
new file mode 100644
index 000000000000..4eac05330fc9
--- /dev/null
+++ b/sci-electronics/gazebo/gazebo-11.12.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="https://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+# Subslot = major version = soname of libs
+SLOT="0/11"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/protobuf-2:=
+ virtual/opengl
+ media-libs/openal
+ net-misc/curl
+ dev-libs/tinyxml
+ >=dev-libs/tinyxml2-6:=
+ dev-libs/libtar
+ dev-cpp/tbb:=
+ >=dev-games/ogre-1.7.4:=[freeimage]
+ <dev-games/ogre-1.10
+ >=media-libs/freeimage-3.15.4[png]
+ sci-libs/libccd
+ >=media-video/ffmpeg-2.6:0=
+ sci-libs/gts
+ >=sci-physics/bullet-2.82:=
+ >=dev-libs/sdformat-9.8:=
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ dev-qt/qtopengl:5
+ dev-libs/boost:=
+ sci-libs/gdal:=
+ virtual/libusb:1
+ dev-libs/libspnav
+ media-libs/freeimage
+ sci-libs/hdf5:=[cxx]
+ sys-apps/util-linux
+ >=media-gfx/graphviz-4
+ net-libs/ignition-msgs:5=
+ sci-libs/ignition-math:6=
+ net-libs/ignition-transport:8=
+ sci-libs/ignition-common:3=
+ sci-libs/ignition-fuel-tools:4=
+ x11-libs/qwt:6=[qt5(+)]
+"
+DEPEND="${RDEPEND}
+ dev-qt/qttest:5
+ x11-apps/mesa-progs
+ test? ( dev-libs/libxslt )
+"
+BDEPEND="
+ || ( app-text/ronn-ng app-text/ronn )
+ app-arch/gzip
+ virtual/pkgconfig
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=(
+ "${FILESDIR}/qwt2.patch"
+ "${FILESDIR}/cmake.patch"
+)
+
+src_configure() {
+ # find OGRE properly
+ sed -e "s#lib/OGRE#$(get_libdir)/OGRE#" -i cmake/gazebo-config.cmake.in || die
+
+ local mycmakeargs=(
+ "-DUSE_UPSTREAM_CFLAGS=OFF"
+ "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+ "-DUSE_HOST_CFLAGS=FALSE"
+ "-DBUILD_TESTING=$(usex test TRUE FALSE)"
+ "-DENABLE_SCREEN_TESTS=FALSE"
+ "-DUSE_EXTERNAL_TINYXML2=TRUE"
+ )
+ cmake_src_configure
+}