summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 11:42:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 13:26:16 +0100
commit4a9f2a14d395df2c985f20d042376ec2379e9cf5 (patch)
tree9f9d5de74f134c928734d33f12b0202e75400358 /sci-electronics
parentsci-calculators/speedcrunch: Drop 0.12.0 (r0) (diff)
downloadgentoo-4a9f2a14d395df2c985f20d042376ec2379e9cf5.tar.gz
gentoo-4a9f2a14d395df2c985f20d042376ec2379e9cf5.tar.bz2
gentoo-4a9f2a14d395df2c985f20d042376ec2379e9cf5.zip
sci-electronics/osqoop: EAPI-7 bump, switch to cmake.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/osqoop/files/osqoop-1.2.0_pre20170131-cmake-add_library-static.patch11
-rw-r--r--sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild12
2 files changed, 20 insertions, 3 deletions
diff --git a/sci-electronics/osqoop/files/osqoop-1.2.0_pre20170131-cmake-add_library-static.patch b/sci-electronics/osqoop/files/osqoop-1.2.0_pre20170131-cmake-add_library-static.patch
new file mode 100644
index 000000000000..8b315cf0c0f1
--- /dev/null
+++ b/sci-electronics/osqoop/files/osqoop-1.2.0_pre20170131-cmake-add_library-static.patch
@@ -0,0 +1,11 @@
+--- a/processing/lib/CMakeLists.txt 2017-02-12 19:13:31.000000000 +0100
++++ b/processing/lib/CMakeLists.txt 2021-02-28 11:30:50.812028355 +0100
+@@ -4,7 +4,7 @@
+ FeedForwardNeuralNetwork.cpp
+ )
+ include_directories (${CMAKE_BINARY_DIR}/processing/lib)
+-add_library(processing ${processing_SRCS})
++add_library(processing STATIC ${processing_SRCS})
+ target_link_libraries(processing Qt5::Core)
+ if (CMAKE_COMPILER_IS_GNUCC)
+ set_target_properties(processing PROPERTIES COMPILE_FLAGS "-fPIC")
diff --git a/sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild b/sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild
index 9bac71de0ad4..9e14ed9013bb 100644
--- a/sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild
+++ b/sci-electronics/osqoop/osqoop-1.2.0_pre20170131.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
COMMIT=b5bd459dd5c2a180a9a3e5a706ed5039159d7286
-inherit cmake-utils vcs-snapshot
+inherit cmake
DESCRIPTION="Multi-platform open source software oscilloscope based on Qt"
HOMEPAGE="https://github.com/stephanemagnenat/osqoop https://github.com/sandsmark/osqoop"
# sandsmark/osqoop: PR-branch on top of last commit in stephanemagnenat/osqoop (17-01-31)
SRC_URI="https://github.com/sandsmark/osqoop/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="GPL-2"
SLOT="0"
@@ -25,3 +26,8 @@ RDEPEND="
virtual/libusb:0
x11-libs/libXtst"
DEPEND="${RDEPEND}"
+
+# downstream fix for BUILD_SHARED_LIBS=ON default
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake-add_library-static.patch
+)