summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-16 12:42:52 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-16 12:43:25 +0100
commit6e15026fdfb8b292f9aef2dedc78565644ada767 (patch)
treef63bbe8523fc92048ebd7cd8e91d5d978ed2f506 /sci-electronics
parentapp-emacs/markdown-mode: Add test dependency on English dictionary (diff)
downloadgentoo-6e15026fdfb8b292f9aef2dedc78565644ada767.tar.gz
gentoo-6e15026fdfb8b292f9aef2dedc78565644ada767.tar.bz2
gentoo-6e15026fdfb8b292f9aef2dedc78565644ada767.zip
sci-electronics/eagle: drop bundled ngspice et al
Closes: https://bugs.gentoo.org/833350 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/eagle/eagle-9.6.2-r2.ebuild (renamed from sci-electronics/eagle/eagle-9.6.2-r1.ebuild)24
1 files changed, 21 insertions, 3 deletions
diff --git a/sci-electronics/eagle/eagle-9.6.2-r1.ebuild b/sci-electronics/eagle/eagle-9.6.2-r2.ebuild
index 187342bbece5..df1ec6a67641 100644
--- a/sci-electronics/eagle/eagle-9.6.2-r1.ebuild
+++ b/sci-electronics/eagle/eagle-9.6.2-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit desktop xdg
+inherit desktop optfeature xdg
DESCRIPTION="Autodesk EAGLE schematic and printed circuit board (PCB) layout editor"
HOMEPAGE="https://www.autodesk.com/"
@@ -63,11 +63,23 @@ RDEPEND="
x11-libs/libXtst
"
+src_prepare() {
+ default
+ # drop bundled ngpsice
+ rm -r ngspice || die
+ # drop bundled qt and other libs
+ rm qt.conf || die
+ rm -r resources plugins libexec || die
+ # this libSuits.so(?) is not packaged anywhere in Gentoo so we keep it
+ mv lib lib.back || die
+ mkdir lib || die
+ mv lib.back/libSuits.so lib/ || die
+ rm -r lib.back || die
+}
+
src_install() {
dodoc doc/*.txt doc/*.pdf doc/ulp/*.pdf
doman doc/eagle.1
- dodoc ngspice/*.txt ngspice/*.pdf
- doman ngspice/share/man/man1/*
dodir /opt/${PN}
# copy everything in
@@ -80,3 +92,9 @@ src_install() {
doicon -s 128x128 bin/${PN}-logo.png
make_desktop_entry ${PN} "CadSoft EAGLE Layout Editor" ${PN}-logo "Graphics;Electronics"
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature 'SPICE circuit simulation support (set "Simulator Path" in Options -> Directories)' sci-electronics/ngspice
+}