summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/bt747
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/bt747')
-rw-r--r--sci-geosciences/bt747/Manifest1
-rw-r--r--sci-geosciences/bt747/bt747-2.0.3.ebuild63
-rw-r--r--sci-geosciences/bt747/metadata.xml18
3 files changed, 82 insertions, 0 deletions
diff --git a/sci-geosciences/bt747/Manifest b/sci-geosciences/bt747/Manifest
new file mode 100644
index 000000000000..d09cb2f91067
--- /dev/null
+++ b/sci-geosciences/bt747/Manifest
@@ -0,0 +1 @@
+DIST BT747_2.0.3_full.zip 10678027 SHA256 592544312e4d31826c419c051dd56b242faec7f0ca13e9da370140e123d29bb0
diff --git a/sci-geosciences/bt747/bt747-2.0.3.ebuild b/sci-geosciences/bt747/bt747-2.0.3.ebuild
new file mode 100644
index 000000000000..35a6302a423e
--- /dev/null
+++ b/sci-geosciences/bt747/bt747-2.0.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WANT_ANT_TASKS="ant-nodeps"
+
+inherit java-utils-2 java-pkg-2 java-ant-2
+
+MY_PN=BT747
+MY_P=${MY_PN}_${PV}
+
+DESCRIPTION="MTK GPS Datalogger Device Control"
+HOMEPAGE="http://bt747.free.fr/"
+SRC_URI="mirror://sourceforge/${PN}/BT747_${PV}_full.zip"
+
+LICENSE="GPL-3"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="
+ >=dev-java/rxtx-2.2_pre2
+ dev-java/swing-layout:1
+ dev-java/jcalendar:1.2
+ dev-java/jcharts
+"
+RDEPEND="${COMMON_DEP}
+ dev-libs/glib:2[dbus]
+ >=virtual/jre-1.5
+"
+DEPEND="${COMMON_DEP}
+ >=virtual/jdk-1.5
+ app-arch/unzip
+"
+
+EANT_BUILD_TARGET="dist.j2se"
+EANT_EXTRA_ARGS="-Dskip.proguard=yes
+ -Drxtxcomm.jar=lib/RXTXcomm.jar
+ -Dswing-layout.jar=lib/swing-layout.jar
+ -Djcalendar.jar=lib/jcalendar.jar"
+
+S="${WORKDIR}"
+
+java_prepare() {
+ rm -rf dist
+ cd lib
+ rm -rf r* W* c* swing-* w* jca*
+ java-pkg_jar-from rxtx-2
+ java-pkg_jar-from swing-layout-1
+ java-pkg_jar-from jcalendar-1.2
+}
+
+src_install() {
+ dodoc ChangeLog.txt README.txt
+ java-pkg_dojar dist/*.jar
+ java-pkg_jarinto /opt/${PN}-${SLOT}/lib
+ java-pkg_newjar lib/jopt-simple-2.4.1.jar jopt-simple.jar
+ java-pkg_dojar lib/swingx*.jar
+ java-pkg_dolauncher ${PN} --main bt747.j2se_view.BT747Main \
+ --java-args="-Xmx192m"
+}
diff --git a/sci-geosciences/bt747/metadata.xml b/sci-geosciences/bt747/metadata.xml
new file mode 100644
index 000000000000..3bb1317da08e
--- /dev/null
+++ b/sci-geosciences/bt747/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+ <longdescription lang="en">
+BT747 is software that can:
+ * Download recorded position data from GPS Data Loggers based on the MTK chipset.
+ * Convert GPS position data in many formats (HTML, GPX, KML, KMZ, ...)
+ * Geotag JPG pictures and position any other filetype on the map (voice, documents, ...)
+ * Runs on Handheld Devices (Palm, WinCE, Mobile Phones supporting Java (J2ME))
+ * Runs on Desktops (Windows, MacOSX, Linux flavors)
+ * Configure MTK Chipset Based Devices and Loggers
+ * Upload AGPS(EPO) data to MTK II Chipset Based Devices and Loggers
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">bt747</remote-id>
+ </upstream>
+</pkgmetadata>