summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-17 05:25:34 +0100
committerSam James <sam@gentoo.org>2021-10-17 05:25:34 +0100
commite93640d6db2ef27849988cd5258eb4f3b1e8a67e (patch)
tree526f8fa9785c06e3b5faf37fc6ff600144e0979f /sci-geosciences/foxtrotgps
parentsci-geosciences/foxtrotgps: add another bug reference to patch (diff)
downloadgentoo-e93640d6db2ef27849988cd5258eb4f3b1e8a67e.tar.gz
gentoo-e93640d6db2ef27849988cd5258eb4f3b1e8a67e.tar.bz2
gentoo-e93640d6db2ef27849988cd5258eb4f3b1e8a67e.zip
sci-geosciences/foxtrotgps: fix patch for newer gpsd (again)
I don't think the API define got bumped in 3.23.1? Closes: https://bugs.gentoo.org/818268 Closes: https://bugs.gentoo.org/739568 Closes: https://bugs.gentoo.org/806986 Closes: https://bugs.gentoo.org/808883 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/foxtrotgps')
-rw-r--r--sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch2
-rw-r--r--sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch b/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch
index 84dffb11efc4..76d0c2d04a6d 100644
--- a/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch
+++ b/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch
@@ -29,7 +29,7 @@ index 602b06e..0baea81 100644
}
-#if GPSD_API_MAJOR_VERSION >= 9
- gpsdata->valid = (libgps_gpsdata.fix.status != STATUS_NO_FIX);
-+#if GPSD_API_MAJOR_VERSION >= 12
++#if GPSD_API_MAJOR_VERSION >= 12 && defined(STATUS_UNK)
+ gpsdata->valid = (libgps_gpsdata.fix.status != STATUS_UNK || libgps_gpsdata.fix.mode >= MODE_2D);
+#elif GPSD_API_MAJOR_VERSION >= 10
+ gpsdata->valid = (libgps_gpsdata.fix.status != STATUS_NO_FIX || libgps_gpsdata.fix.mode >= MODE_2D);
diff --git a/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild b/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
index 9810966d440d..cc36b1da8d8e 100644
--- a/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
+++ b/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
@@ -30,5 +30,5 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${P}-gpsd-api9.patch"
"${FILESDIR}/${P}-gcc10.patch"
- #"${FILESDIR}/${P}-fix-some-receivers.patch"
+ "${FILESDIR}/${P}-fix-some-receivers.patch"
)