summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-18 20:19:26 +0100
committerSam James <sam@gentoo.org>2021-08-18 20:22:53 +0100
commitfd0eed75afb8e3d5377b611d9efc76ae4c5ab0d1 (patch)
tree2531f26430541979c1076d6d7cd950a4f5f52563 /sci-geosciences/foxtrotgps
parentdev-libs/protobuf-c: add 1.4.0 (diff)
downloadgentoo-fd0eed75afb8e3d5377b611d9efc76ae4c5ab0d1.tar.gz
gentoo-fd0eed75afb8e3d5377b611d9efc76ae4c5ab0d1.tar.bz2
gentoo-fd0eed75afb8e3d5377b611d9efc76ae4c5ab0d1.zip
sci-geosciences/foxtrotgps: add upstream patch for some receivers
I've rebased the patch myself and added an extra API check to be conservative as the patch didn't apply cleanly to the tarball. Thanks-to: Maciej S. Szmigiero <mail@maciej.szmigiero.name> Closes: https://bugs.gentoo.org/808883 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/foxtrotgps')
-rw-r--r--sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch33
-rw-r--r--sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild34
2 files changed, 67 insertions, 0 deletions
diff --git a/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch b/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch
new file mode 100644
index 000000000000..23930212f31f
--- /dev/null
+++ b/sci-geosciences/foxtrotgps/files/foxtrotgps-1.2.2-fix-some-receivers.patch
@@ -0,0 +1,33 @@
+From ea27c684924b8d8a560ca6fe1f25443624d54a93 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 18 Aug 2021 20:18:03 +0100
+Subject: [PATCH] Fix some GPS receivers
+
+Rebased version of upstream patch:
+https://bazaar.launchpad.net/~foxtrotgps-team/foxtrotgps/trunk/revision/329
+
+Conservatively added an extra API version check for gpsd.
+
+Bug: https://bugs.gentoo.org/808883
+---
+ src/gps_functions.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/gps_functions.c b/src/gps_functions.c
+index 602b06e..4f30cbb 100644
+--- a/src/gps_functions.c
++++ b/src/gps_functions.c
+@@ -762,7 +762,9 @@ cb_gpsd_data(GIOChannel *src, GIOCondition condition, gpointer data)
+ {
+ gpsdata->fix.time = (time_t) 0;
+ }
+-#if GPSD_API_MAJOR_VERSION >= 9
++#if GPSD_API_MAJOR_VERSION >= 10
++ gpsdata->valid = (libgps_gpsdata.fix.status != STATUS_NO_FIX || libgps_gpsdata.fix.mode >= MODE_2D);
++#elif GPSD_API_MAJOR_VERSION >= 9
+ gpsdata->valid = (libgps_gpsdata.fix.status != STATUS_NO_FIX);
+ #else
+ gpsdata->valid = (libgps_gpsdata.status != STATUS_NO_FIX);
+--
+2.33.0
+
diff --git a/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild b/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..cc36b1da8d8e
--- /dev/null
+++ b/sci-geosciences/foxtrotgps/foxtrotgps-1.2.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="Easy to use, fast and lightweight mapping application (fork of tangogps)"
+HOMEPAGE="https://www.foxtrotgps.org/"
+SRC_URI="https://www.foxtrotgps.org/releases/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ gnome-base/libglade
+ media-libs/libexif
+ net-misc/curl
+ >=sci-geosciences/gpsd-2.90:=
+ sys-apps/dbus
+ x11-libs/gtk+:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gpsd-api9.patch"
+ "${FILESDIR}/${P}-gcc10.patch"
+ "${FILESDIR}/${P}-fix-some-receivers.patch"
+)