summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2015-12-26 23:14:41 +0100
committerAmy Winston <amynka@gentoo.org>2015-12-26 23:29:39 +0100
commite2c276c3de2111874a92d3f321263a218d809209 (patch)
tree5be8eab36aea5e57804206babd1ea4f5c72c7b2d /sci-geosciences/gdal-grass/gdal-grass-2.0.0-r1.ebuild
parentdev-perl/AppConfig: stable for all wrt bug #569862 (diff)
downloadgentoo-e2c276c3de2111874a92d3f321263a218d809209.tar.gz
gentoo-e2c276c3de2111874a92d3f321263a218d809209.tar.bz2
gentoo-e2c276c3de2111874a92d3f321263a218d809209.zip
sci-geosciences/gdal-grass: slot specification fixed bug #568414.By wraeth
Package-Manager: portage-2.2.24
Diffstat (limited to 'sci-geosciences/gdal-grass/gdal-grass-2.0.0-r1.ebuild')
-rw-r--r--sci-geosciences/gdal-grass/gdal-grass-2.0.0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-geosciences/gdal-grass/gdal-grass-2.0.0-r1.ebuild b/sci-geosciences/gdal-grass/gdal-grass-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..9fc8276c9aeb
--- /dev/null
+++ b/sci-geosciences/gdal-grass/gdal-grass-2.0.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="GDAL plugin to access GRASS data"
+HOMEPAGE="http://www.gdal.org/"
+SRC_URI="http://download.osgeo.org/gdal/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="postgres"
+RDEPEND="
+ >=sci-libs/gdal-2.0.0
+ sci-geosciences/grass:0=
+"
+DEPEND="${RDEPEND}
+ dev-libs/expat
+ dev-libs/json-c
+ virtual/jpeg
+ media-libs/tiff
+ sci-libs/libgeotiff
+ sci-libs/proj
+ sys-libs/zlib
+ postgres? ( dev-db/postgresql )"
+
+src_prepare() {
+ # fix mkdir not called with -p in Makefile
+ epatch "${FILESDIR}/gdal-grass-makefile.patch"
+}
+
+src_configure() {
+ econf \
+ --with-grass="/usr/$(get_libdir)/grass70" \
+ --with-gdal="/usr/bin/gdal-config" \
+ $(use_with postgres postgres-includes "/usr/include/postgresql")
+}
+
+src_install() {
+ #pass the right variables to 'make install' to prevent a sandbox access violation
+ emake DESTDIR="${D}" \
+ GRASSTABLES_DIR="${D}$(gdal-config --prefix)/share/gdal/grass" \
+ AUTOLOAD_DIR="${D}/usr/$(get_libdir)/gdalplugins" \
+ install
+}