summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-04-04 15:38:47 +0300
committerMart Raudsepp <leio@gentoo.org>2020-04-04 16:04:18 +0300
commitc0c8c538724d73c450a365f27b4e16d118bed578 (patch)
tree7d307b1874fa6add235bc9c31a7160e0230471eb /sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild
parentgnome-base/gnome-desktop: bump to 3.34.5 (diff)
downloadgentoo-c0c8c538724d73c450a365f27b4e16d118bed578.tar.gz
gentoo-c0c8c538724d73c450a365f27b4e16d118bed578.tar.bz2
gentoo-c0c8c538724d73c450a365f27b4e16d118bed578.zip
sci-geosciences/geocode-glib: bump to 3.26.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild')
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild
new file mode 100644
index 000000000000..b194bf3c6a33
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.26.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org meson xdg
+
+DESCRIPTION="GLib helper library for geocoding services"
+HOMEPAGE="https://git.gnome.org/browse/geocode-glib"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.3 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/disable-installed-tests.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test enable-installed-tests) # Actual installation to live system is sedded out, but we need this for running them in src_test
+ $(meson_use introspection enable-introspection)
+ $(meson_use gtk-doc enable-gtk-doc)
+ )
+ meson_src_configure
+}