summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-03 19:53:40 -0400
committerMatt Turner <mattst88@gentoo.org>2022-07-03 20:07:49 -0400
commit81d5316516c330c46ed86cc3e23409d7a36e535a (patch)
treead48c5702026d7e9012e1a9a3f4c14de627b1db4 /sci-geosciences/geocode-glib
parentkernel-build.eclass: Properly install vmlinux(.debug) (diff)
downloadgentoo-81d5316516c330c46ed86cc3e23409d7a36e535a.tar.gz
gentoo-81d5316516c330c46ed86cc3e23409d7a36e535a.tar.bz2
gentoo-81d5316516c330c46ed86cc3e23409d7a36e535a.zip
sci-geosciences/geocode-glib: Version bump to 3.26.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sci-geosciences/geocode-glib')
-rw-r--r--sci-geosciences/geocode-glib/Manifest1
-rw-r--r--sci-geosciences/geocode-glib/files/3.26.3-tests-Fix-locale-in-pi-test.patch43
-rw-r--r--sci-geosciences/geocode-glib/geocode-glib-3.26.3.ebuild45
3 files changed, 89 insertions, 0 deletions
diff --git a/sci-geosciences/geocode-glib/Manifest b/sci-geosciences/geocode-glib/Manifest
index 373e7b16b678..882ba5a4e1a7 100644
--- a/sci-geosciences/geocode-glib/Manifest
+++ b/sci-geosciences/geocode-glib/Manifest
@@ -1 +1,2 @@
DIST geocode-glib-3.26.2.tar.xz 72956 BLAKE2B 40a32fb0ba61cd91b28e57c518dc5450ce89a16889a335d19fe722c1088a4cdb085237d1fe24d08eeac62581ac68895a7a2b432d66f46fc4e03466485cfe5060 SHA512 b3ef81fac6959f6c4725ca721125cdafbbec69233f321872e17f9035266ed7616018ef54a9082fbd0a83395d18c664144cfe3b431d63744be433f058071cd435
+DIST geocode-glib-3.26.3.tar.xz 75148 BLAKE2B 8eba0cb40511a724cddcab659fe0720b0c0534d811c83f8a90d21b9153af242de2a69b2c882b3eb3008ac128d1631a2ac7692c5e000284579aade987334f6cce SHA512 42313b1da24f5256ad73bd4be366d6bacf35256acc098e4865bbff58e92c5b78f4a2537e4787c6387190f10a2be2a72bc1507f7cb436e096e772195cf30fca7c
diff --git a/sci-geosciences/geocode-glib/files/3.26.3-tests-Fix-locale-in-pi-test.patch b/sci-geosciences/geocode-glib/files/3.26.3-tests-Fix-locale-in-pi-test.patch
new file mode 100644
index 000000000000..5df7814383c0
--- /dev/null
+++ b/sci-geosciences/geocode-glib/files/3.26.3-tests-Fix-locale-in-pi-test.patch
@@ -0,0 +1,43 @@
+From c9bbf13d76600492565fa042638b48cb737e492d Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Sat, 2 Jul 2022 10:11:10 +0200
+Subject: [PATCH] tests: Fix locale in "pi" test
+
+The test expects the locale to be en_GB.UTF-8, so set it as such.
+
+Closes: #27
+---
+ geocode-glib/tests/geocode-glib.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/geocode-glib/tests/geocode-glib.c b/geocode-glib/tests/geocode-glib.c
+index f74d031..ef20716 100644
+--- a/geocode-glib/tests/geocode-glib.c
++++ b/geocode-glib/tests/geocode-glib.c
+@@ -410,10 +410,14 @@ test_pi (void)
+ {
+ g_autoptr (GHashTable) params = NULL;
+ GeocodeForward *object;
++ g_autofree char *old_locale = NULL;
+ GError *error = NULL;
+ GList *res;
+ GeocodePlace *place;
+
++ old_locale = g_strdup (setlocale(LC_ALL, NULL));
++ setlocale (LC_ALL, "en_GB.UTF-8");
++
+ /* The query parameters the mock server expects to receive. */
+ params = g_hash_table_new_full (g_str_hash, g_str_equal, NULL, NULL);
+ add_attr_string (params, "q", "Jack Cole Building, St Andrews");
+@@ -439,6 +443,8 @@ test_pi (void)
+ g_assert_cmpstr (geocode_place_get_street_address (place), ==, "North Haugh π");
+ g_object_unref (place);
+ g_list_free (res);
++
++ setlocale (LC_ALL, old_locale);
+ }
+
+ static void
+--
+2.35.1
+
diff --git a/sci-geosciences/geocode-glib/geocode-glib-3.26.3.ebuild b/sci-geosciences/geocode-glib/geocode-glib-3.26.3.ebuild
new file mode 100644
index 000000000000..f8360512af4b
--- /dev/null
+++ b/sci-geosciences/geocode-glib/geocode-glib-3.26.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson xdg
+
+DESCRIPTION="GLib helper library for geocoding services"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/geocode-glib"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-0.99.2[introspection?]
+ >=net-libs/libsoup-2.42:2.4[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.13
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-tests-Fix-locale-in-pi-test.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Denable-installed-tests=false
+ $(meson_use introspection enable-introspection)
+ $(meson_use gtk-doc enable-gtk-doc)
+ -Dsoup2=true
+ )
+ meson_src_configure
+}