summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-12 00:56:57 +0100
committerSam James <sam@gentoo.org>2021-08-12 00:56:57 +0100
commit358d4384de7945f07a338d54129c31d755a90b2f (patch)
treee3b5e307d09f4a117a6de49b8a6e6c26022cd376 /sci-geosciences/gpsd
parentmail-filter/libspf2: fix metadata indentation (diff)
downloadgentoo-358d4384de7945f07a338d54129c31d755a90b2f.tar.gz
gentoo-358d4384de7945f07a338d54129c31d755a90b2f.tar.bz2
gentoo-358d4384de7945f07a338d54129c31d755a90b2f.zip
sci-geosciences/gpsd: fix installation of udev/hotplug files
Closes: https://bugs.gentoo.org/807661 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/gpsd-3.23.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/sci-geosciences/gpsd/gpsd-3.23.ebuild b/sci-geosciences/gpsd/gpsd-3.23.ebuild
index b6f5d935d703..fa8c1276e647 100644
--- a/sci-geosciences/gpsd/gpsd-3.23.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.23.ebuild
@@ -85,6 +85,9 @@ src_prepare() {
die "please sync ebuild & source"
fi
+ # bug #807661
+ sed -i -e 's:$SRCDIR/gpsd.hotplug:$SRCDIR/../gpsd.hotplug:' SConscript || die
+
default
use python && distutils-r1_src_prepare
@@ -183,7 +186,7 @@ src_compile() {
}
src_install() {
- DESTDIR="${D}" escons install "${scons_opts[@]}" $(usex udev udev-install "")
+ DESTDIR="${D}" escons install "${scons_opts[@]}" $(usex udev udev-install '')
newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
newinitd "${FILESDIR}"/gpsd.init-2 gpsd