summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-24 21:09:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-24 21:25:47 +0200
commit876f39a654bd15c8fe2dbdfcf07bcee2b7d10bf6 (patch)
tree40813a2cb20de5f1043636673128992f98635da4 /sci-geosciences/liblas
parentsci-geosciences/liblas: EAPI-7 bump, add missing slot ops (diff)
downloadgentoo-876f39a654bd15c8fe2dbdfcf07bcee2b7d10bf6.tar.gz
gentoo-876f39a654bd15c8fe2dbdfcf07bcee2b7d10bf6.tar.bz2
gentoo-876f39a654bd15c8fe2dbdfcf07bcee2b7d10bf6.zip
sci-geosciences/liblas: Fix CVE-2018-20540
Bug: https://bugs.gentoo.org/678482 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-geosciences/liblas')
-rw-r--r--sci-geosciences/liblas/files/liblas-1.8.1-CVE-2018-20540.patch55
-rw-r--r--sci-geosciences/liblas/liblas-1.8.1-r2.ebuild1
2 files changed, 56 insertions, 0 deletions
diff --git a/sci-geosciences/liblas/files/liblas-1.8.1-CVE-2018-20540.patch b/sci-geosciences/liblas/files/liblas-1.8.1-CVE-2018-20540.patch
new file mode 100644
index 000000000000..ab2174f04ff0
--- /dev/null
+++ b/sci-geosciences/liblas/files/liblas-1.8.1-CVE-2018-20540.patch
@@ -0,0 +1,55 @@
+From 09d45518776489508f34098f1c159f58b856f459 Mon Sep 17 00:00:00 2001
+From: Mateusz Loskot <mateusz@loskot.net>
+Date: Sun, 20 Jan 2019 02:28:29 +0100
+Subject: [PATCH] Ensure stream is deallocated in case of exception (#162)
+
+Fixes #158
+---
+ include/liblas/liblas.hpp | 32 ++++++++++++++++++++++++--------
+ 1 file changed, 24 insertions(+), 8 deletions(-)
+
+diff --git a/include/liblas/liblas.hpp b/include/liblas/liblas.hpp
+index f5ad44e1..325de3ff 100644
+--- a/include/liblas/liblas.hpp
++++ b/include/liblas/liblas.hpp
+@@ -119,16 +119,32 @@ inline std::istream* Open(std::string const& filename, std::ios::openmode mode)
+ {
+ #ifdef USE_BOOST_IO
+ namespace io = boost::iostreams;
+- io::stream<io::file_source>* ifs = new io::stream<io::file_source>();
+- ifs->open(filename.c_str(), mode);
+- if (ifs->is_open() == false) return NULL;
+- return ifs;
++ io::stream<io::file_source>* ifs = NULL;
++ try
++ {
++ ifs = new io::stream<io::file_source>();
++ ifs->open(filename.c_str(), mode);
++ if (ifs->is_open() == false) return NULL;
++ return ifs;
++ }
++ catch (...)
++ {
++ delete ifs;
++ }
+ #else
+- std::ifstream* ifs = new std::ifstream();
+- ifs->open(filename.c_str(), mode);
+- if (ifs->is_open() == false) return NULL;
+- return ifs;
++ std::ifstream* ifs = NULL;
++ try
++ {
++ ifs = new std::ifstream();
++ ifs->open(filename.c_str(), mode);
++ if (ifs->is_open() == false) return NULL;
++ }
++ catch (...)
++ {
++ delete ifs;
++ }
+ #endif
++ return NULL;
+ }
+
+ /// Create file and open to write in binary mode.
diff --git a/sci-geosciences/liblas/liblas-1.8.1-r2.ebuild b/sci-geosciences/liblas/liblas-1.8.1-r2.ebuild
index 11e130b14047..6153260346a6 100644
--- a/sci-geosciences/liblas/liblas-1.8.1-r2.ebuild
+++ b/sci-geosciences/liblas/liblas-1.8.1-r2.ebuild
@@ -30,6 +30,7 @@ S="${WORKDIR}/libLAS-${PV}"
PATCHES=(
"${FILESDIR}"/${PN}-1.8.0_remove-std-c++98.patch
"${FILESDIR}"/${P}-fix-overload-call.patch # bug 661654
+ "${FILESDIR}"/${P}-CVE-2018-20540.patch # bug 678482
)
src_prepare() {