summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:10:23 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:25:46 +0200
commit4a81d5a8f153492273b37d715293f4f205e0053b (patch)
tree7f4bcc6b15c06e34f7f4cb172eabb25584971118 /sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild
parentsci-geosciences/opencpn-plugin-br24radar: bump version, add live version (diff)
downloadgentoo-4a81d5a8f153492273b37d715293f4f205e0053b.tar.gz
gentoo-4a81d5a8f153492273b37d715293f4f205e0053b.tar.bz2
gentoo-4a81d5a8f153492273b37d715293f4f205e0053b.zip
sci-geosciences/opencpn-plugin-launcher: bump version, add live version
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild')
-rw-r--r--sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild b/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild
new file mode 100644
index 000000000000..67645ede6443
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="launcher_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/nohal/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Launcher Plugin for OpenCPN"
+HOMEPAGE="https://github.com/nohal/launcher_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}