summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/opencpn-plugin-launcher
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/opencpn-plugin-launcher')
-rw-r--r--sci-geosciences/opencpn-plugin-launcher/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-launcher/metadata.xml12
-rw-r--r--sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.0.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-launcher/Manifest b/sci-geosciences/opencpn-plugin-launcher/Manifest
new file mode 100644
index 000000000000..53d880a81f34
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-launcher/Manifest
@@ -0,0 +1 @@
+DIST opencpn-plugin-launcher-1.0.tar.gz 126153 SHA256 56122ad3efa53aa30e289f78b0f8ba6e661b87e6c52f29cfcc28fc0815a83e6f SHA512 efaae3f9f8f1ecb4f4d1094714b7994cbbbb6bf69638a130db43f62a8852f9972003fd1b9ec20139e58a031c8b7c4ebdf1593a4044415a7f8c8417d1fcb7ac90 WHIRLPOOL 7b9239ef1c8be630b1146a36fff1d4fd309bba3152f8e1612ffe0448062d6cb37230db8426a04e779107a880e06402e506aeb6527b8be5e1e49eff1547dedc2b
diff --git a/sci-geosciences/opencpn-plugin-launcher/metadata.xml b/sci-geosciences/opencpn-plugin-launcher/metadata.xml
new file mode 100644
index 000000000000..a88c3246e941
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-launcher/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-geosciences</herd>
+ <maintainer>
+ <email>mschiff@gentoo.org</email>
+ <name>Marc Schiffbauer</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nohal/launcher_pi</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.0.ebuild b/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.0.ebuild
new file mode 100644
index 000000000000..ff7b1b8454e8
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-launcher/opencpn-plugin-launcher-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+inherit cmake-utils wxwidgets
+
+MY_PN="launcher_pi"
+
+DESCRIPTION="Launcher Plugin for OpenCPN"
+HOMEPAGE="http://opencpn.org/ocpn/downloadplugins"
+SRC_URI="https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=sci-geosciences/opencpn-4.0.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"