summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:14:27 +0200
committerMarc Schiffbauer <mschiff@gentoo.org>2016-03-31 01:25:46 +0200
commitb99ca38ed1ab297c48fab5fb560438ea88996417 (patch)
treeda00ec967ffbc1ddbb9d7931ceb3dff615004052 /sci-geosciences/opencpn-plugin-objsearch
parentsci-geosciences/opencpn-plugin-logbookkonni: bump version, add live version (diff)
downloadgentoo-b99ca38ed1ab297c48fab5fb560438ea88996417.tar.gz
gentoo-b99ca38ed1ab297c48fab5fb560438ea88996417.tar.bz2
gentoo-b99ca38ed1ab297c48fab5fb560438ea88996417.zip
sci-geosciences/opencpn-plugin-objsearch: bump version, add live version
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-geosciences/opencpn-plugin-objsearch')
-rw-r--r--sci-geosciences/opencpn-plugin-objsearch/Manifest1
-rw-r--r--sci-geosciences/opencpn-plugin-objsearch/opencpn-plugin-objsearch-0.7.ebuild38
-rw-r--r--sci-geosciences/opencpn-plugin-objsearch/opencpn-plugin-objsearch-9999.ebuild38
3 files changed, 77 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn-plugin-objsearch/Manifest b/sci-geosciences/opencpn-plugin-objsearch/Manifest
index 6d98e1165517..da6525fdb50e 100644
--- a/sci-geosciences/opencpn-plugin-objsearch/Manifest
+++ b/sci-geosciences/opencpn-plugin-objsearch/Manifest
@@ -1 +1,2 @@
DIST opencpn-plugin-objsearch-0.5.1.tar.gz 1954813 SHA256 16923b02c74621f4868110235cae4a8a0261b6fe8c91b9a488a0c67c80e4ccc5 SHA512 dd83352eab307b991d3d296b9bbab2a972a2ce4f33c1ddc55c048c3414c11d5b7a8429a32f2d9c96017fb16c841dc3c6fee8522dea690eaa17b3c7e5ac1fbfd0 WHIRLPOOL 9e0ab972c163a26d67d2389f2179284e0f416aa1de8e993837decbcb23c7c4dadfcc044aa2f83ecc30f21478c1571236bc3f1c7a3231677085e3211527e2d7ea
+DIST opencpn-plugin-objsearch-0.7.tar.gz 2047642 SHA256 297ba3f799c08d46c2a851ae76edcf3b2be53cb0b72e1c63c593bf6ab55bf44a SHA512 9c371bf3a5ef551a68ea7e2569536df37d7ec1241be011c6a313229f3c34697332c967c91855d9ccdd4f0a3412ade130fe241ea22c803f7c37543539602f71b3 WHIRLPOOL 902874e56833d43a6b169b1012449cb8bafa0ca0bec85816b299688d95af8dcbed74c5d9be07838f20f6a3b2cc8ec03d0912738ace4e50f53460dd99b3e7d6e1
diff --git a/sci-geosciences/opencpn-plugin-objsearch/opencpn-plugin-objsearch-0.7.ebuild b/sci-geosciences/opencpn-plugin-objsearch/opencpn-plugin-objsearch-0.7.ebuild
new file mode 100644
index 000000000000..d4cdf27dd150
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-objsearch/opencpn-plugin-objsearch-0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="objsearch_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/nohal/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Chart Object Search Plugin for OpenCPN"
+HOMEPAGE="https://github.com/nohal/objsearch_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}
diff --git a/sci-geosciences/opencpn-plugin-objsearch/opencpn-plugin-objsearch-9999.ebuild b/sci-geosciences/opencpn-plugin-objsearch/opencpn-plugin-objsearch-9999.ebuild
new file mode 100644
index 000000000000..d4cdf27dd150
--- /dev/null
+++ b/sci-geosciences/opencpn-plugin-objsearch/opencpn-plugin-objsearch-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="3.0"
+MY_PN="objsearch_pi"
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/nohal/${MY_PN}.git"
+ inherit git-r3 cmake-utils wxwidgets
+ KEYWORDS=""
+else
+ SRC_URI="
+ https://github.com/nohal/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ "
+ inherit cmake-utils wxwidgets
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+DESCRIPTION="Chart Object Search Plugin for OpenCPN"
+HOMEPAGE="https://github.com/nohal/objsearch_pi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ x11-libs/wxGTK:${WX_GTK_VER}
+ >=sci-geosciences/opencpn-4.2.0
+ sys-devel/gettext
+"
+DEPEND="${RDEPEND}"
+src_prepare() {
+ need-wxwidgets unicode
+ cmake-utils_src_prepare
+}