summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/xtide/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/xtide/files')
-rw-r--r--sci-geosciences/xtide/files/xtide-2.13.1-Werror.patch21
-rw-r--r--sci-geosciences/xtide/files/xtide-2.13.1-gps-switch.patch88
2 files changed, 109 insertions, 0 deletions
diff --git a/sci-geosciences/xtide/files/xtide-2.13.1-Werror.patch b/sci-geosciences/xtide/files/xtide-2.13.1-Werror.patch
new file mode 100644
index 000000000000..fcfd147e51bb
--- /dev/null
+++ b/sci-geosciences/xtide/files/xtide-2.13.1-Werror.patch
@@ -0,0 +1,21 @@
+commit 9cf2369051fa887bd5f13bf7df80c51bcf040306
+Author: hasufell <hasufell@gentoo.org>
+Date: Sat Jul 13 13:25:42 2013 +0200
+
+ BUILD: remove -Werror
+
+ It's discouraged to add non-specific Werror flags.
+
+diff --git a/configure.ac b/configure.ac
+index b366337..86c7569 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,7 +11,7 @@ m4_if(2.65, AC_AUTOCONF_VERSION, [m4_fatal([autoconf version 2.65 is broken and
+ # FIXME: Update version info on each release
+ AC_INIT([XTide], [2.13.1], [dave@flaterco.com])
+
+-AM_INIT_AUTOMAKE([-Wall -Werror])
++AM_INIT_AUTOMAKE([-Wall])
+
+ AC_LANG([C++])
+ AC_PROG_CXX
diff --git a/sci-geosciences/xtide/files/xtide-2.13.1-gps-switch.patch b/sci-geosciences/xtide/files/xtide-2.13.1-gps-switch.patch
new file mode 100644
index 000000000000..54c6546fe298
--- /dev/null
+++ b/sci-geosciences/xtide/files/xtide-2.13.1-gps-switch.patch
@@ -0,0 +1,88 @@
+commit 755677baae16fd8772efd523a25b787ea3fc0772
+Author: hasufell <hasufell@gentoo.org>
+Date: Sat Jul 13 13:26:24 2013 +0200
+
+ BUILD: add --with-gps switch
+
+ We don't want automagic gps detection, but give control
+ to the user.
+
+diff --git a/configure.ac b/configure.ac
+index 86c7569..307def4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -156,6 +156,12 @@ if test -z "${SKIP_COMPLICATED}"; then
+ fi
+ CXXFLAGS="${SAVED_CXXFLAGS}"
+
++AC_ARG_WITH([gps],
++ [AS_HELP_STRING([--with-gps],
++ [use libgpsd (default: no)])],
++ [gps=$withval],
++ [gps=no])
++
+ # xttpd configs
+ AC_ARG_WITH([xttpd-user],
+ [AS_HELP_STRING([--with-xttpd-user=user],
+@@ -381,32 +387,35 @@ AC_CHECK_HEADER([Dstr], [AC_CHECK_LIB([dstr], [DstrCompat20070215Check])])
+ AM_CONDITIONAL(NO_LIBDSTR, test "$ac_cv_lib_dstr_DstrCompat20070215Check" != "yes")
+
+ # libgps is optional; use it if you have a compatible version.
+-AC_CHECK_HEADER([gps.h], [AC_CHECK_LIB([gps], [timestamp], [
+- AC_MSG_CHECKING([if libgps is 3.x or newer, compatible version])
+- AC_COMPILE_IFELSE(
+- [AC_LANG_SOURCE([[
+-#include <gps.h>
+-#if (GPSD_API_MAJOR_VERSION < 5)
+-#FAIL
+-#endif
+-int main (int argc, char **argv) {
+- struct gps_data_t gpsdata;
+- gps_open ("127.0.0.1", "2947", &gpsdata);
+- gps_stream (&gpsdata, WATCH_ENABLE|WATCH_NEWSTYLE, NULL);
+- gps_read (&gpsdata);
+- return (gpsdata.fix.mode >= MODE_2D);
+-}
+- ]])],
+- [
+- AC_MSG_RESULT(yes)
+- AC_DEFINE([GPS_GOOD])
+- AC_SUBST([GPSD_LIBS], ["-lgps"])
+- ],
+- [
+- AC_MSG_RESULT(no)
+- ]
+- )
+-])])
++
++AS_IF([test "x$gps" = "xyes"], [
++ AC_CHECK_HEADER([gps.h], [AC_CHECK_LIB([gps], [timestamp], [
++ AC_MSG_CHECKING([if libgps is 3.x or newer, compatible version])
++ AC_COMPILE_IFELSE(
++ [AC_LANG_SOURCE([[
++ #include <gps.h>
++ #if (GPSD_API_MAJOR_VERSION < 5)
++ #FAIL
++ #endif
++ int main (int argc, char **argv) {
++ struct gps_data_t gpsdata;
++ gps_open ("127.0.0.1", "2947", &gpsdata);
++ gps_stream (&gpsdata, WATCH_ENABLE|WATCH_NEWSTYLE, NULL);
++ gps_read (&gpsdata);
++ return (gpsdata.fix.mode >= MODE_2D);
++ }
++ ]])],
++ [
++ AC_MSG_RESULT(yes)
++ AC_DEFINE([GPS_GOOD])
++ AC_SUBST([GPSD_LIBS], ["-lgps"])
++ ],
++ [
++ AC_MSG_RESULT(no)
++ ]
++ )
++ ], [AC_MSG_ERROR([cannot find libgps])])], [AC_MSG_ERROR([cannot find gps.h])])
++ ])
+
+ AC_TYPE_INT8_T
+ AC_TYPE_INT16_T