summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-15 00:13:34 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-15 00:13:34 +0200
commit4bef1d27b62f8a81283537d10ac6040e40395199 (patch)
treed251e4f14c1caff722b744e6b44794a98899cada /sci-libs/arpack/arpack-3.4.0.ebuild
parentsci-libs/arpack: Conditionally add -fallow-argument-mismatch (diff)
downloadgentoo-4bef1d27b62f8a81283537d10ac6040e40395199.tar.gz
gentoo-4bef1d27b62f8a81283537d10ac6040e40395199.tar.bz2
gentoo-4bef1d27b62f8a81283537d10ac6040e40395199.zip
sci-libs/arpack: [QA] Fix multiple violations
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/arpack/arpack-3.4.0.ebuild')
-rw-r--r--sci-libs/arpack/arpack-3.4.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sci-libs/arpack/arpack-3.4.0.ebuild b/sci-libs/arpack/arpack-3.4.0.ebuild
index 69fc2492c91d..dfec8e3b0d4c 100644
--- a/sci-libs/arpack/arpack-3.4.0.ebuild
+++ b/sci-libs/arpack/arpack-3.4.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools eutils flag-o-matic fortran-2 toolchain-funcs
+inherit autotools flag-o-matic fortran-2 toolchain-funcs
DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
@@ -22,8 +22,8 @@ RDEPEND="
virtual/blas
virtual/lapack
mpi? ( virtual/mpi[fortran] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/${PN}-ng-${PV}"
@@ -50,10 +50,9 @@ src_install() {
newdoc DOCUMENTS/README README.doc
use doc && dodoc "${WORKDIR}"/*.ps
if use examples; then
- docinto /usr/share/doc/${PF}
dodoc -r EXAMPLES
if use mpi; then
- docinto /usr/share/doc/${PF}/EXAMPLES/PARPACK
+ docinto EXAMPLES/PARPACK
dodoc -r PARPACK/EXAMPLES/MPI
fi
fi