summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2020-06-08 00:11:18 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2020-06-08 00:11:30 +0300
commit56bb49e97ee1dc6ee5a257bed3e45c2154b87dab (patch)
tree09c483db974c0f53c6429b84aa2b09e6d31f1828 /sci-libs/arpack/arpack-3.4.0.ebuild
parentapp-doc/doxygen: Drop extraneous KEYWORDS lines (diff)
downloadgentoo-56bb49e97ee1dc6ee5a257bed3e45c2154b87dab.tar.gz
gentoo-56bb49e97ee1dc6ee5a257bed3e45c2154b87dab.tar.bz2
gentoo-56bb49e97ee1dc6ee5a257bed3e45c2154b87dab.zip
sci-libs/arpack: Fix build with gcc10
Closes: https://bugs.gentoo.org/721858 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-libs/arpack/arpack-3.4.0.ebuild')
-rw-r--r--sci-libs/arpack/arpack-3.4.0.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/sci-libs/arpack/arpack-3.4.0.ebuild b/sci-libs/arpack/arpack-3.4.0.ebuild
index bdb9445f39b9..0b424e228681 100644
--- a/sci-libs/arpack/arpack-3.4.0.ebuild
+++ b/sci-libs/arpack/arpack-3.4.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools eutils fortran-2 toolchain-funcs
+inherit autotools eutils flag-o-matic fortran-2 toolchain-funcs
DESCRIPTION="Arnoldi package library to solve large scale eigenvalue problems"
HOMEPAGE="http://www.caam.rice.edu/software/ARPACK/ https://github.com/opencollab/arpack-ng"
@@ -33,6 +33,7 @@ src_prepare() {
}
src_configure() {
+ append-fflags -fallow-argument-mismatch
econf \
--disable-static \
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)" \
@@ -47,11 +48,11 @@ src_install() {
newdoc DOCUMENTS/README README.doc
use doc && dodoc "${WORKDIR}"/*.ps
if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r EXAMPLES
+ docinto /usr/share/doc/${PF}
+ dodoc -r EXAMPLES
if use mpi; then
- insinto /usr/share/doc/${PF}/EXAMPLES/PARPACK
- doins -r PARPACK/EXAMPLES/MPI
+ docinto /usr/share/doc/${PF}/EXAMPLES/PARPACK
+ dodoc -r PARPACK/EXAMPLES/MPI
fi
fi
}