summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2021-12-13 16:35:11 +1300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-15 12:40:31 +0100
commit62c564e6679094847603f21ffc1fd63a5345511c (patch)
treed3c6223758bd0cc7b9f523908e05967983ac1dcb /sci-libs/bliss
parentkde-frameworks/plasma: Hide svg glitches using a smaller mask (diff)
downloadgentoo-62c564e6679094847603f21ffc1fd63a5345511c.tar.gz
gentoo-62c564e6679094847603f21ffc1fd63a5345511c.tar.bz2
gentoo-62c564e6679094847603f21ffc1fd63a5345511c.zip
sci-libs/bliss: New upstream release
Closes: https://bugs.gentoo.org/829119 Closes: https://github.com/gentoo/gentoo/pull/23284 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/bliss')
-rw-r--r--sci-libs/bliss/Manifest1
-rw-r--r--sci-libs/bliss/bliss-0.77.ebuild28
-rw-r--r--sci-libs/bliss/files/bliss-0.77-install.patch32
3 files changed, 61 insertions, 0 deletions
diff --git a/sci-libs/bliss/Manifest b/sci-libs/bliss/Manifest
index 827342cdd284..69758a8152ae 100644
--- a/sci-libs/bliss/Manifest
+++ b/sci-libs/bliss/Manifest
@@ -1 +1,2 @@
DIST bliss-0.73.zip 94108 BLAKE2B 836184b31fa28db3328c21e7563366a93cf1645b02b96e185838e3c2513393b1d0a54783ca14c6d7f1a1d5055800bc3d7acde3c584e61e66c9ab93936824353b SHA512 30f505945c577d8bcb265a349f5bc9d4dcd96555fa3add285199cdd95ea2710f04409008ff06432daffab62c132e884845eae7f823191407906202862509e05d
+DIST bliss-0.77.zip 117888 BLAKE2B ce4b2fa568c5520fe41748bf59a493af1c33ec9cc0732aca5e5ba657ca726e118e26763355778e3def5716d62e7d3aceceb592ef67e5e148c250d3ffffab67d7 SHA512 d210f137e614bca7cf0d88851d0c62292bf479b687bca6a25d9e42661825f882a4ff8c74c96a965bd9d4f246a1bda6b90cef64894914e6f7b17db6bf4a8f4b17
diff --git a/sci-libs/bliss/bliss-0.77.ebuild b/sci-libs/bliss/bliss-0.77.ebuild
new file mode 100644
index 000000000000..88a4d042c220
--- /dev/null
+++ b/sci-libs/bliss/bliss-0.77.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+SRC_URI="https://users.aalto.fi/~tjunttil/${PN}/downloads/${P}.zip"
+DESCRIPTION="Compute Automorphism Groups and Canonical Labelings of Graphs"
+HOMEPAGE="https://users.aalto.fi/~tjunttil/bliss/index.html"
+
+LICENSE="LGPL-3"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="gmp"
+
+RDEPEND="gmp? ( dev-libs/gmp:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
+PATCHES=( "${FILESDIR}/${PN}-0.77-install.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GMP="$(usex gmp)"
+ )
+
+ cmake_src_configure
+}
diff --git a/sci-libs/bliss/files/bliss-0.77-install.patch b/sci-libs/bliss/files/bliss-0.77-install.patch
new file mode 100644
index 000000000000..caab14aa40f6
--- /dev/null
+++ b/sci-libs/bliss/files/bliss-0.77-install.patch
@@ -0,0 +1,32 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 01ed093..cfdb0a6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -62,3 +62,27 @@ if(USE_GMP)
+ target_link_libraries(bliss-executable ${GMP_LIBRARIES})
+ endif(USE_GMP)
+ set_target_properties(bliss-executable PROPERTIES OUTPUT_NAME bliss)
++
++include(GNUInstallDirs)
++
++set(
++ BLISS_HEADERS
++ src/bliss_C.h
++ src/uintseqhash.hh
++ src/abstractgraph.hh
++ src/stats.hh
++ src/digraph.hh
++ src/defs.hh
++ src/heap.hh
++ src/graph.hh
++ src/partition.hh
++ src/kqueue.hh
++ src/utils.hh
++ src/orbit.hh
++ src/timer.hh
++ src/bignum.hh
++)
++
++install(TARGETS bliss-executable RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
++install(TARGETS bliss LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(FILES ${BLISS_HEADERS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/bliss)