summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-03-19 19:36:40 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-03-19 19:41:11 -0400
commit55ef90fedba601304e7c2479f267940f0af380e7 (patch)
tree422f647ec0988e770417571ab197f26da9504f7f /sci-libs/brial
parentfeatures/musl/package.use.mask: maks dev-lang/gforth[check], bug #713138 (diff)
downloadgentoo-55ef90fedba601304e7c2479f267940f0af380e7.tar.gz
gentoo-55ef90fedba601304e7c2479f267940f0af380e7.tar.bz2
gentoo-55ef90fedba601304e7c2479f267940f0af380e7.zip
sci-libs/brial: new library for polynomials over boolean rings.
This library is maintained upstream and in the sage-on-gentoo overlay by François Bissey, but it is well-packaged and passes its tests. It is a dependency of SageMath, and the system copy will eventually be usable by Sage, so now is a good time to adopt it. The overlay ebuild was used with minimal changes. Closes: https://bugs.gentoo.org/713330 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/brial')
-rw-r--r--sci-libs/brial/Manifest1
-rw-r--r--sci-libs/brial/brial-1.2.8.ebuild39
-rw-r--r--sci-libs/brial/metadata.xml31
3 files changed, 71 insertions, 0 deletions
diff --git a/sci-libs/brial/Manifest b/sci-libs/brial/Manifest
new file mode 100644
index 000000000000..f3d47c7a9b98
--- /dev/null
+++ b/sci-libs/brial/Manifest
@@ -0,0 +1 @@
+DIST brial-1.2.8.tar.bz2 1228732 BLAKE2B f9bdfc9416381f3436c555861806a7ea4680e706729b6de9c2b06ea2908090b87b745fe5ce2d94ba9d5832a78067e4848f8ef113b7d8dc22557b6d95b7dad707 SHA512 a94acba140d976dd070b5214c537fb3dba89fc2309addc566b8f0a031328f2d4c2bb3c38c2cb5565c7ff2ca0c5f7f56ca120899d15c768887d3b61a18b3e05be
diff --git a/sci-libs/brial/brial-1.2.8.ebuild b/sci-libs/brial/brial-1.2.8.ebuild
new file mode 100644
index 000000000000..8949ea5ef31b
--- /dev/null
+++ b/sci-libs/brial/brial-1.2.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A C++ library for polynomials over boolean rings"
+HOMEPAGE="https://github.com/BRiAl/BRiAl"
+SRC_URI="https://github.com/BRiAl/BRiAl/releases/download/${PV}/${P}.tar.bz2"
+
+# The top-level license is GPL2, but cudd/LICENSE is BSD.
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="png static-libs"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="dev-libs/boost
+ sci-libs/m4ri[png=]"
+RDEPEND="${DEPEND}"
+
+pkg_setup(){
+ tc-export PKG_CONFIG
+}
+
+src_configure(){
+ # with-boost-libdir added to deal with some rather quirky setups
+ # see https://github.com/cschwan/sage-on-gentoo/issues/551
+ econf \
+ --with-boost="${EPREFIX}"/usr \
+ --with-boost-libdir="${EPREFIX}"/usr/$(get_libdir) \
+ $(use_enable static-libs static)
+}
+
+src_install(){
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-libs/brial/metadata.xml b/sci-libs/brial/metadata.xml
new file mode 100644
index 000000000000..7bb93bb41ee3
--- /dev/null
+++ b/sci-libs/brial/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <longdescription lang="en">
+ BRiAl is a C++ library (the successor to PolyBoRi) that provides
+ high-level data types for Boolean polynomials and monomials,
+ exponent vectors, as well as for the underlying polynomial rings
+ and subsets of the powerset of the Boolean variables.
+ </longdescription>
+
+ <upstream>
+ <remote-id type="github">BRiAl/BRiAl</remote-id>
+ </upstream>
+</pkgmetadata>