summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/btf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/btf')
-rw-r--r--sci-libs/btf/Manifest2
-rw-r--r--sci-libs/btf/btf-1.1.3.ebuild27
-rw-r--r--sci-libs/btf/btf-1.2.0.ebuild21
-rw-r--r--sci-libs/btf/files/btf-1.0.1-autotools.patch34
-rw-r--r--sci-libs/btf/metadata.xml11
5 files changed, 95 insertions, 0 deletions
diff --git a/sci-libs/btf/Manifest b/sci-libs/btf/Manifest
new file mode 100644
index 000000000000..bc48bc451e84
--- /dev/null
+++ b/sci-libs/btf/Manifest
@@ -0,0 +1,2 @@
+DIST BTF-1.1.3.tar.gz 38276 SHA256 01032ba79baba9a90e3c03e9500c42cce9250c2ecab03c48323bc940f3a7cbfe SHA512 1e1b3e9bbed22ae417177f1bb960bd8097af05e7fede4b59df270020845e4bc9a77a16733af980d9b309503edc7ab6ffd852d28c6650e4e53b29125c5dc6364c WHIRLPOOL 319d1a512c42b3f6be294cd98020f9353d35456bd5136b76a98eb6fda77b5f0a6f924f1fc13c8aa29ddceb03602a3d0231d2283964f3a5041b3f4f9f28102bc3
+DIST btf-1.2.0.tar.bz2 290915 SHA256 9c26f0dc080891838421dd4d38bf1350d8f6fadb1e8a090c127e2667041191fb SHA512 4c2dcd5abf7a72485267a666e679545a5bfa8a20dfbf75a939c92547bdf960d40b6ae93cad23ac44f791e515a13f26c1dae446d3ba6e89b3d1f87d91d4dba50c WHIRLPOOL 0c40c7616b1fec6875ce4653e856f64056bd4eafe96c501cea5474d9ea7a1a75401a86db82f73b8f2f9c1244195746faca265abece3c7bfbf579f9bb2aaec37e
diff --git a/sci-libs/btf/btf-1.1.3.ebuild b/sci-libs/btf/btf-1.1.3.ebuild
new file mode 100644
index 000000000000..60a8f6dd54c5
--- /dev/null
+++ b/sci-libs/btf/btf-1.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+inherit autotools-utils
+
+MY_PN=BTF
+
+DESCRIPTION="Algorithm for matrix permutation into block triangular form"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/btf/"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="sci-libs/ufconfig"
+RDEPEND=""
+
+DOCS=( README.txt Doc/ChangeLog )
+PATCHES=( "${FILESDIR}"/${PN}-1.0.1-autotools.patch )
+
+S="${WORKDIR}/${MY_PN}"
diff --git a/sci-libs/btf/btf-1.2.0.ebuild b/sci-libs/btf/btf-1.2.0.ebuild
new file mode 100644
index 000000000000..a331bc8b1a93
--- /dev/null
+++ b/sci-libs/btf/btf-1.2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Algorithm for matrix permutation into block triangular form"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/btf/"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS=" ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+RDEPEND="sci-libs/suitesparseconfig"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/sci-libs/btf/files/btf-1.0.1-autotools.patch b/sci-libs/btf/files/btf-1.0.1-autotools.patch
new file mode 100644
index 000000000000..4156c2dfeb70
--- /dev/null
+++ b/sci-libs/btf/files/btf-1.0.1-autotools.patch
@@ -0,0 +1,34 @@
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-30 12:29:44.232979678 +0000
+@@ -0,0 +1,10 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(btf, 1.0.1, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADERS(UFconfig.h)
++AC_CONFIG_FILES([Makefile Source/Makefile])
++AC_OUTPUT
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-30 12:30:12.862611188 +0000
+@@ -0,0 +1,3 @@
++SUBDIRS = Source
++EXTRA_DIST = README.txt
++include_HEADERS = Include/btf.h Include/btf_internal.h
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-30 12:37:00.857861512 +0000
+@@ -0,0 +1,12 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++BTFSRC = btf_order.c btf_maxtrans.c btf_strongcomp.c
++
++lib_LTLIBRARIES = libbtf.la
++noinst_LTLIBRARIES = libbtfi.la libbtfl.la
++libbtfi_la_SOURCES = $(BTFSRC)
++libbtfi_la_CPPFLAGS = $(AM_CPPFLAGS)
++libbtfl_la_SOURCES = $(BTFSRC)
++libbtfl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++libbtf_la_SOURCES =
++libbtf_la_LIBADD = libbtfl.la libbtfi.la
diff --git a/sci-libs/btf/metadata.xml b/sci-libs/btf/metadata.xml
new file mode 100644
index 000000000000..2c22e8591c55
--- /dev/null
+++ b/sci-libs/btf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The Block Triangular Form is a library of routines offering
+ permutation of an unsymmetric matrix (square or rectangular) into
+ its block upper triangular form (more precisely, it computes a
+ Dulmage-Mendelsohn decomposition).
+</longdescription>
+</pkgmetadata>