summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-02-27 03:31:28 +0300
committerSam James <sam@gentoo.org>2022-02-27 00:54:00 +0000
commitc51cf41931e92294277c1f9b3ef00fc9f2f632c7 (patch)
tree7a7a39661849de4fcc7eec710d73cf55c47ef52a /sci-libs/cantera
parentapp-doc/gimp-help: update python_check_deps call (diff)
downloadgentoo-c51cf41931e92294277c1f9b3ef00fc9f2f632c7.tar.gz
gentoo-c51cf41931e92294277c1f9b3ef00fc9f2f632c7.tar.bz2
gentoo-c51cf41931e92294277c1f9b3ef00fc9f2f632c7.zip
sci-libs/cantera: 2.5.1 revision bump
Drop USE="pch". Fix python_optimize path. Remove static libs. Closes: https://bugs.gentoo.org/832792 Closes: https://bugs.gentoo.org/832787 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/24367 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/cantera')
-rw-r--r--sci-libs/cantera/cantera-2.5.1-r3.ebuild (renamed from sci-libs/cantera/cantera-2.5.1-r2.ebuild)10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-libs/cantera/cantera-2.5.1-r2.ebuild b/sci-libs/cantera/cantera-2.5.1-r3.ebuild
index f4fa50e5d5a0..99ea2dff2599 100644
--- a/sci-libs/cantera/cantera-2.5.1-r2.ebuild
+++ b/sci-libs/cantera/cantera-2.5.1-r3.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://github.com/Cantera/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+cti fortran lapack pch +python test"
+IUSE="+cti fortran lapack +python test"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -84,7 +84,7 @@ src_configure() {
FORTRANFLAGS="${FCFLAGS}"
optimize_flags="-Wno-inline"
renamed_shared_libraries="no"
- use_pch=$(usex pch)
+ use_pch="no"
## In some cases other order can break the detection of right location of Boost: ##
system_fmt="y"
system_sundials="y"
@@ -122,11 +122,11 @@ src_install() {
rm -r "${D}/usr/share/man" || die "Can't remove man files."
else
# Run the byte-compile of modules
- python_optimize "${D}/$(python_get_sitedir)/${PN}"
+ python_optimize "${D}$(python_get_sitedir)/${PN}"
fi
- # We install static libs unconditionally here
- # See https://github.com/gentoo/gentoo/pull/10017#discussion_r229210565
+ # User could remove this line if require static libs for development purpose
+ find "${ED}" -name '*.a' -delete || die
}
pkg_postinst() {