summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-04-02 16:55:57 +0200
committerJustin Lecher <jlec@gentoo.org>2016-04-02 16:56:02 +0200
commit011d5c9fcf200f2f4d054f99a9d7e949d4b3d1a1 (patch)
tree09f3fffa080b5f028dfb83d35b3e528387038093 /sci-libs/cblas-reference/cblas-reference-20030223-r4.ebuild
parentsci-libs/lapack-reference: Drop old (diff)
downloadgentoo-011d5c9fcf200f2f4d054f99a9d7e949d4b3d1a1.tar.gz
gentoo-011d5c9fcf200f2f4d054f99a9d7e949d4b3d1a1.tar.bz2
gentoo-011d5c9fcf200f2f4d054f99a9d7e949d4b3d1a1.zip
sci-libs/cblas-reference: Drop old
obsoletes: Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=501042 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=478602 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/cblas-reference/cblas-reference-20030223-r4.ebuild')
-rw-r--r--sci-libs/cblas-reference/cblas-reference-20030223-r4.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/sci-libs/cblas-reference/cblas-reference-20030223-r4.ebuild b/sci-libs/cblas-reference/cblas-reference-20030223-r4.ebuild
deleted file mode 100644
index 72164d89c970..000000000000
--- a/sci-libs/cblas-reference/cblas-reference-20030223-r4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit autotools eutils fortran-2 multilib toolchain-funcs
-
-MyPN="${PN/-reference/}"
-
-DESCRIPTION="C wrapper interface to the F77 reference BLAS implementation"
-HOMEPAGE="http://www.netlib.org/blas/"
-SRC_URI="http://www.netlib.org/blas/blast-forum/${MyPN}.tgz"
-
-SLOT="0"
-LICENSE="public-domain"
-IUSE=""
-KEYWORDS="alpha amd64 hppa ppc ppc64 s390 sparc x86 ~x86-fbsd"
-
-RDEPEND="
- virtual/blas
- app-eselect/eselect-cblas"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-ESELECT_PROF=reference
-S="${WORKDIR}/CBLAS"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-autotool.patch
- eautoreconf
-}
-
-src_compile() {
- econf \
- --libdir=/usr/$(get_libdir)/blas/reference \
- --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README || die "failed to install docs"
- insinto /usr/share/doc/${PF}
- doins cblas_example*c || die "install examples failed"
- eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas.reference ${ESELECT_PROF}
-}
-
-pkg_postinst() {
- local p=cblas
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
-}