summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-27 18:56:40 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-28 15:54:24 +0000
commita58c2fb947d959b4b18322c36d39cdd2f9fd1353 (patch)
treeb0d559daf76c4166549ec82e7138495f493d419a /sci-libs/ccfits
parentdev-ruby/jquery-rails: add ruby23, bug 626274 (diff)
downloadgentoo-a58c2fb947d959b4b18322c36d39cdd2f9fd1353.tar.gz
gentoo-a58c2fb947d959b4b18322c36d39cdd2f9fd1353.tar.bz2
gentoo-a58c2fb947d959b4b18322c36d39cdd2f9fd1353.zip
sci-libs/ccfits: version bump, switch maintenance to sci-astronomy
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'sci-libs/ccfits')
-rw-r--r--sci-libs/ccfits/Manifest1
-rw-r--r--sci-libs/ccfits/ccfits-2.5.ebuild47
-rw-r--r--sci-libs/ccfits/metadata.xml22
3 files changed, 59 insertions, 11 deletions
diff --git a/sci-libs/ccfits/Manifest b/sci-libs/ccfits/Manifest
index 13e11de12311..f218546a2560 100644
--- a/sci-libs/ccfits/Manifest
+++ b/sci-libs/ccfits/Manifest
@@ -1 +1,2 @@
DIST CCfits-2.4.tar.gz 1792643 SHA256 ba6c5012b260adf7633f92581279ea582e331343d8c973981aa7de07242bd7f8 SHA512 b12d455bb6dd631056e02a12e996d3bf0b6169f8922011e4b64f979b08d2ab8f405e14947c6f5d26ad18bf2f5764854a84987ae105944515f533fe6b0b4ef7be WHIRLPOOL 7f0ca6f0e684f7d66d7272a89dbeb8fa95e3907f358ec624f5f817311288fdfb6467ec915d0ab9f2eee753fcaee3f4b68f497c2dffcf7a38bdce9a7f97681e2a
+DIST CCfits-2.5.tar.gz 1416358 SHA256 938ecd25239e65f519b8d2b50702416edc723de5f0a5387cceea8c4004a44740 SHA512 63ab4d153063960510cf60651d5c832824cf85f937f84adc5390c7c2fb46eb8e9f5d8cda2554d79d24c7a4f1b6cf0b7a6e20958fb69920b65d7c362c0a5f26b5 WHIRLPOOL 2bd2834d9c113b0dd3cceba381ad186bd13ccfa7184a8b4a314f4b5a8034121481e8ed68fe50dd25484ddce0f0391f884cde6783db72bf9cc61044e540c9d4be
diff --git a/sci-libs/ccfits/ccfits-2.5.ebuild b/sci-libs/ccfits/ccfits-2.5.ebuild
new file mode 100644
index 000000000000..9530618f2c8c
--- /dev/null
+++ b/sci-libs/ccfits/ccfits-2.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+MYPN=CCfits
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="C++ interface for cfitsio"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/fitsio/CCfits/"
+SRC_URI="${HOMEPAGE}/${MYP}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cfitsio-3.080"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYPN}"
+
+DOCS=( CHANGES README.INSTALL )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2-makefile.patch # avoid building cookbook by default and no rpath
+)
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ AT_M4DIR=config/m4 eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install () {
+ if use doc; then
+ DOCS+=( *.pdf )
+ HTML_DOCS=( html/. )
+ fi
+ default
+ use static-libs || prune_libtool_files --all
+}
diff --git a/sci-libs/ccfits/metadata.xml b/sci-libs/ccfits/metadata.xml
index a328d442c418..e4f684da7916 100644
--- a/sci-libs/ccfits/metadata.xml
+++ b/sci-libs/ccfits/metadata.xml
@@ -1,15 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
- </maintainer>
- <longdescription lang="en">
- CCfits is an object oriented interface to the cfitsio library. It is
- designed to make the capabilities of cfitsio available to
- programmers working in C++. It is written in ANSI C++ and
- implemented using the C++ Standard Library with namespaces,
- exception handling, and member template functions.
-</longdescription>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ CCfits is an object oriented interface to the cfitsio library. It is
+ designed to make the capabilities of cfitsio available to
+ programmers working in C++. It is written in ANSI C++ and
+ implemented using the C++ Standard Library with namespaces,
+ exception handling, and member template functions.
+ </longdescription>
</pkgmetadata>