summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/cfitsio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/cfitsio')
-rw-r--r--sci-libs/cfitsio/Manifest1
-rw-r--r--sci-libs/cfitsio/cfitsio-3.360.ebuild57
-rw-r--r--sci-libs/cfitsio/metadata.xml18
3 files changed, 76 insertions, 0 deletions
diff --git a/sci-libs/cfitsio/Manifest b/sci-libs/cfitsio/Manifest
new file mode 100644
index 000000000000..00ace0279414
--- /dev/null
+++ b/sci-libs/cfitsio/Manifest
@@ -0,0 +1 @@
+DIST cfitsio-3.360.tar.gz 4104894 SHA256 b5fb209583c76a0bcc39808e55ebf2417b9c26114c59db1a3f49ea1ede5fa95d SHA512 158819b4a3a29c29a5f017283e2b20067420994e881d202dbf3ba199c9e564dc1e74f8be5ce84f78107126d2a8688cc55cc7ed284540ca647e44cdc3b0b02072 WHIRLPOOL 05589a27c6fa83a0240b26924954c1c6d25d985ad609dfbd37fccfe5758fd28efbd97a5ec289803053e2f53e053e51c017292845de1b4368bcd1725fa2eccdb7
diff --git a/sci-libs/cfitsio/cfitsio-3.360.ebuild b/sci-libs/cfitsio/cfitsio-3.360.ebuild
new file mode 100644
index 000000000000..23165576aa16
--- /dev/null
+++ b/sci-libs/cfitsio/cfitsio-3.360.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit autotools-utils fortran-2
+
+DESCRIPTION="C and Fortran library for manipulating FITS files"
+HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/1"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="doc examples fortran static-libs +tools threads"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ fortran? ( dev-lang/cfortran )"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ # avoid internal cfortran
+ if use fortran; then
+ mv cfortran.h cfortran.h.disabled
+ ln -s "${EPREFIX}"/usr/include/cfortran.h . || die
+ fi
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable fortran)
+ $(use_enable threads)
+ $(use_enable tools)
+ )
+ autotools-utils_src_configure
+}
+
+src_install () {
+ autotools-utils_src_install
+ dodoc README* Changes* docs/changes.txt docs/cfitsio.doc
+ use fortran && dodoc docs/fitsio.doc
+ use doc && dodoc docs/{quick,cfitsio,fpackguide}.pdf
+ use doc && use fortran && dodoc docs/fitsio.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins cookbook.c testprog.c speed.c smem.c
+ use fortran && doins cookbook.f testf77.f
+ fi
+}
diff --git a/sci-libs/cfitsio/metadata.xml b/sci-libs/cfitsio/metadata.xml
new file mode 100644
index 000000000000..3a1d7eeeb433
--- /dev/null
+++ b/sci-libs/cfitsio/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-astronomy</herd>
+ <longdescription lang="en">
+ CFITSIO is a library of C and Fortran subroutines for reading and
+ writing data files in FITS (Flexible Image Transport System) data
+ format. CFITSIO provides simple high-level routines for reading and
+ writing FITS files that insulate the programmer from the internal
+ complexities of the FITS format. CFITSIO also provides advanced
+ features for manipulating and filtering the information in FITS
+ files.
+</longdescription>
+ <use>
+ <flag name="tools">Build execs fpack, funpack, imcopy, fitscopy, listhead
+ </flag>
+ </use>
+</pkgmetadata>