summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/cgnslib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/cgnslib')
-rw-r--r--sci-libs/cgnslib/Manifest1
-rw-r--r--sci-libs/cgnslib/cgnslib-3.2.1.ebuild49
-rw-r--r--sci-libs/cgnslib/files/cgnslib-3.2.1-cmake.patch149
-rw-r--r--sci-libs/cgnslib/metadata.xml14
4 files changed, 213 insertions, 0 deletions
diff --git a/sci-libs/cgnslib/Manifest b/sci-libs/cgnslib/Manifest
new file mode 100644
index 000000000000..624bc849a872
--- /dev/null
+++ b/sci-libs/cgnslib/Manifest
@@ -0,0 +1 @@
+DIST cgnslib_3.2.1.tar.gz 865223 SHA256 34306316f04dbf6484343a4bc611b3bf912ac7dbc3c13b581defdaebbf6c1fc3 SHA512 318fda24e7f5f20407c6026ad4b10a84a0ea02a04d3dab3e0e2277d21cbc1b43f04eb65c4b912a7964e1219cf83afdabb357d25b40e76add9bed8bd2564a674e WHIRLPOOL 5f49f3e19712da5b178f7e40deb024a3287835613d61a46e2b7cb24fa4c9253dd87499b0e34a024945ced686b3a0d5c62ffbde88070f4d204d19f0651f8545f1
diff --git a/sci-libs/cgnslib/cgnslib-3.2.1.ebuild b/sci-libs/cgnslib/cgnslib-3.2.1.ebuild
new file mode 100644
index 000000000000..287aca7a934d
--- /dev/null
+++ b/sci-libs/cgnslib/cgnslib-3.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+FORTRAN_NEEDED="fortran"
+
+inherit cmake-utils fortran-2 versionator
+
+MY_P="${PN}_$(replace_version_separator 3 '-')"
+MY_S="${PN}_$(get_version_component_range 1-2)"
+
+DESCRIPTION="The CFD General Notation System (CGNS) is a standard for CFD data"
+HOMEPAGE="http://www.cgns.org/"
+SRC_URI="mirror://sourceforge/project/cgns/${MY_S}/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fortran hdf5 legacy mpi szip zlib"
+
+DEPEND="
+ hdf5? ( >=sci-libs/hdf5-1.8[mpi=] )
+ szip? ( sci-libs/szip )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}_${PV}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake.patch
+)
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCGNS_ENABLE_64BIT=ON
+ $(usex x86 -DCGNS_ENABLE_LFS=ON)
+ $(cmake-utils_use fortran CGNS_ENABLE_FORTRAN)
+ $(cmake-utils_use hdf5 CGNS_ENABLE_HDF5)
+ $(cmake-utils_use legacy CGNS_ENABLE_LEGACY)
+ $(cmake-utils_use mpi HDF5_NEED_MPI)
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-libs/cgnslib/files/cgnslib-3.2.1-cmake.patch b/sci-libs/cgnslib/files/cgnslib-3.2.1-cmake.patch
new file mode 100644
index 000000000000..bf8ea5f2bfeb
--- /dev/null
+++ b/sci-libs/cgnslib/files/cgnslib-3.2.1-cmake.patch
@@ -0,0 +1,149 @@
+ CMakeLists.txt | 20 +--------------
+ src/CMakeLists.txt | 72 +++++++++++++++++++++++++++---------------------------
+ 2 files changed, 37 insertions(+), 55 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d9c1b3c..d4c2bf7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -81,7 +81,7 @@ if (CGNS_ENABLE_LFS)
+ if (HAVE_OPEN64)
+ add_definitions(-DHAVE_LSEEK64)
+ endif (HAVE_OPEN64)
+- if (HAVE_OPEN64)
++ if (HAVE_LSEEK64)
+ add_definitions(-DHAVE_LSEEK64)
+ endif (HAVE_LSEEK64)
+ endif (WIN32)
+@@ -254,24 +254,6 @@ else (CGNS_ENABLE_HDF5 AND HDF5_NEED_MPI)
+ mark_as_advanced(FORCE CGNS_ENABLE_PARALLEL)
+ endif (CGNS_ENABLE_HDF5 AND HDF5_NEED_MPI)
+
+-####################
+-# RPATH Management #
+-####################
+-
+-# use, i.e. don't skip the full RPATH for the build tree
+-set(CMAKE_SKIP_BUILD_RPATH FALSE)
+-
+-# when building, don't use the install RPATH already
+-# (but later on when installing)
+-set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+-
+-# the RPATH to be used when installing
+-set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
+-
+-# add the automatically determined parts of the RPATH
+-# which point to directories outside the build tree to the install RPATH
+-set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+-
+ ########
+ # CGNS #
+ ########
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 3c12c6d..694da42 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -69,7 +69,7 @@ set(SYSCFLAGS "")
+ set(CFGFLAGS "")
+ set(LIBS "")
+
+-file(TO_NATIVE_PATH ${CMAKE_INSTALL_PREFIX}/lib LIBDIR)
++file(TO_NATIVE_PATH ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX} LIBDIR)
+ file(TO_NATIVE_PATH ${CMAKE_INSTALL_PREFIX}/include INCLUDEDIR)
+ file(TO_NATIVE_PATH ${CMAKE_C_COMPILER} CC)
+ if (WIN32)
+@@ -102,42 +102,42 @@ set(ZLIBLIB "")
+ set(MPIINC "")
+ set(MPILIBS "")
+
+-macro(native_paths INPUT_PATH_VARIABLE RESULT_VARIABLE)
+- set(${RESULT_VARIABLE} "")
+- foreach(PATH ${${INPUT_PATH_VARIABLE}})
+- file(TO_NATIVE_PATH ${PATH} NATIVE_PATH)
+- list(APPEND ${RESULT_VARIABLE} ${NATIVE_PATH})
+- endforeach(PATH ${${INPUT_PATH_VARIABLE}})
+-endmacro(native_paths)
++macro(native_paths INPUT_PATH_VARIABLE RESULT_VARIABLE)
++ set(${RESULT_VARIABLE} "")
++ foreach(PATH ${${INPUT_PATH_VARIABLE}})
++ file(TO_NATIVE_PATH ${PATH} NATIVE_PATH)
++ list(APPEND ${RESULT_VARIABLE} ${NATIVE_PATH})
++ endforeach(PATH ${${INPUT_PATH_VARIABLE}})
++endmacro(native_paths)
+
+ if (CGNS_ENABLE_HDF5)
+ set(BUILDHDF5 1)
+- if (HDF5_INCLUDE_PATH)
+- native_paths(HDF5_INCLUDE_PATH HDF5INC)
+- endif (HDF5_INCLUDE_PATH)
+- if (HDF5_LIBRARY)
+- native_paths(HDF5_LIBRARY HDF5LIB)
+- endif (HDF5_LIBRARY)
+- if (HDF5_NEED_SZIP)
+- set(H5NEEDSZIP 1)
+- if (SZIP_LIBRARY)
+- native_paths(SZIP_LIBRARY SZIPLIB)
+- endif (SZIP_LIBRARY)
+- endif (HDF5_NEED_SZIP)
+- if (HDF5_NEED_ZLIB)
+- set(H5NEEDZLIB 1)
+- if (ZLIB_LIBRARY)
+- native_paths(${ZLIB_LIBRARY} ZLIBLIB)
+- endif (ZLIB_LIBRARY)
+- endif (HDF5_NEED_ZLIB)
+- if (HDF5_NEED_MPI)
+- set(H5NEEDMPI 1)
+- if (MPI_INC)
+- native_paths(MPI_INC MPIINC)
+- endif (MPI_INC)
+- if (MPI_LIBS)
+- native_paths(MPI_LIBS MPILIBS)
+- endif (MPI_LIBS)
++ if (HDF5_INCLUDE_PATH)
++ native_paths(HDF5_INCLUDE_PATH HDF5INC)
++ endif (HDF5_INCLUDE_PATH)
++ if (HDF5_LIBRARY)
++ native_paths(HDF5_LIBRARY HDF5LIB)
++ endif (HDF5_LIBRARY)
++ if (HDF5_NEED_SZIP)
++ set(H5NEEDSZIP 1)
++ if (SZIP_LIBRARY)
++ native_paths(SZIP_LIBRARY SZIPLIB)
++ endif (SZIP_LIBRARY)
++ endif (HDF5_NEED_SZIP)
++ if (HDF5_NEED_ZLIB)
++ set(H5NEEDZLIB 1)
++ if (ZLIB_LIBRARY)
++ native_paths(${ZLIB_LIBRARY} ZLIBLIB)
++ endif (ZLIB_LIBRARY)
++ endif (HDF5_NEED_ZLIB)
++ if (HDF5_NEED_MPI)
++ set(H5NEEDMPI 1)
++ if (MPI_INC)
++ native_paths(MPI_INC MPIINC)
++ endif (MPI_INC)
++ if (MPI_LIBS)
++ native_paths(MPI_LIBS MPILIBS)
++ endif (MPI_LIBS)
+ if (CGNS_ENABLE_PARALLEL)
+ set(BUILDPARALLEL 1)
+ endif (CGNS_ENABLE_PARALLEL)
+@@ -251,7 +251,7 @@ if(CGNS_BUILD_SHARED)
+ endif(CGNS_BUILD_SHARED)
+
+ # Set the install path of the static library
+-install(TARGETS cgns_static ARCHIVE DESTINATION lib)
++install(TARGETS cgns_static ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ # Set the install path of the shared library
+ if(CGNS_BUILD_SHARED)
+ # for windows, need to install both cgnsdll.dll and cgnsdll.lib
+@@ -259,7 +259,7 @@ if(CGNS_BUILD_SHARED)
+ install(TARGETS cgns_shared ARCHIVE DESTINATION lib)
+ install(TARGETS cgns_shared RUNTIME DESTINATION lib)
+ else (WIN32 OR CYGWIN)
+- install(TARGETS cgns_shared LIBRARY DESTINATION lib)
++ install(TARGETS cgns_shared LIBRARY DESTINATION lib${LIB_SUFFIX})
+ endif (WIN32 OR CYGWIN)
+ endif(CGNS_BUILD_SHARED)
+
diff --git a/sci-libs/cgnslib/metadata.xml b/sci-libs/cgnslib/metadata.xml
new file mode 100644
index 000000000000..993590617a99
--- /dev/null
+++ b/sci-libs/cgnslib/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <use>
+ <flag name="legacy">Enable or disable building legacy code (3.0 compatible)</flag>
+ </use>
+ <maintainer>
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cgns</remote-id>
+ </upstream>
+</pkgmetadata>