summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/chemkit/chemkit-0.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/chemkit/chemkit-0.1.ebuild')
-rw-r--r--sci-libs/chemkit/chemkit-0.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sci-libs/chemkit/chemkit-0.1.ebuild b/sci-libs/chemkit/chemkit-0.1.ebuild
new file mode 100644
index 000000000000..89820e28d923
--- /dev/null
+++ b/sci-libs/chemkit/chemkit-0.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils multilib python-single-r1 virtualx
+
+DESCRIPTION="Library for chemistry applications"
+HOMEPAGE="http://www.chemkit.org/"
+SRC_URI="mirror://sourceforge/project/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="applications examples python test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ test? ( applications python )"
+
+RDEPEND="
+ dev-libs/boost
+ dev-cpp/eigen:3
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ media-libs/glu
+ examples? (
+ x11-libs/libX11
+ x11-libs/libXext
+ )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-multilib.patch
+ )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCHEMKIT_BUILD_PLUGIN_BABEL=on
+ $(cmake-utils_use applications CHEMKIT_BUILD_APPS)
+ $(cmake-utils_use applications CHEMKIT_BUILD_QT_DESIGNER_PLUGINS)
+ $(cmake-utils_use examples CHEMKIT_BUILD_EXAMPLES)
+ $(cmake-utils_use examples CHEMKIT_BUILD_DEMOS)
+ $(cmake-utils_use python CHEMKIT_BUILD_BINDINGS_PYTHON)
+ $(cmake-utils_use test CHEMKIT_BUILD_TESTS)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ VIRTUALX_COMMAND="cmake-utils_src_test"
+ virtualmake
+}
+
+src_install() {
+ use examples && dobin demos/*-viewer/*-viewer examples/uff-energy/uff-energy
+
+ cmake-utils_src_install
+}