summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-29 14:02:31 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-29 14:02:40 +0000
commitf806a9d8e446c02b00291d1e439b7c7be5d979c1 (patch)
tree60ea74b824015dac947649791c8a6ffe53606fb9 /sci-libs/cifparse-obj
parentsci-libs/cifparse-obj: Add support for gcc-6 (diff)
downloadgentoo-f806a9d8e446c02b00291d1e439b7c7be5d979c1.tar.gz
gentoo-f806a9d8e446c02b00291d1e439b7c7be5d979c1.tar.bz2
gentoo-f806a9d8e446c02b00291d1e439b7c7be5d979c1.zip
sci-libs/cifparse-obj: Version Bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/cifparse-obj')
-rw-r--r--sci-libs/cifparse-obj/Manifest1
-rw-r--r--sci-libs/cifparse-obj/cifparse-obj-7.105.ebuild55
-rw-r--r--sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch110
3 files changed, 166 insertions, 0 deletions
diff --git a/sci-libs/cifparse-obj/Manifest b/sci-libs/cifparse-obj/Manifest
index c833b220101f..a68648bf6ecf 100644
--- a/sci-libs/cifparse-obj/Manifest
+++ b/sci-libs/cifparse-obj/Manifest
@@ -1 +1,2 @@
DIST cifparse-obj-v7.025-prod-src.tar.gz 928484 SHA256 f2fd71fc2af0995839d9ee7825403e383209bb45a1bad68c270e5756476a8ef8 SHA512 bf5d6b55592aca8678396eb9819f5bd7bff4d912410590dfb750c9ad85bdcdbd251425c45b67e2db027a8ce8d028b77c91edcc5333279ed1190f6049c01f5cc9 WHIRLPOOL 0bd0376f3ea1d562c9650186dd1b48eef454f8acd0f4c0e074a1fccbbccf6edbef2d3e2dcd92799c1e15f0e0a4f1d32a50aaee0120c06ef846f6c971cede4924
+DIST cifparse-obj-v7.105-prod-src.tar.gz 931151 SHA256 3a0d48d6101fbe5fca4b65c53e5669726979db1a57bccf11ee769a3e40f2a856 SHA512 d626aa055bdd6762eda4b5b04121f37fff3bc09460b12cd6cb80566545d23e5c08a8ad54fa184076932d2cff38aa9d91fa659fbe9a70d4a07b8b1677c28549f4 WHIRLPOOL e1cb2e89916b40ad3094b2c53050869dfee0dbb4f8a4219153bef51a5c90729bda0922103a1d423bba1c6768c1b65c975f43c9f542ba1c333a85207f6fa09e9a
diff --git a/sci-libs/cifparse-obj/cifparse-obj-7.105.ebuild b/sci-libs/cifparse-obj/cifparse-obj-7.105.ebuild
new file mode 100644
index 000000000000..de696526467f
--- /dev/null
+++ b/sci-libs/cifparse-obj/cifparse-obj-7.105.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-v${PV}-prod-src"
+
+DESCRIPTION="Provides an object-oriented application interface to information in mmCIF format"
+HOMEPAGE="http://sw-tools.pdb.org/apps/CIFPARSE-OBJ/index.html"
+SRC_URI="http://sw-tools.pdb.org/apps/CIFPARSE-OBJ/source/${MY_P}.tar.gz"
+
+LICENSE="PDB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${PN}-7.025-gcc5_6.patch
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e "s:^\(CC=\).*:\1$(tc-getCC):g" \
+ -e "s:^\(CCC=\).*:\1$(tc-getCXX):g" \
+ -e "s:^\(F77=\).*:\1${FORTRANC}:g" \
+ -e "s:^\(F77_LINKER=\).*:\1${FORTRANC}:g" \
+ -e "s:-static::g" \
+ -i "${S}"/etc/make.* || die "Failed to fix makefile"
+}
+
+src_compile() {
+ # parallel make fails
+ emake -j1 \
+ C_OPT="${CFLAGS}" \
+ CXX_OPT="${CXXFLAGS}"
+}
+
+src_install() {
+ dolib.a lib/*
+ insinto /usr/include/${PN}
+ doins include/*
+}
diff --git a/sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch b/sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch
new file mode 100644
index 000000000000..1716cd6390a4
--- /dev/null
+++ b/sci-libs/cifparse-obj/files/cifparse-obj-7.105-makefile.patch
@@ -0,0 +1,110 @@
+ etc/make.platform.gnu3 | 14 +++++++-------
+ etc/make.platform.gnu4 | 16 ++++++++--------
+ 2 files changed, 15 insertions(+), 15 deletions(-)
+
+diff --git a/etc/make.platform.gnu3 b/etc/make.platform.gnu3
+index 54b0297..138fa47 100644
+--- a/etc/make.platform.gnu3
++++ b/etc/make.platform.gnu3
+@@ -107,8 +107,8 @@ NON_ANSI_C_FLAG=
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(C_WARNINGS) \
++CFLAGS=$(C_OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(C_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+
+ ## C++ compiler
+@@ -128,14 +128,14 @@ C_PLUS_WARNINGS=$(WARNINGS) $(NO_DEPRECATED)
+ EXT=C
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
++C++FLAGS_NONANSI=$(CXX_OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
+ $(C_PLUS_WARNINGS) $(DEFINES) $(INCLUDES)
+
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+-C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
++C++FLAGS_RELAXED=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
+ $(DEFINES) $(INCLUDES)
+
+ ## Fortran compiler
+@@ -145,7 +145,7 @@ C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+@@ -158,7 +158,7 @@ F77LIBS=
+ STATIC_LINKING=-static
+
+ # Linker flags
+-LDFLAGS=$(ABI) -w $(STATIC_LINKING)
++LDFLAGS=$(ABI) -w $(STATIC_LINKING) $(LD_OPT)
+ LDFLAGS_NO_STATIC=$(ABI) -w
+
+ # Fortran linker
+diff --git a/etc/make.platform.gnu4 b/etc/make.platform.gnu4
+index 6676f35..51681fa 100644
+--- a/etc/make.platform.gnu4
++++ b/etc/make.platform.gnu4
+@@ -107,11 +107,11 @@ NON_ANSI_C_FLAG=
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(DEFINES) $(INCLUDES)
++CFLAGS=$(C_OPT) $(ABI) $(PIC) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(PIC) $(NON_ANSI_C_FLAG) $(DEFINES) $(INCLUDES)
+
+ ## C++ compiler
+-## This part defines C++ compiler information
++
+
+ # C++ compiler executable
+ CCC=g++
+@@ -127,14 +127,14 @@ C_PLUS_WARNINGS=$(WARNINGS) $(NO_DEPRECATED)
+ EXT=C
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
++C++FLAGS_NONANSI=$(CXX_OPT) $(ABI) $(PIC) $(NON_ANSI_C_PLUS_FLAG) \
+ $(C_PLUS_WARNINGS) $(DEFINES) $(INCLUDES)
+
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+-C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
++C++FLAGS_RELAXED=$(CXX_OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
+ $(DEFINES) $(INCLUDES)
+
+ ## Fortran compiler
+@@ -144,7 +144,7 @@ C++FLAGS_RELAXED=$(OPT) $(ABI) $(PIC) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) \
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+@@ -157,7 +157,7 @@ F77LIBS=
+ STATIC_LINKING=-static
+
+ # Linker flags
+-LDFLAGS=$(ABI) -w $(STATIC_LINKING)
++LDFLAGS=$(ABI) -w $(STATIC_LINKING) $(LD_OPT)
+ LDFLAGS_NO_STATIC=$(ABI) -w
+
+ # Fortran linker