summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-12-29 04:01:16 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-12-29 07:01:28 +0000
commit562a051a9a1921760fe10fe25662510bf211d5bb (patch)
treef8505d53a58a733d751fa18a9476d880dee1eae6 /sci-libs/cminpack/cminpack-1.3.5.ebuild
parentsci-astronomy/pal: initial import (diff)
downloadgentoo-562a051a9a1921760fe10fe25662510bf211d5bb.tar.gz
gentoo-562a051a9a1921760fe10fe25662510bf211d5bb.tar.bz2
gentoo-562a051a9a1921760fe10fe25662510bf211d5bb.zip
sci-libs/cminpack: version bump
Added github upstream Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-libs/cminpack/cminpack-1.3.5.ebuild')
-rw-r--r--sci-libs/cminpack/cminpack-1.3.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/cminpack/cminpack-1.3.5.ebuild b/sci-libs/cminpack/cminpack-1.3.5.ebuild
new file mode 100644
index 000000000000..1a46678cae61
--- /dev/null
+++ b/sci-libs/cminpack/cminpack-1.3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="C implementation of the MINPACK nonlinear optimization library"
+HOMEPAGE="http://devernay.free.fr/hacks/cminpack/"
+SRC_URI="https://github.com/devernay/cminpack/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="minpack"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+PATCHES=( "${FILESDIR}"/${P}-underlinking.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMINPACK_LIB_INSTALL_DIR=$(get_libdir)
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_EXAMPLES=$(usex test)
+ )
+ cmake-utils_src_configure
+ use test && export LD_LIBRARY_PATH="${BUILD_DIR}:${LD_LIBRARY_PATH}"
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc readme*
+ use doc && dodoc -r doc/*
+}