summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/colamd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/colamd')
-rw-r--r--sci-libs/colamd/Manifest1
-rw-r--r--sci-libs/colamd/colamd-2.8.0.ebuild21
-rw-r--r--sci-libs/colamd/files/colamd-2.7.1-autotools.patch58
-rw-r--r--sci-libs/colamd/files/colamd-2.7.4-autotools.patch58
-rw-r--r--sci-libs/colamd/metadata.xml15
5 files changed, 153 insertions, 0 deletions
diff --git a/sci-libs/colamd/Manifest b/sci-libs/colamd/Manifest
new file mode 100644
index 000000000000..942bd4abe1ec
--- /dev/null
+++ b/sci-libs/colamd/Manifest
@@ -0,0 +1 @@
+DIST colamd-2.8.0.tar.bz2 304819 SHA256 a744cbf0f41c76fa1dceae9072204f1d2529cba11851db123c3496a2780839e1 SHA512 36b2e50e01ad44f04f084ebcdcfb7d9d1d1712c6f53c8bce9f46ce39edc418aa64b8e67489fb06cb95d86658fd9f9bad89217a5f9f4777181f0f0e9b58c04aee WHIRLPOOL 0551f47a1af8f46a12b26403b71e14b4caa5e72f03f6f7df285aaf69976264b94ac06803b2c459007c5574fb44282ccfc370c9c28885c4f7ba39bb21af8c880f
diff --git a/sci-libs/colamd/colamd-2.8.0.ebuild b/sci-libs/colamd/colamd-2.8.0.ebuild
new file mode 100644
index 000000000000..718e8ad8c4cd
--- /dev/null
+++ b/sci-libs/colamd/colamd-2.8.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Column approximate minimum degree ordering algorithm"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/ccolamd/"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+RDEPEND="sci-libs/suitesparseconfig"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/sci-libs/colamd/files/colamd-2.7.1-autotools.patch b/sci-libs/colamd/files/colamd-2.7.1-autotools.patch
new file mode 100644
index 000000000000..5778d20e2f05
--- /dev/null
+++ b/sci-libs/colamd/files/colamd-2.7.1-autotools.patch
@@ -0,0 +1,58 @@
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,3 @@
++SUBDIRS = Source Demo
++include_HEADERS = $(top_srcdir)/Include/colamd.h
++EXTRA_DIST = README.txt
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,12 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(colamd, 2.7.1, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADER( UFconfig.h )
++AC_OUTPUT(
++ Makefile \
++ Demo/Makefile \
++ Source/Makefile)
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,11 @@
++AM_CFLAGS = -I$(top_builddir)/Include
++lib_LTLIBRARIES = libcolamd.la
++noinst_LTLIBRARIES = libcolamdi.la libcolamdl.la
++
++libcolamdl_la_SOURCES = colamd.c
++libcolamdl_la_CPPFLAGS = -DDLONG
++
++libcolamdi_la_SOURCES = colamd.c
++
++libcolamd_la_SOURCES = colamd_global.c
++libcolamd_la_LIBADD = libcolamdi.la libcolamdl.la
+--- Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Demo/Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,20 @@
++LDADD = $(top_builddir)/Source/libcolamd.la
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++check_PROGRAMS = colamd_example colamd_l_example
++colamd_example_SOURCES = colamd_example.c
++colamd_l_example_SOURCES = colamd_l_example.c
++colamd_l_example_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i > my_$$i.out; \
++ if ! diff $(srcdir)/$$i.out my_$$i.out; then \
++ echo "Testing $$i failed"; \
++ exit 1; \
++ fi \
++ done;
++
++clean-local:
++ rm -f my*.out
diff --git a/sci-libs/colamd/files/colamd-2.7.4-autotools.patch b/sci-libs/colamd/files/colamd-2.7.4-autotools.patch
new file mode 100644
index 000000000000..f58464cd987f
--- /dev/null
+++ b/sci-libs/colamd/files/colamd-2.7.4-autotools.patch
@@ -0,0 +1,58 @@
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,3 @@
++SUBDIRS = Source Demo
++include_HEADERS = $(top_srcdir)/Include/colamd.h
++EXTRA_DIST = README.txt
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,12 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(colamd, 2.7.1, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADER( UFconfig.h )
++AC_OUTPUT(
++ Makefile \
++ Demo/Makefile \
++ Source/Makefile)
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,11 @@
++AM_CFLAGS = -I$(top_srcdir)/Include
++lib_LTLIBRARIES = libcolamd.la
++noinst_LTLIBRARIES = libcolamdi.la libcolamdl.la
++
++libcolamdl_la_SOURCES = colamd.c
++libcolamdl_la_CPPFLAGS = -DDLONG
++
++libcolamdi_la_SOURCES = colamd.c
++
++libcolamd_la_SOURCES = colamd_global.c
++libcolamd_la_LIBADD = libcolamdi.la libcolamdl.la
+--- Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Demo/Makefile.am 2008-01-29 19:06:31.000000000 +0000
+@@ -0,0 +1,20 @@
++LDADD = $(top_builddir)/Source/libcolamd.la
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++check_PROGRAMS = colamd_example colamd_l_example
++colamd_example_SOURCES = colamd_example.c
++colamd_l_example_SOURCES = colamd_l_example.c
++colamd_l_example_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i > my_$$i.out; \
++ if ! diff $(srcdir)/$$i.out my_$$i.out; then \
++ echo "Testing $$i failed"; \
++ exit 1; \
++ fi \
++ done;
++
++clean-local:
++ rm -f my*.out
diff --git a/sci-libs/colamd/metadata.xml b/sci-libs/colamd/metadata.xml
new file mode 100644
index 000000000000..fd01c0c5651a
--- /dev/null
+++ b/sci-libs/colamd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The COLumn Approximate Minimum Degree ordering algorithm
+ computes a permutation vector P such that the LU factorization of A
+ (:,P) tends to be sparser than that of A. The Cholesky factorization
+ of (A (:,P))\'*(A (:,P)) will also tend to be sparser than that of
+ A\'*A. SYMAMD is a symmetric minimum degree ordering method based on
+ COLAMD, available as a MATLAB-callable function. It constructs a
+ matrix M such that M\'*M has the same pattern as A, and then uses
+ COLAMD to compute a column ordering of M.
+</longdescription>
+</pkgmetadata>