summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-23 22:24:24 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-23 22:24:24 -0500
commit1250b1a78a43cce60350d566b8e716669bc237db (patch)
tree2a0050ec44d27a7b3137bf170ed140a4527e8c3c /sci-libs/colpack/colpack-1.0.6.ebuild
parentsci-libs/btf: drop old EAPI (diff)
downloadgentoo-1250b1a78a43cce60350d566b8e716669bc237db.tar.gz
gentoo-1250b1a78a43cce60350d566b8e716669bc237db.tar.bz2
gentoo-1250b1a78a43cce60350d566b8e716669bc237db.zip
sci-libs/colpack: drop old
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'sci-libs/colpack/colpack-1.0.6.ebuild')
-rw-r--r--sci-libs/colpack/colpack-1.0.6.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/sci-libs/colpack/colpack-1.0.6.ebuild b/sci-libs/colpack/colpack-1.0.6.ebuild
deleted file mode 100644
index 14cc481ca736..000000000000
--- a/sci-libs/colpack/colpack-1.0.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs autotools
-
-MYPN=ColPack
-
-DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
-LICENSE="GPL-3 LGPL-3"
-HOMEPAGE="http://www.cscapes.org/coloringpage/software.htm"
-SRC_URI="http://www.cscapes.org/download/${MYPN}/${MYPN}-${PV}.tar.gz"
-
-SLOT="0"
-IUSE="openmp static-libs"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MYPN}-${PV}"
-
-pkg_setup() {
- if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
- ewarn "You are using gcc without OpenMP"
- die "Need an OpenMP capable compiler"
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-flags.patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable openmp) \
- $(use_enable static-libs static)
-}