summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-22 10:13:51 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-22 10:21:13 +0000
commitbc76ed3e0b217950cd928793e7742b9bf2899154 (patch)
treee3d4d8dbdb7a36f71e7b488c8a48a71bcfbb6c65 /sci-libs/cxsparse
parentsci-libs/suitesparseconfig: Add 32bit support (diff)
downloadgentoo-bc76ed3e0b217950cd928793e7742b9bf2899154.tar.gz
gentoo-bc76ed3e0b217950cd928793e7742b9bf2899154.tar.bz2
gentoo-bc76ed3e0b217950cd928793e7742b9bf2899154.zip
sci-libs/cxsparse: Add 32bit support
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/cxsparse')
-rw-r--r--sci-libs/cxsparse/cxsparse-3.1.2.ebuild20
-rw-r--r--sci-libs/cxsparse/metadata.xml10
2 files changed, 21 insertions, 9 deletions
diff --git a/sci-libs/cxsparse/cxsparse-3.1.2.ebuild b/sci-libs/cxsparse/cxsparse-3.1.2.ebuild
index 866f66333108..f3e828931624 100644
--- a/sci-libs/cxsparse/cxsparse-3.1.2.ebuild
+++ b/sci-libs/cxsparse/cxsparse-3.1.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit autotools-utils
+inherit multilib-minimal
DESCRIPTION="Extended sparse matrix package"
HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CXSparse/"
@@ -15,6 +15,18 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
IUSE="static-libs"
-RDEPEND="sci-libs/suitesparseconfig"
+RDEPEND="sci-libs/suitesparseconfig[${MULTILIB_USEDEP}]"
DEPEND="${RDEPEND}
virtual/pkgconfig"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name "*.la" -delete || die
+ fi
+}
diff --git a/sci-libs/cxsparse/metadata.xml b/sci-libs/cxsparse/metadata.xml
index d0d5fedd4eb6..fb290bc72702 100644
--- a/sci-libs/cxsparse/metadata.xml
+++ b/sci-libs/cxsparse/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
-</maintainer>
-<longdescription lang="en">
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription lang="en">
CXSparse is an extended version of CSparse, a sparse matrix package,
with support for double or complex matrices, with int or long
integers.