summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-17 08:10:18 +0000
committerSam James <sam@gentoo.org>2022-05-17 08:11:34 +0000
commit0655625bf64978eb3e9f629e1ba29a49894a155e (patch)
tree0aece22ad9579f0de46baf60287e6c3b6d30d894 /sci-libs/gdal
parentx11-plugins/vicious: keyword 2.5.1 for ~riscv (diff)
downloadgentoo-0655625bf64978eb3e9f629e1ba29a49894a155e.tar.gz
gentoo-0655625bf64978eb3e9f629e1ba29a49894a155e.tar.bz2
gentoo-0655625bf64978eb3e9f629e1ba29a49894a155e.zip
sci-libs/gdal: work around jpeg/png bugs in 3.5.0 for now
Force on jpeg & png for now. It's not ideal but reported both upstream and I lack the gdal internals knowledge to deduce whether the various plugins which depend on each of them are functional (enough?) without each of them. They're both pretty small dependencies and hard to avoid in general, although I accept it's an inconvenience, some of this stuff was fairly expected & unavoidable with the big port to CMake. Bug: https://github.com/OSGeo/gdal/issues/5741 Bug: https://github.com/OSGeo/gdal/issues/5742 Bug: https://bugs.gentoo.org/844751 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/gdal-3.5.0-r3.ebuild (renamed from sci-libs/gdal/gdal-3.5.0-r2.ebuild)6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-libs/gdal/gdal-3.5.0-r2.ebuild b/sci-libs/gdal/gdal-3.5.0-r3.ebuild
index 93225abeab64..42e368935481 100644
--- a/sci-libs/gdal/gdal-3.5.0-r2.ebuild
+++ b/sci-libs/gdal/gdal-3.5.0-r3.ebuild
@@ -15,7 +15,7 @@ SRC_URI+=" test? ( https://download.osgeo.org/${PN}/${PV}/${PN}autotest-${PV}.ta
LICENSE="BSD Info-ZIP MIT"
SLOT="0/31" # subslot is libgdal.so.<SONAME>
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="armadillo +curl cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_ssse3 doc fits geos gif gml hdf5 heif java jpeg2k lzma mysql netcdf odbc ogdi opencl oracle pdf png postgres python spatialite sqlite test webp xls zstd"
+IUSE="armadillo +curl cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse4_1 cpu_flags_x86_ssse3 doc fits geos gif gml hdf5 heif java jpeg jpeg2k lzma mysql netcdf odbc ogdi opencl oracle pdf png postgres python spatialite sqlite test webp xls zstd"
# Tests fail to build in 3.5.0, let's not worry too much yet given
# we're only just porting to CMake. Revisit later.
RESTRICT="!test? ( test ) test"
@@ -42,7 +42,6 @@ DEPEND="dev-libs/expat
dev-libs/libxml2:2
dev-libs/openssl:=
media-libs/tiff
- media-libs/libjpeg-turbo:=
>=sci-libs/libgeotiff-1.5.1-r1:=
>=sci-libs/proj-6.0.0:=
sys-libs/zlib[minizip(+)]
@@ -54,6 +53,7 @@ DEPEND="dev-libs/expat
gml? ( >=dev-libs/xerces-c-3.1 )
heif? ( media-libs/libheif:= )
hdf5? ( >=sci-libs/hdf5-1.6.4:=[szip] )
+ jpeg? ( media-libs/libjpeg-turbo:= )
jpeg2k? ( media-libs/openjpeg:2= )
lzma? ( || (
app-arch/xz-utils
@@ -134,7 +134,7 @@ src_configure() {
-DGDAL_USE_HDFS=OFF
-DGDAL_USE_ICONV=ON # TODO dep
-DGDAL_USE_IDB=OFF
- -DGDAL_USE_JPEG=ON
+ -DGDAL_USE_JPEG=$(usex jpeg)
# https://gdal.org/build_hints.html#jpeg12
# Independent of whether using system libjpeg