summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-09 22:09:59 +0000
committerSam James <sam@gentoo.org>2021-03-09 22:09:59 +0000
commit871d75f47010b9efc658ea04690c18a837c67e1b (patch)
tree4d01d4df36f5dd7325fa331fe207fb0e30ee6d31 /sci-libs/gdal
parentdev-libs/libofx: add link to upstream commits (diff)
downloadgentoo-871d75f47010b9efc658ea04690c18a837c67e1b.tar.gz
gentoo-871d75f47010b9efc658ea04690c18a837c67e1b.tar.bz2
gentoo-871d75f47010b9efc658ea04690c18a837c67e1b.zip
sci-libs/gdal: update libdir patch slightly
* Removed more obsolete libproj logic/checks * Fix json-c too Bug: https://bugs.gentoo.org/696106 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/files/gdal-3.2.1-libdir.patch166
1 files changed, 95 insertions, 71 deletions
diff --git a/sci-libs/gdal/files/gdal-3.2.1-libdir.patch b/sci-libs/gdal/files/gdal-3.2.1-libdir.patch
index 0a6c99b73f11..fcf20dd8bed4 100644
--- a/sci-libs/gdal/files/gdal-3.2.1-libdir.patch
+++ b/sci-libs/gdal/files/gdal-3.2.1-libdir.patch
@@ -1,8 +1,33 @@
https://github.com/OSGeo/gdal/pull/3560
-https://bugs.gentoo.org/696106
---- a/configure.ac
-+++ b/configure.ac
-@@ -1133,11 +1133,11 @@ if test "$with_libz" = "external" -o "$with_libz" = "" -o "$with_libz" = "yes" ;
+
+From fbb2adf5b67741f561036b41ab196c72b5978517 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 9 Mar 2021 21:57:57 +0000
+Subject: [PATCH] Respect --libdir parameter
+
+When searching for various libraries, we want to use
+the libdir passed in to autotools (--libdir)
+to ensure that we find the library
+for the correct ABI.
+
+It is possible that we pick up the wrong
+copy from e.g. /usr/lib/ where a 32-bit
+copy of e.g. zlib exists
+when we're in the middle of a 64-bit build.
+
+Use ${libdir} to ensure we respect
+any preferences/information given and
+search for libraries in the right place.
+
+No behaviour should change here as
+--libdir defaults to 'lib'.
+
+Bug: https://bugs.gentoo.org/696106
+Signed-off-by: Sam James <sam@gentoo.org>
+
+--- a/gdal/configure.ac
++++ b/gdal/configure.ac
+@@ -1121,11 +1121,11 @@ if test "$with_libz" = "external" -o "$with_libz" = "" -o "$with_libz" = "yes" ;
elif test "$with_libz" != "no" -a "$with_libz" != "internal" ; then
@@ -17,7 +42,7 @@ https://bugs.gentoo.org/696106
if test "$LIBZ_SETTING" = "external" ; then
AC_MSG_RESULT([using libz library from $with_libz])
else
-@@ -1178,7 +1178,7 @@ AC_ARG_WITH(libdeflate,
+@@ -1166,7 +1166,7 @@ AC_ARG_WITH(libdeflate,
if test "$with_libdeflate" != "no" ; then
if test "$with_libdeflate" != "" -a "$with_libdeflate" != "yes"; then
@@ -26,7 +51,7 @@ https://bugs.gentoo.org/696106
else
AC_CHECK_LIB(deflate, libdeflate_zlib_decompress, [libdeflate_lib=yes], [libdeflate_lib=no])
fi
-@@ -1209,7 +1209,7 @@ fi
+@@ -1197,7 +1197,7 @@ fi
if test "$LIBDEFLATE_SETTING" = "yes" ; then
if test "$with_libdeflate" != "" -a "$with_libdeflate" != "yes"; then
EXTRA_INCLUDES="-I$with_libdeflate/include $EXTRA_INCLUDES"
@@ -35,7 +60,7 @@ https://bugs.gentoo.org/696106
else
LIBS="-ldeflate $LIBS"
fi
-@@ -1302,7 +1302,7 @@ else
+@@ -1290,7 +1290,7 @@ else
LIBS="-L$with_libtiff -ltiff $LIBS"
EXTRA_INCLUDES="-I$with_libtiff $EXTRA_INCLUDES"
else
@@ -44,7 +69,7 @@ https://bugs.gentoo.org/696106
EXTRA_INCLUDES="-I$with_libtiff/include $EXTRA_INCLUDES"
fi
-@@ -1426,19 +1426,12 @@ else
+@@ -1414,52 +1414,22 @@ else
fi
else
ORIG_LIBS="$LIBS"
@@ -55,21 +80,36 @@ https://bugs.gentoo.org/696106
AC_LANG_POP([C++])
if test "$PROJ_FOUND" = "no"; then
- LIBS="-L$with_proj/lib -lproj $with_proj_extra_lib_for_test $ORIG_LIBS"
++ LIBS="-L$with_proj/${libdir} -lproj $with_proj_extra_lib_for_test $ORIG_LIBS"
+ unset ac_cv_lib_proj_proj_create_from_wkt
+ AC_LANG_PUSH([C++])
+ AC_CHECK_LIB(proj,proj_create_from_wkt,PROJ_FOUND=yes,PROJ_FOUND=no,)
+ AC_LANG_POP([C++])
+ fi
+ if test "$PROJ_FOUND" = "no"; then
+- LIBS="-L$with_proj/lib64 -lproj $with_proj_extra_lib_for_test $ORIG_LIBS"
- unset ac_cv_lib_proj_proj_create_from_wkt
- AC_LANG_PUSH([C++])
- AC_CHECK_LIB(proj,proj_create_from_wkt,PROJ_FOUND=yes,PROJ_FOUND=no,)
- AC_LANG_POP([C++])
- fi
- if test "$PROJ_FOUND" = "no"; then
-- LIBS="-L$with_proj/lib64 -lproj $with_proj_extra_lib_for_test $ORIG_LIBS"
+- LIBS="-L$with_proj/lib -lproj $with_proj_extra_lib_for_test $ORIG_LIBS"
+ LIBS="-L$with_proj/${libdir} -lproj $with_proj_extra_lib_for_test $ORIG_LIBS"
- unset ac_cv_lib_proj_proj_create_from_wkt
AC_LANG_PUSH([C++])
- AC_CHECK_LIB(proj,proj_create_from_wkt,PROJ_FOUND=yes,PROJ_FOUND=no,)
-@@ -1460,22 +1453,6 @@ else
- PROJ_INCLUDE="-DPROJ_RENAME_SYMBOLS"
- fi
- fi
+ AC_CHECK_LIB(proj,internal_proj_create_from_wkt,PROJ_FOUND=yes,PROJ_FOUND=no,)
+ AC_LANG_POP([C++])
+- if test "$PROJ_FOUND" = "no"; then
+- LIBS="-L$with_proj/lib -lproj $with_proj_extra_lib_for_test $ORIG_LIBS"
+- unset ac_cv_lib_proj_internal_proj_create_from_wkt
+- AC_LANG_PUSH([C++])
+- AC_CHECK_LIB(proj,internal_proj_create_from_wkt,PROJ_FOUND=yes,PROJ_FOUND=no,)
+- AC_LANG_POP([C++])
+- fi
+- if test "$PROJ_FOUND" = "yes"; then
+- PROJ_INCLUDE="-DPROJ_RENAME_SYMBOLS"
+- fi
+- fi
- if test "$PROJ_FOUND" = "no"; then
- LIBS="-L$with_proj/lib -linternalproj $with_proj_extra_lib_for_test $ORIG_LIBS"
- AC_LANG_PUSH([C++])
@@ -82,14 +122,10 @@ https://bugs.gentoo.org/696106
- AC_CHECK_LIB(internalproj,internal_proj_create_from_wkt,PROJ_FOUND=yes,PROJ_FOUND=no,)
- AC_LANG_POP([C++])
- fi
-- if test "$PROJ_FOUND" = "yes"; then
-- PROJ_INCLUDE="-DPROJ_RENAME_SYMBOLS"
-- fi
-- fi
- if test "$PROJ_FOUND" = "no"; then
- AC_MSG_ERROR([PROJ 6 symbols not found])
- fi
-@@ -1535,7 +1512,7 @@ elif test "$with_spatialite" = "dlopen"; then
+ if test "$PROJ_FOUND" = "yes"; then
+ PROJ_INCLUDE="-DPROJ_RENAME_SYMBOLS"
+ fi
+@@ -1523,7 +1493,7 @@ elif test "$with_spatialite" = "dlopen"; then
SPATIALITE_SONAME="spatialite.so"
fi
else
@@ -98,7 +134,7 @@ https://bugs.gentoo.org/696106
if test -f "$with_spatialite/include/spatialite.h" -a \
"$SPATIALITE_INIT_FOUND" = "yes"; then
-@@ -1543,7 +1520,7 @@ else
+@@ -1531,7 +1501,7 @@ else
if test "$HAVE_SQLITE3" = "yes"; then
SPATIALITE_INC="-I$with_spatialite/include"
HAVE_SPATIALITE=yes
@@ -107,7 +143,7 @@ https://bugs.gentoo.org/696106
LIBS="$SQLITE3_LDFLAGS $LIBS $SPATIALITE_LIBS"
AC_MSG_RESULT(spatialite enabled)
else
-@@ -1605,10 +1582,10 @@ if test "$with_zstd" = "" -o "$with_zstd" = "yes" ; then
+@@ -1593,10 +1563,10 @@ if test "$with_zstd" = "" -o "$with_zstd" = "yes" ; then
fi
elif test "$with_zstd" != "" -a "$with_zstd" != "no"; then
@@ -120,7 +156,7 @@ https://bugs.gentoo.org/696106
EXTRA_INCLUDES="-I$with_zstd/include $EXTRA_INCLUDES"
else
AC_MSG_ERROR([libzstd not found])
-@@ -1931,20 +1908,20 @@ fi
+@@ -1919,20 +1889,20 @@ fi
# TODO: separate libs for rasters and vectors
if test "$with_grass" != "yes" -a "$with_grass" != "no" ; then
@@ -145,7 +181,7 @@ https://bugs.gentoo.org/696106
fi
GRASS_INCLUDE="-I$with_grass/include"
GRASS_GISBASE="$with_grass"
-@@ -1968,10 +1945,10 @@ elif test "$with_libgrass" = "yes" -o "$with_libgrass" = "" ; then
+@@ -1956,10 +1926,10 @@ elif test "$with_libgrass" = "yes" -o "$with_libgrass" = "" ; then
else
@@ -158,7 +194,7 @@ https://bugs.gentoo.org/696106
GRASS_INCLUDE="-I$with_libgrass -I$with_libgrass/include $EXTRA_INCLUDES"
else
AC_MSG_ERROR([--with-libgrass=$with_grass requested, but libgrass5 not found!])
-@@ -2018,7 +1995,7 @@ dnl Fedora has cfitsio headers in ""/usr/include/cfitsio
+@@ -2006,7 +1976,7 @@ dnl Fedora has cfitsio headers in /usr/include/cfitsio
else
FITS_SETTING=external
@@ -167,7 +203,7 @@ https://bugs.gentoo.org/696106
EXTRA_INCLUDES="-I$with_cfitsio -I$with_cfitsio/include $EXTRA_INCLUDES"
echo "using libcfitsio from $with_cfitsio."
-@@ -2067,7 +2044,7 @@ elif test "$with_pcraster" = "internal" ; then
+@@ -2055,7 +2025,7 @@ elif test "$with_pcraster" = "internal" ; then
else
PCRASTER_SETTING=external
@@ -176,7 +212,7 @@ https://bugs.gentoo.org/696106
EXTRA_INCLUDES="-I$with_pcraster/include $EXTRA_INCLUDES"
echo "using libcsf from $with_pcraster."
-@@ -2118,7 +2095,7 @@ elif test "$with_png" = "internal" ; then
+@@ -2106,7 +2076,7 @@ elif test "$with_png" = "internal" ; then
else
PNG_SETTING=external
@@ -185,7 +221,7 @@ https://bugs.gentoo.org/696106
EXTRA_INCLUDES="-I$with_png -I$with_png/include $EXTRA_INCLUDES"
echo "using libpng from $with_png."
-@@ -2153,7 +2130,7 @@ else
+@@ -2141,7 +2111,7 @@ else
DDS_SETTING=yes
CRUNCHDIR="$with_dds"
@@ -194,7 +230,7 @@ https://bugs.gentoo.org/696106
echo "using libcrunch from $with_dds."
fi
-@@ -2191,7 +2168,7 @@ elif test "$with_gta" = "yes" -o "$with_gta" = "" ; then
+@@ -2179,7 +2149,7 @@ elif test "$with_gta" = "yes" -o "$with_gta" = "" ; then
else
GTA_SETTING=yes
@@ -203,7 +239,7 @@ https://bugs.gentoo.org/696106
EXTRA_INCLUDES="-I$with_gta -I$with_gta/include $EXTRA_INCLUDES"
echo "using libgta from $with_gta."
-@@ -2229,7 +2206,7 @@ elif test "$with_pcidsk" = "" -o "$with_pcidsk" = "yes" -o "$with_pcidsk" = "int
+@@ -2217,7 +2187,7 @@ elif test "$with_pcidsk" = "" -o "$with_pcidsk" = "yes" -o "$with_pcidsk" = "int
else
PCIDSK_SETTING=external
@@ -212,7 +248,7 @@ https://bugs.gentoo.org/696106
PCIDSK_INCLUDE="-I$with_pcidsk/include -I$with_pcidsk/include/pcidsk"
echo "using libpcidsk from $with_pcidsk."
-@@ -2304,10 +2281,10 @@ else
+@@ -2292,10 +2262,10 @@ else
dnl We now require libgeotiff 1.5.0
dnl first check if $with_geotiff/lib has the library:
@@ -225,7 +261,7 @@ https://bugs.gentoo.org/696106
if test -d $with_geotiff/include ; then
EXTRA_INCLUDES="-I$with_geotiff/include $EXTRA_INCLUDES"
fi
-@@ -2379,7 +2356,7 @@ elif test "$with_jpeg" = "internal" ; then
+@@ -2367,7 +2337,7 @@ elif test "$with_jpeg" = "internal" ; then
else
JPEG_SETTING=external
@@ -234,7 +270,7 @@ https://bugs.gentoo.org/696106
EXTRA_INCLUDES="-I$with_jpeg -I$with_jpeg/include $EXTRA_INCLUDES"
echo "using libjpeg from $with_jpeg."
-@@ -2530,7 +2507,7 @@ elif test "$with_gif" = "internal" ; then
+@@ -2518,7 +2488,7 @@ elif test "$with_gif" = "internal" ; then
else
GIF_SETTING=external
@@ -243,7 +279,7 @@ https://bugs.gentoo.org/696106
EXTRA_INCLUDES="-I$with_gif -I$with_gif/include $EXTRA_INCLUDES"
echo "using libgif from $with_gif."
-@@ -2596,10 +2573,10 @@ elif test "$with_ogdi" = "yes" -o "$with_ogdi" = "" ; then
+@@ -2584,10 +2554,10 @@ elif test "$with_ogdi" = "yes" -o "$with_ogdi" = "" ; then
else
@@ -256,7 +292,7 @@ https://bugs.gentoo.org/696106
OGDI_INCLUDE="-I$with_ogdi -I$with_ogdi/include"
echo "using libogdi from $with_ogdi."
-@@ -2609,10 +2586,10 @@ else
+@@ -2597,10 +2567,10 @@ else
fi
else
dnl For backward compatibility. Retry with ogdi31 as a name
@@ -269,7 +305,7 @@ https://bugs.gentoo.org/696106
OGDI_INCLUDE="-I$with_ogdi -I$with_ogdi/include"
echo "using libogdi31 from $with_ogdi."
-@@ -2730,10 +2707,10 @@ elif test "$with_sosi" = "yes" ; then
+@@ -2718,10 +2688,10 @@ elif test "$with_sosi" = "yes" ; then
rm -f testfyba
else
@@ -283,7 +319,7 @@ https://bugs.gentoo.org/696106
SOSI_ENABLED=yes
else
AC_MSG_ERROR([not found.])
-@@ -2794,14 +2771,14 @@ else
+@@ -2782,14 +2752,14 @@ else
AC_ARG_WITH(boost-lib-path,
[ --with-boost-lib-path=ARG Path to boost libraries for mongocxx client],,,)
@@ -303,10 +339,19 @@ https://bugs.gentoo.org/696106
else
AC_MSG_ERROR([not found.])
fi
-diff --git a/frmts/grass/pkg/configure.in b/frmts/grass/pkg/configure.in
-index 25602bd..0765333 100644
---- a/frmts/grass/pkg/configure.in
-+++ b/frmts/grass/pkg/configure.in
+@@ -4770,8 +4740,8 @@ if test "$with_libjson_c" = "external" -o "$with_libjson_c" = "" -o "$with_libjs
+ elif test "$with_libjson_c" = "internal" ; then
+ LIBJSONC_SETTING=internal
+ elif test "$with_libjson_c" != "no"; then
+- LIBS="-L$with_libjson_c/lib $LIBS"
+- AC_CHECK_LIB(json-c,json_object_set_serializer,LIBJSONC_SETTING=external,LIBJSONC_SETTING=internal,-L$with_libjson_c/lib)
++ LIBS="-L$with_libjson_c/${libdir} $LIBS"
++ AC_CHECK_LIB(json-c,json_object_set_serializer,LIBJSONC_SETTING=external,LIBJSONC_SETTING=internal,-L$with_libjson_c/${libdir})
+ else
+ AC_MSG_ERROR([libjson-c (internal or external) is required])
+ fi
+--- a/gdal/frmts/grass/pkg/configure.in
++++ b/gdal/frmts/grass/pkg/configure.in
@@ -99,7 +99,7 @@ else
if $GDAL_CONFIG --autoload > /dev/null 2>&1 ; then
AUTOLOAD_DIR=`$GDAL_CONFIG --autoload`
@@ -350,10 +395,8 @@ index 25602bd..0765333 100644
fi
GRASS_INCLUDE="-I$with_grass/include"
GRASS_GISBASE="$with_grass"
-diff --git a/m4/ax_lib_expat.m4 b/m4/ax_lib_expat.m4
-index d1fb22c..32caf45 100644
---- a/m4/ax_lib_expat.m4
-+++ b/m4/ax_lib_expat.m4
+--- a/gdal/m4/ax_lib_expat.m4
++++ b/gdal/m4/ax_lib_expat.m4
@@ -119,9 +119,9 @@ AC_DEFUN([AX_LIB_EXPAT],
expat_lib_flags="-lexpat"
fi
@@ -366,10 +409,8 @@ index d1fb22c..32caf45 100644
fi
fi
fi
-diff --git a/m4/ax_lib_libkml.m4 b/m4/ax_lib_libkml.m4
-index 16af436..f542c2e 100644
---- a/m4/ax_lib_libkml.m4
-+++ b/m4/ax_lib_libkml.m4
+--- a/gdal/m4/ax_lib_libkml.m4
++++ b/gdal/m4/ax_lib_libkml.m4
@@ -172,7 +172,7 @@ kmldom::KmlFactory* factory = kmldom::KmlFactory::GetFactory();
if test "$libkml_prefix" = "/usr"; then
libkml_lib_flags="-lkmldom -lkmlbase -lkmlengine -lkmlconvenience -lminizip -luriparser"
@@ -379,10 +420,8 @@ index 16af436..f542c2e 100644
fi
run_libkml_test="yes"
elif test "$libkml_requested" = "yes"; then
-diff --git a/m4/ax_lib_xerces.m4 b/m4/ax_lib_xerces.m4
-index fdd0e79..6ef7af0 100644
---- a/m4/ax_lib_xerces.m4
-+++ b/m4/ax_lib_xerces.m4
+--- a/gdal/m4/ax_lib_xerces.m4
++++ b/gdal/m4/ax_lib_xerces.m4
@@ -100,7 +100,7 @@ AC_DEFUN([AX_LIB_XERCES],
if test "$xerces_prefix" = "/usr"; then
xerces_lib_flags="-lxerces-c -lpthread"
@@ -392,18 +431,3 @@ index fdd0e79..6ef7af0 100644
fi
run_xerces_test="yes"
elif test "$xerces_requested" = "yes"; then
-diff --git a/configure.ac b/configure.ac
-index 020b249..ffad6ba 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -4794,8 +4794,8 @@ if test "$with_libjson_c" = "external" -o "$with_libjson_c" = "" -o "$with_libjs
- elif test "$with_libjson_c" = "internal" ; then
- LIBJSONC_SETTING=internal
- elif test "$with_libjson_c" != "no"; then
-- LIBS="-L$with_libjson_c/lib $LIBS"
-- AC_CHECK_LIB(json-c,json_object_set_serializer,LIBJSONC_SETTING=external,LIBJSONC_SETTING=internal,-L$with_libjson_c/lib)
-+ LIBS="-L$with_libjson_c/${libdir} $LIBS"
-+ AC_CHECK_LIB(json-c,json_object_set_serializer,LIBJSONC_SETTING=external,LIBJSONC_SETTING=internal,-L$with_libjson_c/${libdir})
- else
- AC_MSG_ERROR([libjson-c (internal or external) is required])
- fi