summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-20 18:03:04 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-20 18:06:44 +0100
commit0e930a6532f6df3ce4b097e9e2d72d4dfb036fe4 (patch)
tree62f485f8425e09e7c0ddb77d21ff73cc647c96b6 /sci-libs/getdata/getdata-0.9.0.ebuild
parentsci-libs/getdata: Build correctly for single python (diff)
downloadgentoo-0e930a6532f6df3ce4b097e9e2d72d4dfb036fe4.tar.gz
gentoo-0e930a6532f6df3ce4b097e9e2d72d4dfb036fe4.tar.bz2
gentoo-0e930a6532f6df3ce4b097e9e2d72d4dfb036fe4.zip
sci-libs/getdata: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sci-libs/getdata/getdata-0.9.0.ebuild')
-rw-r--r--sci-libs/getdata/getdata-0.9.0.ebuild95
1 files changed, 95 insertions, 0 deletions
diff --git a/sci-libs/getdata/getdata-0.9.0.ebuild b/sci-libs/getdata/getdata-0.9.0.ebuild
new file mode 100644
index 000000000000..6cd783a0afa0
--- /dev/null
+++ b/sci-libs/getdata/getdata-0.9.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+AUTOTOOLS_AUTORECONF=true
+
+FORTRAN_STANDARD="95"
+FORTRAN_NEEDED=fortran
+
+inherit autotools-utils fortran-2 python-single-r1
+
+DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
+HOMEPAGE="http://getdata.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 debug fortran lzma python perl static-libs"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ python? ( ${PYTHON_DEPS} )
+ perl? ( dev-lang/perl )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-serial-test.patch
+ )
+
+src_configure() {
+ local myeconfargs=()
+ use perl && myeconfargs+=( --with-perl-dir=vendor )
+ myeconfargs+=(
+ --disable-idl
+ --without-libslim
+ --with-libz
+ --docdir="${EPREFIX}/usr/share/doc/${P}"
+ $(use_enable debug)
+ $(use_enable fortran)
+ $(use_enable fortran fortran95)
+ $(use_enable python)
+ $(use_enable perl)
+ $(use_with bzip2 libbz2)
+ $(use_with lzma liblzma)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python; then
+ python_copy_sources
+ building() {
+ cd "${BUILD_DIR}"/bindings/python || die
+ sed "s:-lpython...:$(python_get_LIBS):g" -i Makefile || die
+ emake \
+ PYTHON_VERSION="${EPYTHON#python}" \
+ NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)"
+ }
+ python_foreach_impl building
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use python; then
+ installation() {
+ cd "${BUILD_DIR}"/bindings/python || die
+ emake \
+ DESTDIR="${D}" \
+ PYTHON_VERSION="${EPYTHON#python}" \
+ NUMPY_CPPFLAGS="-I${EPREFIX}$(python_get_sitedir)/numpy/core/include" \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)" \
+ install
+ find \
+ "${ED}/$(python_get_sitedir)" \
+ -type f \( -name "*.a" -o -name "*.la" \) -delete || die
+ }
+ python_foreach_impl installation
+ fi
+}