summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-17 12:51:22 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-17 12:51:22 +0100
commit94345c1d2ab65a14def36d5a781798c6fdf609a1 (patch)
tree634cab92baeee799c88d05386c444ed8f7a23792 /sci-libs/hypre
parentsci-libs/gsl: Remove old (diff)
downloadgentoo-94345c1d2ab65a14def36d5a781798c6fdf609a1.tar.gz
gentoo-94345c1d2ab65a14def36d5a781798c6fdf609a1.tar.bz2
gentoo-94345c1d2ab65a14def36d5a781798c6fdf609a1.zip
sci-libs/hypre: Remove old
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/hypre')
-rw-r--r--sci-libs/hypre/Manifest2
-rw-r--r--sci-libs/hypre/hypre-2.14.0.ebuild107
-rw-r--r--sci-libs/hypre/hypre-2.18.0.ebuild101
-rw-r--r--sci-libs/hypre/metadata.xml1
4 files changed, 0 insertions, 211 deletions
diff --git a/sci-libs/hypre/Manifest b/sci-libs/hypre/Manifest
index 73775a2eb873..fc080f5581bf 100644
--- a/sci-libs/hypre/Manifest
+++ b/sci-libs/hypre/Manifest
@@ -1,3 +1 @@
-DIST hypre-2.14.0.tar.gz 7312329 BLAKE2B 93de48bdd05c383c74fb1b3b25ddcd5830be099aa7557262547932e17eba524c25ff69ff94d10f29ffdabfef9c05281fd485a7c9b999141f2488ae4fc0238736 SHA512 c7b59fb7ab1cc906e339fcc00603898e44234a65aa74600f740bc825aa94aa66ff0cbd4bd4b7f339c0d28ff5bd9494f15b57f2017a22348fee14b4e8333f1e6c
-DIST hypre-2.18.0.tar.gz 5698227 BLAKE2B e6562b78dcff6592a7df86d2162e3669c9ea3f71cc8926402038da319cb6c1b801a7ac5e44612ba86762ccdd63ae30cd2976451368309622b46e67a7a7dc1d83 SHA512 41292d590285703b5fb91c767fc9d064e36911f09583a81a3da9f2b5524143b23bb1beba3449d759e3f681760d9ad155072e1762d7d6bbe0e65660d5b16c472a
DIST hypre-2.18.2.tar.gz 5699792 BLAKE2B 6adb343d23594adea60a4009f589285236365a5769b1d5cb66908ce83984dd48b3be929e6c7298c7b9cb1e2d67b1fe7ea641c8a160562d223edb9809977fb684 SHA512 7b343a5c8530d7f5e31cad6c940c2f154b2b954566d4fe8525d690fec41db23936a46fb642a994791de32984e696c624804fb1fde1f0c9ce026f1a6e46b9c0f4
diff --git a/sci-libs/hypre/hypre-2.14.0.ebuild b/sci-libs/hypre/hypre-2.14.0.ebuild
deleted file mode 100644
index a7d775a6c575..000000000000
--- a/sci-libs/hypre/hypre-2.14.0.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED=fortran
-
-inherit cmake-utils fortran-2 toolchain-funcs flag-o-matic
-
-DESCRIPTION="Parallel matrix preconditioners library"
-HOMEPAGE="https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods"
-SRC_URI="https://github.com/LLNL/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc examples fei fortran int64 openmp mpi"
-
-RDEPEND="
- sci-libs/superlu:=
- virtual/blas
- virtual/lapack
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( CHANGELOG COPYRIGHT README )
-
-# 2.11.1: fei and mli wrappers still buggy with big integers
-REQUIRED_USE="int64? ( !fei )"
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] &&\
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && tc-check-openmp
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && \
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp ; then
- ewarn "You are using a non capable gcc compiler ( < 4.2 ? )"
- die "Need an OpenMP capable compiler"
- fi
-}
-
-src_prepare() {
- default
- # link with system superlu and propagate LDFLAGS
- sed -e "s:@LIBS@:@LIBS@ $($(tc-getPKG_CONFIG) --libs superlu):" \
- -e 's:_SHARED@:_SHARED@ $(LDFLAGS):g' \
- -i src/config/Makefile.config.in || die
- sed -e '/HYPRE_ARCH/s: = :=:g' \
- -i src/configure || die
- # link with system blas and lapack
- sed -e '/^BLASFILES/d' \
- -e '/^LAPACKFILES/d' \
- -i src/lib/Makefile || die
-}
-
-src_configure() {
- tc-export CC CXX
- append-flags -Dhypre_dgesvd=dgesvd_
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && \
- append-flags -fopenmp && append-ldflags -fopenmp
- use mpi && CC=mpicc FC=mpif77 CXX=mpicxx
-
- cd src
-
- # without-superlu: means do not use bundled one
- econf \
- --enable-shared \
- --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')" \
- --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')" \
- --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')" \
- --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')" \
- --with-timing \
- --without-superlu \
- $(use_enable debug) \
- $(use_enable openmp hopscotch) \
- $(use_enable int64 bigint) \
- $(use_enable fortran) \
- $(use_with fei) \
- $(use_with fei mli) \
- $(use_with openmp) \
- $(use_with mpi MPI)
-}
-
-src_compile() {
- emake -C src
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}/src/lib:${LD_LIBRARY_PATH}" \
- PATH="${S}/src/test:${PATH}" \
- emake -C src check
-}
-
-src_install() {
- emake -C src install \
- HYPRE_INSTALL_DIR="${ED}" \
- HYPRE_LIB_INSTALL="${ED}/usr/$(get_libdir)" \
- HYPRE_INC_INSTALL="${ED}$/usr/include/hypre"
- use doc && dodoc docs/*.pdf
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r src/examples
- fi
-}
diff --git a/sci-libs/hypre/hypre-2.18.0.ebuild b/sci-libs/hypre/hypre-2.18.0.ebuild
deleted file mode 100644
index 7f9dd4cc4b14..000000000000
--- a/sci-libs/hypre/hypre-2.18.0.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED=fortran
-
-inherit cmake-utils fortran-2 toolchain-funcs flag-o-matic
-
-DESCRIPTION="Parallel matrix preconditioners library"
-HOMEPAGE="https://computation.llnl.gov/projects/hypre-scalable-linear-solvers-multigrid-methods"
-SRC_URI="https://github.com/${PN}-space/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug examples fortran int64 openmp mpi"
-
-RDEPEND="
- sci-libs/superlu:=
- virtual/blas
- virtual/lapack
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( CHANGELOG COPYRIGHT README )
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] &&\
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && tc-check-openmp
-}
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != binary ]] && \
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp ; then
- ewarn "You are using a non capable gcc compiler ( < 4.2 ? )"
- die "Need an OpenMP capable compiler"
- fi
-}
-
-src_prepare() {
- default
- # link with system superlu and propagate LDFLAGS
- sed -e "s:@LIBS@:@LIBS@ $($(tc-getPKG_CONFIG) --libs superlu):" \
- -e 's:_SHARED@:_SHARED@ $(LDFLAGS):g' \
- -i src/config/Makefile.config.in || die
- sed -e '/HYPRE_ARCH/s: = :=:g' \
- -i src/configure || die
- # link with system blas and lapack
- sed -e '/^BLASFILES/d' \
- -e '/^LAPACKFILES/d' \
- -i src/lib/Makefile || die
-}
-
-src_configure() {
- tc-export CC CXX
- append-flags -Dhypre_dgesvd=dgesvd_
- use openmp && [[ $(tc-getCC)$ == *gcc* ]] && \
- append-flags -fopenmp && append-ldflags -fopenmp
- use mpi && CC=mpicc FC=mpif77 CXX=mpicxx
-
- cd src
-
- # without-superlu: means do not use bundled one
- econf \
- --enable-shared \
- --with-blas-libs="$($(tc-getPKG_CONFIG) --libs-only-l blas | sed -e 's/-l//g')" \
- --with-blas-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L blas | sed -e 's/-L//g')" \
- --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs-only-l lapack | sed -e 's/-l//g')" \
- --with-lapack-lib-dirs="$($(tc-getPKG_CONFIG) --libs-only-L lapack | sed -e 's/-L//g')" \
- --with-timing \
- --without-superlu \
- $(use_enable debug) \
- $(use_enable openmp hopscotch) \
- $(use_enable int64 bigint) \
- $(use_enable fortran) \
- $(use_with openmp) \
- $(use_with mpi MPI)
-}
-
-src_compile() {
- emake -C src
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}/src/lib:${LD_LIBRARY_PATH}" \
- PATH="${S}/src/test:${PATH}" \
- emake -C src check
-}
-
-src_install() {
- emake -C src install \
- HYPRE_INSTALL_DIR="${ED}" \
- HYPRE_LIB_INSTALL="${ED}/usr/$(get_libdir)" \
- HYPRE_INC_INSTALL="${ED}$/usr/include/hypre"
-
- if use examples; then
- dodoc -r src/examples
- fi
-}
diff --git a/sci-libs/hypre/metadata.xml b/sci-libs/hypre/metadata.xml
index 48b9bd61f1b4..d245803317be 100644
--- a/sci-libs/hypre/metadata.xml
+++ b/sci-libs/hypre/metadata.xml
@@ -14,6 +14,5 @@
</upstream>
<use>
<flag name="int64">Build the 64 bits integer library</flag>
- <flag name="fei">Build the internal Finite Element Interface routines</flag>
</use>
</pkgmetadata>