summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-12-23 15:22:24 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-12-23 15:22:31 +0100
commit1faac3ab322638e63f545d92a102f247c26973f0 (patch)
tree540b30c5f59b48dc6ba2d8fb848940e13bfc5741 /sci-libs/idlcoyote/idlcoyote-20161220.ebuild
parentsys-apps/kexec-tools: Bump to version 2.0.13 (diff)
downloadgentoo-1faac3ab322638e63f545d92a102f247c26973f0.tar.gz
gentoo-1faac3ab322638e63f545d92a102f247c26973f0.tar.bz2
gentoo-1faac3ab322638e63f545d92a102f247c26973f0.zip
sci-libs/idlcoyote: Desymlink
Diffstat (limited to 'sci-libs/idlcoyote/idlcoyote-20161220.ebuild')
-rw-r--r--[l---------]sci-libs/idlcoyote/idlcoyote-20161220.ebuild34
1 files changed, 33 insertions, 1 deletions
diff --git a/sci-libs/idlcoyote/idlcoyote-20161220.ebuild b/sci-libs/idlcoyote/idlcoyote-20161220.ebuild
index 51dbdff20e5c..c7f60d3ff3a0 120000..100644
--- a/sci-libs/idlcoyote/idlcoyote-20161220.ebuild
+++ b/sci-libs/idlcoyote/idlcoyote-20161220.ebuild
@@ -1 +1,33 @@
-idlcoyote-99999999.ebuild \ No newline at end of file
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} != 99999999 ]]; then
+ SRC_URI="http://www.idlcoyote.com/programs/zip_files/coyoteprograms.zip -> ${P}.zip"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/coyote"
+ DEPEND="app-arch/unzip"
+else
+ inherit git-r3
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI=( "git://github.com/idl-coyote/coyote.git" )
+ KEYWORDS=""
+fi
+
+DESCRIPTION="GDL library from D. Fannings IDL courses"
+HOMEPAGE="http://www.idlcoyote.com/"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-lang/gdl"
+
+src_install() {
+ dodoc README.txt
+ rm README.txt || die
+ insinto /usr/share/gnudatalanguage/coyote
+ doins -r *
+}