summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-15 09:40:30 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-15 18:33:36 +0200
commitc07fcf4f202ff3e63f1b26f04f4f408a8f2f70a3 (patch)
treedc7010cafa176a683ed3b2184a32a2a20d3e7053 /sci-libs/ignition-math
parentdev-util/ignition-cmake: bump to 2.2.0 (diff)
downloadgentoo-c07fcf4f202ff3e63f1b26f04f4f408a8f2f70a3.tar.gz
gentoo-c07fcf4f202ff3e63f1b26f04f4f408a8f2f70a3.tar.bz2
gentoo-c07fcf4f202ff3e63f1b26f04f4f408a8f2f70a3.zip
sci-libs/ignition-math: bump to 6.4.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-libs/ignition-math')
-rw-r--r--sci-libs/ignition-math/Manifest1
-rw-r--r--sci-libs/ignition-math/files/includes.patch12
-rw-r--r--sci-libs/ignition-math/ignition-math-6.4.0.ebuild26
3 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/ignition-math/Manifest b/sci-libs/ignition-math/Manifest
index ee43fc826373..101617f61906 100644
--- a/sci-libs/ignition-math/Manifest
+++ b/sci-libs/ignition-math/Manifest
@@ -1 +1,2 @@
DIST ignition-math4_4.0.0.tar.bz2 387717 BLAKE2B 1b19bcd377eb18b616a300e022419ba2651795e04c0f0a3769f565e6febdc1a37f321c81730e1c13c9f9b17f35e6cf558d1129b278b2477ec8d5a5f46b927d66 SHA512 4815c6222945fd228b2d23c9da7ad8876f8ba1fea382312e1eb320819ec5d8bbf637095c18dbe2413184bbea77040bd1a5492ea9427355fc5e62f6169277530e
+DIST ignition-math6_6.4.0.tar.gz 515870 BLAKE2B d975edfa2e23560784adef1d66e7613c822a65bcc8b20d33aa030a570fdf3b19043eb6750e93728f2ff5e8ee14ab047a1420bf9991ea6519ec7399235e262ba1 SHA512 8a6e672ef6de591d25200f288deaaa16cc43e3c90804ee5ead0f06345036afbfa40acb531eb5b6a1fa80bd34c0c5964662cc0659d8bed2c811ad7c776d6f77cb
diff --git a/sci-libs/ignition-math/files/includes.patch b/sci-libs/ignition-math/files/includes.patch
new file mode 100644
index 000000000000..5d7750bcec9a
--- /dev/null
+++ b/sci-libs/ignition-math/files/includes.patch
@@ -0,0 +1,12 @@
+Index: ignition-math6_6.4.0/src/RollingMean.cc
+===================================================================
+--- ignition-math6_6.4.0.orig/src/RollingMean.cc
++++ ignition-math6_6.4.0/src/RollingMean.cc
+@@ -17,6 +17,7 @@
+
+ #include <numeric>
+ #include <deque>
++#include <limits>
+ #include "ignition/math/RollingMean.hh"
+
+ using namespace ignition::math;
diff --git a/sci-libs/ignition-math/ignition-math-6.4.0.ebuild b/sci-libs/ignition-math/ignition-math-6.4.0.ebuild
new file mode 100644
index 000000000000..e4620e3360bb
--- /dev/null
+++ b/sci-libs/ignition-math/ignition-math-6.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+inherit cmake-utils vcs-snapshot
+
+DESCRIPTION="A small, fast, and high performance math library for robot applications"
+HOMEPAGE="https://ignitionrobotics.org/libraries/math"
+SRC_URI="https://github.com/ignitionrobotics/ign-math/archive/${PN}6_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="6/6"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3
+ dev-util/ignition-cmake:2"
+BDEPEND="
+ dev-util/ignition-cmake:2"
+
+S="${WORKDIR}/${PN}6_${PV}"
+PATCHES=( "${FILESDIR}/includes.patch" )