summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 15:51:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 15:53:27 +0100
commit24be6f057de13d62eed1567a4deeb548f538a3d3 (patch)
treefc067ab531a8aa463d1afbece478524b71e35b34 /sci-libs/indilib/indilib-1.8.3.ebuild
parentprofiles: x86: Stable-mask kde-apps/kget[bittorrent] (diff)
downloadgentoo-24be6f057de13d62eed1567a4deeb548f538a3d3.tar.gz
gentoo-24be6f057de13d62eed1567a4deeb548f538a3d3.tar.bz2
gentoo-24be6f057de13d62eed1567a4deeb548f538a3d3.zip
sci-libs/indilib: 1.8.3 version bump
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/indilib/indilib-1.8.3.ebuild')
-rw-r--r--sci-libs/indilib/indilib-1.8.3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-libs/indilib/indilib-1.8.3.ebuild b/sci-libs/indilib/indilib-1.8.3.ebuild
new file mode 100644
index 000000000000..c0ffca05006a
--- /dev/null
+++ b/sci-libs/indilib/indilib-1.8.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake udev
+
+DESCRIPTION="INDI Astronomical Control Protocol library"
+HOMEPAGE="https://www.indilib.org/"
+SRC_URI="https://github.com/${PN}/${PN/lib/}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+ LGPL-2+ LGPL-2.1+"
+SLOT="0/1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="ogg test websocket"
+
+RDEPEND="
+ net-misc/curl
+ sci-libs/cfitsio:=
+ sci-libs/fftw:3.0=
+ sci-libs/gsl:=
+ sci-libs/libnova:=
+ sys-libs/zlib
+ virtual/jpeg:0
+ virtual/libusb:0
+ ogg? (
+ media-libs/libogg
+ media-libs/libtheora
+ )
+ websocket? ( dev-libs/boost:= )
+"
+DEPEND="${RDEPEND}
+ kernel_linux? ( sys-kernel/linux-headers )
+ test? ( >=dev-cpp/gtest-1.8.0 )
+ websocket? ( dev-cpp/websocketpp )
+"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${P/lib/}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINDI_BUILD_QT5_CLIENT=OFF
+ -DINDI_BUILD_UNITTESTS=$(usex test)
+ -DUDEVRULES_INSTALL_DIR="$(get_udevdir)"/rules.d
+ $(cmake_use_find_package ogg OggTheora)
+ -DINDI_BUILD_WEBSOCKET=$(usex websocket)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}"/test cmake_src_test
+}