summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-09-13 16:15:24 +0800
committerJason Zaman <perfinion@gentoo.org>2019-09-13 21:32:11 +0800
commit9dac95a25986d82f106ad8c6227dd070011d89ac (patch)
treea88178995529ef83610cfb5564d16122a13ad23c /sci-libs/keras-preprocessing
parentsci-libs/keras-applications: bump 1.0.8 (diff)
downloadgentoo-9dac95a25986d82f106ad8c6227dd070011d89ac.tar.gz
gentoo-9dac95a25986d82f106ad8c6227dd070011d89ac.tar.bz2
gentoo-9dac95a25986d82f106ad8c6227dd070011d89ac.zip
sci-libs/keras-preprocessing: bump 1.1.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-libs/keras-preprocessing')
-rw-r--r--sci-libs/keras-preprocessing/Manifest1
-rw-r--r--sci-libs/keras-preprocessing/keras-preprocessing-1.1.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/sci-libs/keras-preprocessing/Manifest b/sci-libs/keras-preprocessing/Manifest
index 06698b535be0..dca1269031b7 100644
--- a/sci-libs/keras-preprocessing/Manifest
+++ b/sci-libs/keras-preprocessing/Manifest
@@ -1 +1,2 @@
DIST keras-preprocessing-1.0.9.tar.gz 46476 BLAKE2B af80a6647bb56f8c4dba93120bc2b70db36d2c6a0e36c3be9a4843e5c36c9ffe50db1cd9396eecd47f6c0595c110825d70d2e6b28a29a0a199b5cfcc499e4440 SHA512 93ef9b294638bfeaea82170b323f08b261a2519f5ee8b9aac7d88e5b32c6486646d91075cea71bfbc27780c8af55125319873361f0431d48b451e574d1e7a400
+DIST keras-preprocessing-1.1.0.tar.gz 50631 BLAKE2B 235a1a7d296684e5405c6472026a53b1930923e74065529ba6921e91bf8849d35c02378f8eeabc4f532a4e25937e8fd8f712a59067c5b358afe10b88e1531fcb SHA512 68c71e82ea2139d3db4142c86a2c404e4d65a9a881f72b07b4ccf28733b93a9e4837f91534a20c3ca5128600d8b885cc8723181d96c9045d5280ad7f84091cbb
diff --git a/sci-libs/keras-preprocessing/keras-preprocessing-1.1.0.ebuild b/sci-libs/keras-preprocessing/keras-preprocessing-1.1.0.ebuild
new file mode 100644
index 000000000000..51974c566595
--- /dev/null
+++ b/sci-libs/keras-preprocessing/keras-preprocessing-1.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python{3_5,3_6,3_7} )
+inherit distutils-r1
+
+DESCRIPTION="Easy data preprocessing and data augmentation for deep learning models"
+HOMEPAGE="https://keras.io/"
+SRC_URI="https://github.com/keras-team/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"