summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/lemon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/lemon')
-rw-r--r--sci-libs/lemon/Manifest1
-rw-r--r--sci-libs/lemon/files/lemon-1.3-as-needed.patch47
-rw-r--r--sci-libs/lemon/files/lemon-1.3-multilib.patch18
-rw-r--r--sci-libs/lemon/lemon-1.3-r2.ebuild82
-rw-r--r--sci-libs/lemon/metadata.xml26
5 files changed, 174 insertions, 0 deletions
diff --git a/sci-libs/lemon/Manifest b/sci-libs/lemon/Manifest
new file mode 100644
index 000000000000..857b08a42c9a
--- /dev/null
+++ b/sci-libs/lemon/Manifest
@@ -0,0 +1 @@
+DIST lemon-1.3.tar.gz 5454290 SHA256 6c190dbb1e17bdb71597e79c409b2e798ffcbdb7d764ea45d6299339b12d3e05 SHA512 f48c14e42e0a463a3d203a05a012fdf635cf09503a5d18e14e64722e9f7f68d7fc223059e0a6a5d118491a473a25196d531e0a6302552f9fb8c121a4ed70af45 WHIRLPOOL 14325b538a27a8d46bc3840fa5687c8d286e7668e06f06c074417db245bc920b90f48825189b0e20858050b26676151a55bdb279bed4a0bccb133d9439435fad
diff --git a/sci-libs/lemon/files/lemon-1.3-as-needed.patch b/sci-libs/lemon/files/lemon-1.3-as-needed.patch
new file mode 100644
index 000000000000..ab205e69a4fa
--- /dev/null
+++ b/sci-libs/lemon/files/lemon-1.3-as-needed.patch
@@ -0,0 +1,47 @@
+ CMakeLists.txt | 4 ++++
+ lemon/CMakeLists.txt | 2 ++
+ 2 files changed, 6 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b06e5c7..fa68aa8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -84,21 +84,25 @@ IF(GLPK_FOUND)
+ SET(LEMON_HAVE_LP TRUE)
+ SET(LEMON_HAVE_MIP TRUE)
+ SET(LEMON_HAVE_GLPK TRUE)
++ SET(LEMON_LP_LIBRARIES ${LEMON_LP_LIBRARIES} ${GLPK_LIBRARIES})
+ ENDIF(GLPK_FOUND)
+ IF(ILOG_FOUND)
+ SET(LEMON_HAVE_LP TRUE)
+ SET(LEMON_HAVE_MIP TRUE)
+ SET(LEMON_HAVE_CPLEX TRUE)
++ SET(LEMON_LP_LIBRARIES ${LEMON_LP_LIBRARIES} ${ILOG_LIBRARIES})
+ ENDIF(ILOG_FOUND)
+ IF(COIN_FOUND)
+ SET(LEMON_HAVE_LP TRUE)
+ SET(LEMON_HAVE_MIP TRUE)
+ SET(LEMON_HAVE_CLP TRUE)
+ SET(LEMON_HAVE_CBC TRUE)
++ SET(LEMON_LP_LIBRARIES ${LEMON_LP_LIBRARIES} ${COIN_LIBRARIES})
+ ENDIF(COIN_FOUND)
+ IF(SOPLEX_FOUND)
+ SET(LEMON_HAVE_LP TRUE)
+ SET(LEMON_HAVE_SOPLEX TRUE)
++ SET(LEMON_LP_LIBRARIES ${LEMON_LP_LIBRARIES} ${COIN_LIBRARIES})
+ ENDIF(SOPLEX_FOUND)
+
+ IF(ILOG_FOUND)
+diff --git a/lemon/CMakeLists.txt b/lemon/CMakeLists.txt
+index 8011833..2487345 100644
+--- a/lemon/CMakeLists.txt
++++ b/lemon/CMakeLists.txt
+@@ -59,6 +59,8 @@ IF(UNIX)
+ SET_TARGET_PROPERTIES(lemon PROPERTIES OUTPUT_NAME emon)
+ ENDIF()
+
++TARGET_LINK_LIBRARIES(lemon ${LEMON_LP_LIBRARIES})
++
+ INSTALL(
+ TARGETS lemon
+ ARCHIVE DESTINATION lib
diff --git a/sci-libs/lemon/files/lemon-1.3-multilib.patch b/sci-libs/lemon/files/lemon-1.3-multilib.patch
new file mode 100644
index 000000000000..ee578d4a0f6a
--- /dev/null
+++ b/sci-libs/lemon/files/lemon-1.3-multilib.patch
@@ -0,0 +1,18 @@
+ lemon/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/lemon/CMakeLists.txt b/lemon/CMakeLists.txt
+index 8011833..0209acf 100644
+--- a/lemon/CMakeLists.txt
++++ b/lemon/CMakeLists.txt
+@@ -61,8 +61,8 @@ ENDIF()
+
+ INSTALL(
+ TARGETS lemon
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION lib${LIB_SUFFIX}
++ LIBRARY DESTINATION lib${LIB_SUFFIX}
+ COMPONENT library
+ )
+
diff --git a/sci-libs/lemon/lemon-1.3-r2.ebuild b/sci-libs/lemon/lemon-1.3-r2.ebuild
new file mode 100644
index 000000000000..5ed924f8dbcc
--- /dev/null
+++ b/sci-libs/lemon/lemon-1.3-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C++ template static library of common data structures and algorithms"
+HOMEPAGE="https://lemon.cs.elte.hu/trac/lemon/"
+SRC_URI="http://lemon.cs.elte.hu/pub/sources/${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+coin doc glpk static-libs test tools"
+
+RDEPEND="
+ glpk? ( sci-mathematics/glpk:= )
+ coin? ( sci-libs/coinor-cbc:= sci-libs/coinor-clp:= )"
+DEPEND="${RDEPEND}
+ doc? (
+ app-text/ghostscript-gpl
+ dev-libs/mathjax
+ app-doc/doxygen )"
+
+REQUIRED_USE="|| ( coin glpk )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-multilib.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+)
+
+src_prepare() {
+ sed -i \
+ -e '/ADD_SUBDIRECTORY(demo)/d' \
+ CMakeLists.txt || die
+
+ use doc || sed -i \
+ -e '/ADD_SUBDIRECTORY(doc)/d' \
+ CMakeLists.txt || die
+
+ use tools || sed -i \
+ -e '/ADD_SUBDIRECTORY(tools)/d' \
+ CMakeLists.txt || die
+
+ use test || sed -i \
+ -e '/ADD_SUBDIRECTORY(test)/d' \
+ CMakeLists.txt || die
+
+ for t in \
+ max_clique \
+ max_flow \
+ graph_utils \
+ random \
+ time_measure \
+ tsp; do
+ sed -i -e "/${t}_test/d" test/CMakeLists.txt || die
+ done
+ sed -i \
+ -e '/ADD_TEST(lp_test lp_test)/d' \
+ -e '/ADD_DEPENDENCIES(check lp_test)/d' \
+ test/CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=TRUE
+ -DCOIN_ROOT_DIR="${EPREFIX}/usr"
+ -DLEMON_DOC_MATHJAX_RELPATH="${EPREFIX}/usr/share/mathjax"
+ $(cmake-utils_use doc LEMON_DOC_SOURCE_BROWSER)
+ $(cmake-utils_use doc LEMON_DOC_USE_MATHJAX)
+ $(cmake-utils_use coin LEMON_ENABLE_COIN)
+ $(cmake-utils_use glpk LEMON_ENABLE_GLPK)
+ )
+ cmake-utils_src_configure
+}
+
+src_test() {
+ emake -C "${BUILD_DIR}" check
+}
diff --git a/sci-libs/lemon/metadata.xml b/sci-libs/lemon/metadata.xml
new file mode 100644
index 000000000000..1a144a87e2f5
--- /dev/null
+++ b/sci-libs/lemon/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>mmokrejs@gmail.com</email>
+ <name>Martin Mokrejs</name>
+</maintainer>
+<longdescription>
+ LEMON stands for Library for Efficient Modeling and Optimization in
+ Networks. It is a C++ template library providing efficient
+ implementations of common data structures and algorithms with focus
+ on combinatorial optimization tasks connected mainly with graphs and
+ networks.
+</longdescription>
+<use>
+ <flag name="coin">Enable the <pkg>coinor-clp</pkg> and
+ <pkg>coinor-cbc</pkg> graph algorithms</flag>
+ <flag name='glpk'>Enable GNU Linear Programming Kit
+ <pkg>sci-mathematics/glpk</pkg> support</flag>
+ <flag name="tools">Build additional tools</flag>
+ <flag name="coin">Enable the <pkg>coinor-clp</pkg> and
+ <pkg>coinor-cbc</pkg> graph algorithms
+ </flag>
+</use>
+</pkgmetadata>