summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/libint/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/libint/files')
-rw-r--r--sci-libs/libint/files/1.1.4-as-needed.patch39
-rw-r--r--sci-libs/libint/files/dont-append-mcpu.patch16
-rw-r--r--sci-libs/libint/files/libint-1.1.6-as-needed.patch77
3 files changed, 132 insertions, 0 deletions
diff --git a/sci-libs/libint/files/1.1.4-as-needed.patch b/sci-libs/libint/files/1.1.4-as-needed.patch
new file mode 100644
index 000000000000..cc87d760b699
--- /dev/null
+++ b/sci-libs/libint/files/1.1.4-as-needed.patch
@@ -0,0 +1,39 @@
+diff --git a/src/lib/libderiv/Makefile.library b/src/lib/libderiv/Makefile.library
+index ee152ef..8debfe8 100644
+--- a/src/lib/libderiv/Makefile.library
++++ b/src/lib/libderiv/Makefile.library
+@@ -23,7 +23,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
+diff --git a/src/lib/libint/Makefile.library b/src/lib/libint/Makefile.library
+index 23e2918..01c4225 100644
+--- a/src/lib/libint/Makefile.library
++++ b/src/lib/libint/Makefile.library
+@@ -41,7 +41,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
+diff --git a/src/lib/libr12/Makefile.library b/src/lib/libr12/Makefile.library
+index 1510807..26d47a4 100644
+--- a/src/lib/libr12/Makefile.library
++++ b/src/lib/libr12/Makefile.library
+@@ -47,7 +47,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
diff --git a/sci-libs/libint/files/dont-append-mcpu.patch b/sci-libs/libint/files/dont-append-mcpu.patch
new file mode 100644
index 000000000000..72b5e437051b
--- /dev/null
+++ b/sci-libs/libint/files/dont-append-mcpu.patch
@@ -0,0 +1,16 @@
+diff -urN libint-1.1.2.orig/configure libint-1.1.2/configure
+--- libint-1.1.2.orig/configure 2003-12-05 13:24:55.000000000 -0800
++++ libint-1.1.2/configure 2005-12-06 03:27:37.000000000 -0800
+@@ -3554,10 +3554,10 @@
+ cpu_arch_option="-mcpu=$target_cpu"
+ fi
+ if test X$GCC = Xyes; then
+- COPTIONS_MISC="$COPTIONS_MISC $cpu_arch_option"
++ COPTIONS_MISC="$COPTIONS_MISC"
+ fi
+ if test X$GXX = Xyes; then
+- CXXOPTIONS_MISC="$CXXOPTIONS_MISC $cpu_arch_option"
++ CXXOPTIONS_MISC="$CXXOPTIONS_MISC"
+ fi
+ echo "$as_me:3562: result: IA-32: $cpu_arch_option" >&5
+ echo "${ECHO_T}IA-32: $cpu_arch_option" >&6
diff --git a/sci-libs/libint/files/libint-1.1.6-as-needed.patch b/sci-libs/libint/files/libint-1.1.6-as-needed.patch
new file mode 100644
index 000000000000..c48505314b39
--- /dev/null
+++ b/sci-libs/libint/files/libint-1.1.6-as-needed.patch
@@ -0,0 +1,77 @@
+ configure.ac | 3 +--
+ src/bin/MakeRules.in | 2 +-
+ src/lib/libderiv/Makefile.library | 2 +-
+ src/lib/libint/Makefile.library | 2 +-
+ src/lib/libr12/Makefile.library | 2 +-
+ 5 files changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index dc86e88..8cc3aac 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -317,12 +317,11 @@ LIBS=$withval
+ echo Using extra libraries: $withval
+ )
+
+-LDFLAGS=
+ LIBDIRS=
+ AC_ARG_WITH(libdirs,
+ [ --with-libdirs Specifies library directories (-Ldir1 -Ldir2).],
+ LIBDIRS=$withval
+-LDFLAGS=$withval
++LDFLAGS="$LDFLAGS $withval"
+ echo Using extra library directories: $withval
+ )
+
+diff --git a/src/bin/MakeRules.in b/src/bin/MakeRules.in
+index 5b90607..8ea5005 100644
+--- a/src/bin/MakeRules.in
++++ b/src/bin/MakeRules.in
+@@ -3,7 +3,7 @@ HAVE_MAKERULES = yes
+
+ BINOBJ = $(BUILD_CSRC:%.c=%.$(OBJSUF)) $(BUILD_CXXSRC:%.cc=%.$(OBJSUF))
+ $(BUILD_BINARY): $(BINOBJ)
+- $(LD) $^ $(LDFLAGS) $(SYSLIBS) -o $@
++ $(LD) $(LDFLAGS) $^ $(SYSLIBS) -o $@
+
+ .PHONY: install install_inc install_target uninstall clean oclean distclean targetclean realclean
+ install::
+diff --git a/src/lib/libderiv/Makefile.library b/src/lib/libderiv/Makefile.library
+index ee152ef..8debfe8 100644
+--- a/src/lib/libderiv/Makefile.library
++++ b/src/lib/libderiv/Makefile.library
+@@ -23,7 +23,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
+diff --git a/src/lib/libint/Makefile.library b/src/lib/libint/Makefile.library
+index 23e2918..01c4225 100644
+--- a/src/lib/libint/Makefile.library
++++ b/src/lib/libint/Makefile.library
+@@ -41,7 +41,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)
+diff --git a/src/lib/libr12/Makefile.library b/src/lib/libr12/Makefile.library
+index 1510807..26d47a4 100644
+--- a/src/lib/libr12/Makefile.library
++++ b/src/lib/libr12/Makefile.library
+@@ -47,7 +47,7 @@ $(TOPDIR)/lib/$(NAME).a: $(LIBOBJ)
+
+ # this is how shared library is made
+ $(TOPDIR)/lib/$(NAME).la: $(LIBOBJ)
+- $(LTLINK) $(CXX) -o $@ $^ $(LTLINKLIBOPTS)
++ $(LTLINK) $(CXX) $(LDFLAGS) -o $@ $^ $(LTLINKLIBOPTS)
+
+ $(TOPDIR)/include/$(NAME)/$(NAME).h: $(NAME).h
+ $(INSTALL) $(INSTALLDIROPT) $(TOPDIR)/include/$(NAME)