summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-01 21:14:25 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-01 21:34:50 +0100
commit8aca469b7b450488c3312fa2183433d9fcf42712 (patch)
tree931fbc5345ec316b75c3b7b7b07c31fee16cc84f /sci-libs/libmuscle/libmuscle-3.7-r3.ebuild
parentdev-cpp/sparsehash: Remove old (diff)
downloadgentoo-8aca469b7b450488c3312fa2183433d9fcf42712.tar.gz
gentoo-8aca469b7b450488c3312fa2183433d9fcf42712.tar.bz2
gentoo-8aca469b7b450488c3312fa2183433d9fcf42712.zip
sci-libs/libmuscle: Modernise to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-libs/libmuscle/libmuscle-3.7-r3.ebuild')
-rw-r--r--sci-libs/libmuscle/libmuscle-3.7-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sci-libs/libmuscle/libmuscle-3.7-r3.ebuild b/sci-libs/libmuscle/libmuscle-3.7-r3.ebuild
new file mode 100644
index 000000000000..d3a8107c1052
--- /dev/null
+++ b/sci-libs/libmuscle/libmuscle-3.7-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for sci-biology/mauve"
+HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
+SRC_URI="mirror://gentoo/${P}-r1.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="!sci-biology/muscle"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-bufferoverflow.patch
+ "${FILESDIR}"/${PN}-3.7-fix-build-system.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # package provides .pc file
+ find "${D}" -name '*.la' -delete || die
+}