summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/liborigin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/liborigin')
-rw-r--r--sci-libs/liborigin/Manifest1
-rw-r--r--sci-libs/liborigin/liborigin-20110829.ebuild54
-rw-r--r--sci-libs/liborigin/metadata.xml8
3 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/liborigin/Manifest b/sci-libs/liborigin/Manifest
new file mode 100644
index 000000000000..d170955c5d88
--- /dev/null
+++ b/sci-libs/liborigin/Manifest
@@ -0,0 +1 @@
+DIST liborigin2-20110829.zip 158364 SHA256 51ebf6de57d2b44cd6f5ab772ed92154eec9598a14a6655967ebcf2d7f8da0a2 SHA512 d0e4013a686fbc61c58b1f39e98aace91978bcadffbb2ef9d32576a3b2f19cc2443d595da2d3ecc19298ec6e29c20717db94e1fda6a64d71f3763841228a01c0 WHIRLPOOL 6828990a46643e7eb838ebda425d2a0d4477945552afe10b18048edaa104b94b43ea428700417c3701251646add3e45a4c4bcd1076b1740e42fa145c816200a2
diff --git a/sci-libs/liborigin/liborigin-20110829.ebuild b/sci-libs/liborigin/liborigin-20110829.ebuild
new file mode 100644
index 000000000000..ba5705dc99ef
--- /dev/null
+++ b/sci-libs/liborigin/liborigin-20110829.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib qt4-r2
+
+DESCRIPTION="Library for reading OriginLab OPJ project files"
+HOMEPAGE="http://soft.proindependent.com/liborigin2/"
+SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${PN}2-${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/boost
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-cpp/tree
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}"/${PN}${SLOT}
+
+src_prepare() {
+ mv liborigin2.pro liborigin.pro || die
+ qt4-r2_src_prepare
+ cat >> liborigin.pro <<-EOF
+ INCLUDEPATH += "${EPREFIX}/usr/include/tree"
+ headers.files = \$\$HEADERS
+ headers.path = "${EPREFIX}/usr/include/liborigin2"
+ target.path = "${EPREFIX}/usr/$(get_libdir)"
+ INSTALLS = target headers
+ EOF
+ # use system one
+ rm -f tree.hh || die
+}
+
+src_compile() {
+ qt4-r2_src_compile
+ if use doc; then
+ cd doc && \
+ doxygen Doxyfile || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ local DOCS="readme FORMAT"
+ use doc && local HTML_DOCS=( doc/html/. )
+ qt4-r2_src_install
+}
diff --git a/sci-libs/liborigin/metadata.xml b/sci-libs/liborigin/metadata.xml
new file mode 100644
index 000000000000..b0d1cf12843c
--- /dev/null
+++ b/sci-libs/liborigin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ A library providing IO for Microcal Origin files.
+ </longdescription>
+</pkgmetadata>