summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 20:38:17 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 23:40:02 +0100
commitd5fd1a6ad2a5373a4ab06b1b8f123091417228ed (patch)
tree243db603a35dc20407c8072911822954b06e6160 /sci-libs/liborigin
parentx11-libs/qwt: add version 6.2.0 (diff)
downloadgentoo-d5fd1a6ad2a5373a4ab06b1b8f123091417228ed.tar.gz
gentoo-d5fd1a6ad2a5373a4ab06b1b8f123091417228ed.tar.bz2
gentoo-d5fd1a6ad2a5373a4ab06b1b8f123091417228ed.zip
sci-libs/liborigin: add new snapshot
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs/liborigin')
-rw-r--r--sci-libs/liborigin/Manifest1
-rw-r--r--sci-libs/liborigin/files/liborigin-3.0.1_p20210828-buildsystem.patch37
-rw-r--r--sci-libs/liborigin/liborigin-3.0.1_p20210828.ebuild55
3 files changed, 93 insertions, 0 deletions
diff --git a/sci-libs/liborigin/Manifest b/sci-libs/liborigin/Manifest
index 3e0b88d860e1..05362459eb68 100644
--- a/sci-libs/liborigin/Manifest
+++ b/sci-libs/liborigin/Manifest
@@ -1 +1,2 @@
DIST liborigin-3.0.1.tar.gz 156842 BLAKE2B 2c88d0419c4c7be1ff6d3aaba1f794fe67174e02e591878c754a32d9b2789bd8594d39f4786d9ac04884b443b528086617a9e1fdbca8815089c8ebb400dd321c SHA512 c3fde3549bce462ea38b961885d6c835aac53db64375645db1d3636eb78396b3353c5bcc9ea3313dac3ffb436de35677ecec6fddb2fcf1eb37eaf6a78e2a31f8
+DIST liborigin-3.0.1_p20210828.tar.gz 156437 BLAKE2B 48713d8854ccd7f46b1aca72bf7b7739af588f08aea32e1d27ff4416ca4fa96a942b19e37fb151f5e7afbd5133d870c305a608e639c620672e683fe805d4f5d1 SHA512 0c9866bef16844102be6ae6e150c927420ca07e6ee50342e9fbd4312f9cd3c476c8d730464b010076f31d7fdcc16bd1133de9ace3a6e5b9b321a231ddab00458
diff --git a/sci-libs/liborigin/files/liborigin-3.0.1_p20210828-buildsystem.patch b/sci-libs/liborigin/files/liborigin-3.0.1_p20210828-buildsystem.patch
new file mode 100644
index 000000000000..a34067aeb1b8
--- /dev/null
+++ b/sci-libs/liborigin/files/liborigin-3.0.1_p20210828-buildsystem.patch
@@ -0,0 +1,37 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a8e5914..8eb13c2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -41,7 +41,6 @@ set (devel-headers
+ OriginObj.h
+ OriginFile.h
+ OriginParser.h
+- tree.hh
+ )
+
+ # allow for installation of individual targets
+@@ -74,11 +73,13 @@ if( "${CMAKE_SOURCE_DIR}" STREQUAL "${PROJECT_SOURCE_DIR}" )
+ SOVERSION ${PROJECT_VERSION_MAJOR}
+ )
+ # Generate a pkg-config file matching this config
+- configure_file( "liborigin.pc.in" "$liborigin.pc" @ONLY )
++ configure_file( "liborigin.pc.in" "liborigin.pc" @ONLY )
+
++ if(ENABLE_TOOLS)
+ # command line util
+ add_executable(opj2dat opj2dat.cpp)
+ target_link_libraries (opj2dat origin_static)
++ endif ()
+
+ include(GNUInstallDirs)
+ # install libraries
+@@ -92,7 +93,9 @@ if( "${CMAKE_SOURCE_DIR}" STREQUAL "${PROJECT_SOURCE_DIR}" )
+ # install pkg-config file
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/liborigin.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ #
++ if(ENABLE_TOOLS)
+ install(TARGETS opj2dat DESTINATION ${CMAKE_INSTALL_BINDIR} OPTIONAL)
++ endif ()
+ # documentation
+ install(FILES COPYING FORMAT README
+ DESTINATION ${CMAKE_INSTALL_DOCDIR}
diff --git a/sci-libs/liborigin/liborigin-3.0.1_p20210828.ebuild b/sci-libs/liborigin/liborigin-3.0.1_p20210828.ebuild
new file mode 100644
index 000000000000..9b2c2bb6e60f
--- /dev/null
+++ b/sci-libs/liborigin/liborigin-3.0.1_p20210828.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+COMMIT="970b90ada051dfa2e80929cde91d052bf28be674"
+
+DESCRIPTION="Library for reading OriginLab OPJ project files"
+HOMEPAGE="https://sourceforge.net/projects/liborigin/ https://github.com/SciDAVis/liborigin/"
+SRC_URI="https://github.com/SciDAVis/liborigin/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-3"
+SLOT="2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc tools"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-cpp/tree
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # add missing header
+ "${FILESDIR}/${PN}-3.0.1-missing-header.patch"
+ # downstream
+ "${FILESDIR}/${P}-buildsystem.patch" # ENABLE_TOOLS, shared link, doc paths
+)
+
+src_prepare() {
+ cmake_src_prepare
+ rm tree.hh || die "failed to remove bundled tree.hh"
+
+ sed -e "/install.*html/s/liborigin/${PF}/" \
+ -i CMakeLists.txt || die "failed to fix htmldoc install path"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DGENERATE_CODE_FOR_LOG=$(usex debug)
+ $(cmake_use_find_package doc Doxygen)
+ -DENABLE_TOOLS=$(usex tools)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
+}